The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Опубликован прототип платформы ALP, идущей на смену SUSE Linux Enterprise

05.10.2022 08:25

Компания SUSE опубликовала первый прототип платформы ALP (Adaptable Linux Platform), позиционируемой как продолжение развития дистрибутива SUSE Linux Enterprise. Ключевым отличием новой системы является разделение базовой основы дистрибутива на две части: урезанную "host OS" для работы поверх оборудования и слой для поддержки приложений, ориентированный на запуск в контейнерах и виртуальных машинах. Сборки подготовлены для архитектуры x86_64.

Идея в том, чтобы в "host OS" развивать минимальное окружение, необходимое для поддержки и управления оборудованием, а все приложения и компоненты пространства пользователя запускать не в смешанном окружении, а в отдельных контейнерах или в виртуальных машинах, выполняемых поверх "host OS" и изолированных друг от друга. Подобная организация позволит пользователям сфокусировать внимание на приложениях и абстрагировать рабочие процессы, отделив их от низкоуровневого системного окружения и оборудования.

В качестве основы для "host OS" задействован продукт SLE Micro, основанный на наработках проекта MicroOS. Для централизованного управления предлагаются системы управления конфигурацией Salt (предустановлена) и Ansible (опция). Для запуска изолированных контейнеров доступны инструментарии Podman и K3s (Kubernetes). Среди системных компонентов, вынесенных в контейнеры, присутствуют yast2, podman, k3s, cockpit, GDM (GNOME Display Manager) и KVM.

Из особенностей системного окружения упоминается использование по умолчанию дискового шифрования (FDE, Full Disk Encryption) с возможностью хранения ключей в TPM. Корневой раздел монтируется в режиме только для чтения и не меняется в процессе работы. В окружении применяется механизм атомарной установки обновлений. В отличие от атомарных обновлений на базе ostree и snap, используемых в Fedora и Ubuntu, в ALP вместо построения отдельных атомарных образов и развёртывания дополнительной инфраструктуры доставки применяются штатный пакетный менеджер и механизм снапшотов в ФС Btrfs.

Основные концепции ALP:

  • Минимизация вмешательства пользователя (zero-touch), подразумевающая автоматизацию основных процессов сопровождения, развёртывания и настройки.
  • Автоматическое поддержание безопасности и нахождения системы в актуальном состоянии (self-updating). Предусмотрен настраиваемый режим автоматической установки обновлений (например, можно включить автоустановку только исправлений критических уязвимостей или вернуться к ручному подтверждения установки обновлений). Для обновления ядра Linux без перезапуска и приостановки работы поддерживаются live-патчи.
  • Автоматическое применение оптимизаций (self-tuning) и поддержание живучести системы (self-healing). Система фиксирует последнее стабильное состояние и после применения обновлений или изменения настроек в случае выявление аномалий, проблем или нарушения поведения автоматически переводится в предыдущее состояние, используя снапшоты Btrfs.
  • Многоверсионный программный стек. Изоляция компонентов в контейнерах позволяет одновременно использовать разные версии инструментов и приложений. Например, можно запускать приложения, использующие в зависимостях разные версии Python, Java и Node.js, разделяя несовместимые между собой зависимости. Базовые зависимости поставляются в форме наборов BCI (Base Container Images). Пользователь может создавать, обновлять и удалять программные стеки не затрагивая другие окружения.

В отличие от SUSE Linux Enterprise развитие ALP изначально ведётся с использованием открытого процесса разработки, при котором промежуточные сборки и результаты тестирования публично доступны всем желающим, что позволяет заинтересованным лицам отслеживать проводимую работу и принимать участие в разработке.

  1. Главная ссылка к новости (https://www.suse.com/c/the-fir...)
  2. OpenNews: Планы в отношении следующего поколения дистрибутива SUSE Linux
  3. OpenNews: Компания SUSE развивает собственную замену CentOS 8, совместимую с RHEL 8.5
  4. OpenNews: Первый выпуск дистрибутива openSUSE Leap Micro
  5. OpenNews: Релиз дистрибутива openSUSE Leap 15.4
  6. OpenNews: Выпуск D-Installer 0.4, нового инсталлятора для openSUSE и SUSE
Лицензия: CC-BY
Тип: Интересно / Программы
Короткая ссылка: https://opennet.ru/57872-suse
Ключевые слова: suse, opensuse, alp
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (140) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (1), 10:09, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • –7 +/
    Почти как у BSD систем с их базовой системой. Только эти виртуалки бы нафиг убрать, лишние абстракции.
     
     
  • 2.4, Аноним (4), 10:13, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +7 +/
    Ты не понимаешь это другое. Базовый слой он не может быть изменен пользователем. Он меняется только вендром.
     
     
  • 3.14, pin (??), 11:07, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +10 +/
    Так бы сразу и сказал - vendor lock-in.
     
     
  • 4.33, Аноним (33), 13:51, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Да например производитель ноутбука может выпустить базовый образ где дрова только на этот ноут. А все остальное доставляется из стора или делаешь контейнер где ставишь всё как обычно, но у контейнера не будет никаких связей с хостовой системой, даже питон скрипт из большой системы не дернуть простым способом. Короче плясок с бубном на многие вечера.
     
     
  • 5.55, Аноним (55), 15:12, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Что мешает производителю прямо сейчас делать для обычных дистрибутивов бинарные драйверы с привязкой к id железа? И без этой хост системы.
     
     
  • 6.57, Аноним (57), 15:14, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    То что у каждого ядра свой аби и апи драйверов?
     
     
  • 7.61, Аноним (55), 15:52, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Что мешает распространять бинарные дрова с конкретным ядром для конкретного железа?
     
     
  • 8.72, Аноним (72), 17:35, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Дорого Лень Это я у тебя бы хотел спросить почему этого не происходит ... текст свёрнут, показать
     
     
  • 9.95, Аноним (95), 22:43, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    А я у тебя хотел спросить, почему с появлением ALP вдруг все захотят вендор Лок ... текст свёрнут, показать
     
     
  • 10.111, Аноним (111), 10:13, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Потому что могут ... текст свёрнут, показать
     
  • 10.145, Аноним (145), 09:28, 15/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Потому, как всегда так делали If you did a ten, you will do again Пример из жи... текст свёрнут, показать
     
  • 5.64, beck (??), 16:22, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Да это ж Андроид!
     
     
  • 6.73, Аноним (72), 17:36, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Единственная нормальная методика дистрибуции Линукс.
     

  • 1.2, Аноним (2), 10:12, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    >Минимизация вмешательства пользователя (zero-touch)

    Так это убивает всю "магию" linux, когда можешь подстроить под себя систему

     
     
  • 2.7, leap42 (ok), 10:33, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • –4 +/
    > Так это убивает всю "магию" linux, когда можешь подстроить под себя систему

    Так настраивайте внутри виртуалок и контейнеров сколько угодно как удобно. А это просто попытка сделать маленький, простой и надёжный хост аля VMware ESX (если я верно понял).

     
     
  • 3.130, Аноним (130), 20:44, 07/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >маленький, простой и надёжный хост

    Как пользователь suse с многолетним стажем, уверенно заявляю: эти ребята так не умеют. И если раньше мелкие огрехи еще были терпимы, то с учетом их последних тенденций сложно представить, какого неповоротливого и глючного монстра они выкатят.

     
  • 2.11, Аноним (-), 10:48, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • –9 +/
    Ну так сиди на старом дистрибутиве до пенсии. Тебя же не заставляют обновляться.
     
  • 2.124, Роман (??), 16:37, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    С выходом из спячки вас.

    Магов в мире мало, фронтенд разработчиков много, магию убивают и делают boring tech с десяток лет если не раньше.

    Кроме сисадминов она и не нужна особо никому, видно по образам Bitnami в AWS например

     
  • 2.143, adolfus (ok), 12:46, 12/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Ту дело не в утере "магии" *nix, а в том, что некоторые проприетарные приложения, интенсивно иcпользующие собственную аллокацию памяти и привилегированные инструкции, из-под контейнера станут работать гораздо медленнее. А некоторые программы из состава электронных сапров, стоящих как мазератти, из-под гипервизора вообще не работают -- им в сетапе нужно отключать виртуализацию.
    Вряд ли сусе эти сраные контейнеры сделает обязательными, скорее всего это будет опция. Возможно включаемая по-умолчанию. Иначе сапры откажутся от сусе, как одной из базовых платформ.
     

  • 1.3, Аноним (4), 10:12, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    В полку Ubuntu Core, Fedora Kinoite, Fedora Silverblue прибыло. Хорошо что есть конкуренция. Хорошо что есть подвижке в заскорузлой архитектуре *nix-ситем. Которую проектировали в 70-х годах из расчета запуска одного  прикладного приложения для расчетов на несколько дней.

    Ну и будет теперь необходимость докупить оперативы обязательно купить SSD на HDD это все будет очень медленно ворочаться.

     
     
  • 2.15, Аноним (2), 11:10, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Настроящий ответ "заскорузлой архитектуре" - это NixOS, но там же думать надо, а не по гайдам с archwiki все настраивать
     
     
  • 3.22, Массоны Рептилоиды (?), 12:00, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +10 +/
    Хрень этот ваш NixOS! Я все по гайдам с archwiki в нём настраивал - ничего не заработало!
     
     
  • 4.43, Аноним (43), 14:28, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Осталось завести баг для арча, что он не никсос.

    Как починят - сразу заработает.

     
  • 3.27, Аноним (4), 12:24, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Вещь в себе прибитая гвоздями, вендорлокнутая. Заточенная под собственную репу. Ну такой.
     
     
  • 4.46, я из фейсбука (?), 14:34, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > Заточенная под собственную репу

    Это как?

     
     
  • 5.58, Аноним (57), 15:16, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Это значить нельзя культурно штатно зайти в магазин приложений снап или флатпак или централизованное хранилища аппимаджей взять себе софтину не привязанную к дистру и запустить в отличии даже от сабжа.
     
     
  • 6.66, Аноним (66), 17:06, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    А оы разрешение не спрашивай и всё будет отлично.
     
  • 6.71, Аноним (2), 17:31, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Про snap не знаю, но flatpak в NixOS прекрасно работает, проверено. А Appimage вообще пофига на устройство дистрибутива. Вот если надо что-то совсем экзотичное руками собрать и поставить, то да ./configure && make && make install уже не прокатит и надо учить ПМ
     
     
  • 7.112, Аноним (111), 10:14, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    ./configure это такой миф ты зависимости сам никогда не соберешь если они в ридми не указаны.
     
  • 3.59, Аноним (59), 15:34, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +5 +/
    >там же думать надо

    Я не хочу думать, я хочу сделать че надо, получить денежку и пойти жить жизнь с семьей. Думать мне есть об чем и без этого.

     
  • 3.147, Самый Лучший Гусь (?), 01:11, 29/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    NixOS это эти же самые гайды с archwiki, только запакованые в nixpkgs. Всё что выходит за его рамки вызывает жжение чуть ниже уровня спины и острое желание съесть свою шляпу. Впрочем, её рамки весьма широки, что не может не вызывать некоторой радости.
     

  • 1.5, Александр (??), 10:14, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Ответ Linux на "DLL hell"?
     
     
  • 2.6, Аноним (1), 10:20, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Не, на это ответом будет nix.
     
     
  • 3.10, Аноним (-), 10:46, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Guix*

    поравил, не благодарите

     
     
  • 4.18, Аноним (18), 11:24, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    И не собирался. Guix без проприетарщины нежизнеспособен.
     
     
  • 5.39, Аноним (39), 14:09, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    А NIX жизнеспособен без фирмварей?
     
     
  • 6.56, Аноним (55), 15:13, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Он жизнеспособен, так как с ними.
     
  • 4.29, Аноним (29), 12:44, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Положняк по NixOS Guix NixOS 8212 для реальных систем Плюсы systemd, allow... большой текст свёрнут, показать
     
     
  • 5.30, Аноним (30), 12:52, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Вам что, даже смузи не помог лисп осилить?
    В Guix используется Scheme.
     
  • 5.60, data man (ok), 15:40, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > №1 по кол-ву пакетов.

    Каких именно? :)
    Repository Total N/u Newest Outdated
    nixpkgs unstable 78559 63758 36780 85.6% 6115 14.2%
    nixpkgs stable 22.05 71676 61907 29390 67.0% 14378 32.8%
    AUR 69025 35010 21315 73.9% 7481 25.9%
    nixpkgs stable 21.11 67337 59030 21002 50.3% 20666 49.5%
    nixpkgs stable 21.05 57298 49580 14295 40.2% 21171 59.6%
    Devuan Unstable 34878 26569 18702 71.8% 6784 26.1%
    Debian Unstable 34868 26569 18710 71.9% 6774 26.0%

    P.S. Льющие на Debian/Devuan - утритесь.

     
     
  • 6.107, Анончик (?), 02:59, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Вы на полном серьезе сравнили с AUR?
    Это че уже каникулы начались?
     
     
  • 7.110, data man (ok), 03:33, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Эт чё, у вас в палате WiFi появился?
     

  • 1.8, ryoken (ok), 10:43, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Туда до полного щасстья не хватает транслятора дял запуска на разных архитектурах. А вообще похоже вроде бы на Qubes OS в смысле загоняния прикладного софта по своим стойлам.
     
  • 1.9, Аноним (-), 10:45, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    Чего только не сделаешь, лишь бы не использовать микроядро с полностью изолированными процессами.
     
  • 1.12, Аноним (12), 10:49, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +6 +/
    Да вы задолбали. То после числа 13 у них идёт 42, а потом 15. То SLES делают поверх openSUSE, то наоборот. А теперь ещё и ALP!

    SUSE 9.1
    SLES 9
    SUSE 9.2
    SUSE 9.3
    SUSE 10.0
    SUSE 10.1
    SLES 10
    openSUSE 10.2
    openSUSE 10.3
    openSUSE 11.0
    openSUSE 11.1
    SLES 11
    openSUSE 11.2
    openSUSE 11.3
    openSUSE 11.4
    openSUSE 12.1
    openSUSE 12.2
    openSUSE 12.3
    openSUSE 13.1
    SLES 12
    openSUSE 13.1
    openSUSE Leap 42.1
    openSUSE Leap 42.2
    openSUSE Leap 42.3
    openSUSE Leap 15.0
    SLES 15
    openSUSE Leap 15.1
    openSUSE Leap 15.2
    openSUSE Leap 15.3
    openSUSE Leap 15.4
    ALP

     
     
  • 2.13, Аноним (13), 10:50, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Ребрендинг - самый простой способ состричь больше капусты.
     
     
  • 3.16, Аноним (12), 11:17, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Скорей бы уже вернулись к KDE3 без всяких там hal/udev/dbus и без systemd/pulseaudio//pipewire/avahi, и SaX2 вернули
     
     
  • 4.19, Аноним42 (?), 11:37, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Думаешь от возвращения софта времен когда у тебя xep стоял он снова стоять будет?
    Это ошибка, чувак, не будет
     
     
  • 5.23, Массоны Рептилоиды (?), 12:13, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Брехня!
    Я когда Damn Small Linux или Frenzy, на худой конец, запускаю - стоит как лавовая лампа!
     
     
  • 6.28, К.О. (?), 12:34, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > на худой конец

    Тонкое замечание

     
     
  • 7.131, Аноним (130), 20:47, 07/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    И короткое.
     
  • 5.25, Аноним (12), 12:20, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ничё, вернут. Вон Интел вернула же пентиум три после провала четвёртого? Вот и суся однажды догадается, почему у неё такие низкие финансовые показатели, хотя до того как они продали *опу ред хату, были высокими
     
  • 4.41, Аноним (39), 14:20, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Без udev, говоришь? Возвращаемся к mknod ручками?
     
  • 3.31, Аноним (31), 13:08, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    скорее, это самый простой способ продолжать зарабатывать при угробленной в ноль репутации. яркие примеры:
    сберкасса, сбербанк, сбер
    яндэкс браузер, вивальди
    mail.ru, vk
     
     
  • 4.87, Аноним (87), 18:24, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > яндэкс браузер, вивальди

    а где здесь ребрендинг? два абсолютно разных продукта

     
  • 3.35, Аноним (35), 13:59, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    о, икспертиза от успешного человека. больше полтоса-то хоть платят в твоих рога-и-ко?
     
  • 2.32, Аноним (32), 13:12, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Да всё в порядке, их просто мозилла кусила в задницу когда они 42 вытащили из ниоткуда, потом через цикл отпустило.
     
     
  • 3.132, Аноним (130), 20:50, 07/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Не, мозилла их так и покусывает с тех пор.
     

  • 1.17, Аноним (17), 11:18, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Всё хорошо, если бы не Btrfs. А использование других ФС данная архитектура, как я понимаю, не предполагает. Приговор: нинужно.
     
     
  • 2.40, torm84 (?), 14:17, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • –3 +/
    А чем оно плохо? Я её уже лет 7 использую и никаких бед не знаю...
     
     
  • 3.133, Аноним (130), 20:51, 07/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    "Я всю жизнь на болоте живу и всем советую!"
     

  • 1.20, кусь (?), 11:40, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    ALPlinux. BaseAlp.
     
     
  • 2.67, pic (?), 17:11, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да хотя бы это сделайте, ад зависимостей надоел уже.
     

  • 1.21, bOOster (ok), 11:47, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • –4 +/
    Молодцы - jail из BSD изобрели, в коем-то веке.
     
     
  • 2.45, Аноним (39), 14:33, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    LXC с шахматами.
     

  • 1.34, Аноним (33), 13:58, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    Вот понадобилось мне давича открыть старый Kicad проект последний Кикад шлёт матом. Что теперь делать надо доставать тот самый старый кикад в котором сделан проект и открывать в нём.

    И что нахожу я тот самый кикад 2007 года выпуска и для Линукса в бинарном виде и для оффтопика. И что толку как не пляши с линуксовым кикадом всех библиотек ты никогда не соберешь и никогда эту фекалию не запустишь.

    А оффтопик версию кикада 2007 года ставишь в виртуалке оффтопик 10 запускаешь установщики Next Next и всё просто работает. 15 лет прошло и всё просто работает. Почему нельзя сделать чтобы всё просто работало в Линуксе хоть контейнерами хоть слоями хоть чем. Какое мне дело до 5 сэкономленных мегабайтах оперативы если я не могу просто взять и запустить приложение?

     
     
  • 2.36, Аноним (35), 14:01, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    не мешай икспертам самолюбоваться
     
  • 2.37, Аноним (33), 14:03, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Кстати в вайне тоже виндовая версия хорошо работает. Где это видано что приложение с другой платформы работает лучше чем нативное приложение?
     
     
  • 3.38, Аноним (33), 14:04, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Держу всех в курсе, если что.
     
     
  • 4.99, Аноним (99), 01:45, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Это однозначно диверсия против линуха от самих разработчиков кикада.
     
  • 3.49, Аноним (43), 14:49, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • –2 +/
    >Кстати в вайне тоже виндовая версия хорошо работает. Где это видано что приложение с другой платформы работает лучше чем нативное приложение?

    Линукс не дружит с закрытыми сорсами, а только с тем, что можно перекомпилировать и пропатчить при необходимости, поэтому программы с закрытыми сорсами протухают там быстрее, чем на Винде, если их не обновлять. Если хочется и закрытые сорсы, и обеспечить поддержку Линукса этой версией ПО на длительный срок, то разработка под Винду с обеспечением работоспособности под Вайном - это весьма популярный вариант.

     
     
  • 4.91, Криптоханыга (?), 18:56, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Давно ли KiCAD стало приложением с закрытыми исходниками?
     
     
  • 5.93, Аноним (43), 21:28, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А в чём тогда проблема найти исходники кикада той версии (или более поздней, поддерживающей нужный формат) и попробовать скомпилировать их на современном Линуксе?

    Далеко не факт, что сработает, конечно, но попробовать можно.

    Хотя виртуалка со старым Линуксом, скорее всего, окажется более простым решением.

     
     
  • 6.98, mikhailnov (ok), 01:16, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Можно даже не пробовать — просто так не скомпилируются. Там wxGTK же.
     
  • 6.100, Аноним (99), 01:48, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    А в чём тогда проблема разработчикам кикада не выкидывать код предыдущих читалок файлов данных? И это не только у кикада такое, фрикад - то же самое, там даже разрабы прямо отвечают, что сохранялка не предназначена для переноса между версиями...
     
     
  • 7.115, Аноним (43), 11:13, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >А в чём тогда проблема разработчикам кикада не выкидывать код предыдущих читалок файлов данных? И это не только у кикада такое, фрикад - то же самое, там даже разрабы прямо отвечают, что сохранялка не предназначена для переноса между версиями...

    Денег же вы им не дали на сохранение этого кода, вот и творят, что хотят :)

    Не пользуйтесь софтом, который не соответствует вашим требованиям - пользуйтесь тем, в котором таких проблем нет. Если такого нет, наймите программистов, чтобы сделать такой, или сделайте сами, если умеете.

     
  • 3.148, Анонимас (?), 11:05, 03/11/2022 [^] [^^] [^^^] [ответить]  
  • +/
    У меня такое было со старыми играми под оффтопик, когда версии для первой мыловарки запускались легче версий для Win95.
     
  • 2.42, Аноним (39), 14:26, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Так надо было самодостаточный пакет собирать, чтоб через 15 лет работало. Да-да, именно, самодостаточный: и графические тулкиты тоже в него, и остальные зависимости.
     
     
  • 3.69, pic (?), 17:18, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    15 лет назад такого не было.
     
     
  • 4.89, Аноним (-), 18:34, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Да ладно, а чо это в слаке до сих пор валяются .a-шки? Может, кто-то прогулял уроки компиляции статических библиотек или не умеет завести ar с нужными объектными файлами, в случае, если тчо пошло не так?
     
  • 2.44, Аноним (43), 14:32, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >И что нахожу я тот самый кикад 2007 года выпуска и для Линукса в бинарном виде и для оффтопика. И что толку как не пляши с линуксовым кикадом всех библиотек ты никогда не соберешь и никогда эту фекалию не запустишь.

    Решается виртуалкой (или Bochsом как-нибудь, если совсем всё печально) с версией дистрибутива, который этот кикад поддерживал.

    Плохое решение, согласен, на Винде с этим гораздо лучше, но таков Linux way.

     
     
  • 3.47, Аноним (47), 14:45, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    У что это за дистрибутив 2007 год у которого работают репозитории до сих пор? Ты сейчас даже репу для Ubuntu 07.04 нигде не найдешь. А доставлять зависимости точно придётся.
     
     
  • 4.50, 1 (??), 14:55, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    В 2007 всё поставлялось на установочных дисках.
     
     
  • 5.52, Аноним (57), 15:01, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    В твоём воображении.
     
  • 5.62, _kp (ok), 15:54, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Верно. И достаточно скачать образы одного из дистрибутива того времени.

    Вот, мне понадобился не так давно Debian3 и 5, RedHat 5.2 на ретрокомпы. В коллекции железок много, зачем одни и те же ОС ставить.
    Скачал диски с полными образами на нескольких СD, поставил без проблем. А установка по сети, конечно, уже не работает.

     
     
  • 6.70, pic (?), 17:19, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Попробуй найди их.
     
  • 6.123, Аноним42 (?), 15:48, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Правда что ли Смотри сюда http archive debian org debian dists potato Это De... большой текст свёрнут, показать
     
     
  • 7.125, _kp (ok), 17:58, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Я то поставил, и тоже отвечал.

    По сети пробовал 5й Дебиан ставить, установился, но дальше пошла каша с зависимостями, чего не было... в начале 2010х. Смонтировал диски, и проблем нет.
    Остальное даже не пытался по сети.

    Конечно нет проблем настроить что угодно, но задача была не настраивать, а по быстрому собрать. Оно мне даже не особо надо было. Попросили на часть моих коллекционных компов поставить ОС и ПО, как было n лет назад, ну а мне не жалко. Сделал.

    Вообще, как у коллекционера у меня и на дисках всё есть, и не экзотические версии дистрибутивов есть все. но сейчас бардак из за пристройки этажа дома и места под железо, и было быстрее скачать, чем специально перерывать коробки.

     
     
  • 8.126, Аноним42 (?), 18:32, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Звучит очень странно Я тут уже в теме упоминал, что я несколько лет назад ставил... текст свёрнут, показать
     
  • 4.51, Аноним (43), 15:00, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >У что это за дистрибутив 2007 год у которого работают репозитории до сих пор? Ты сейчас даже репу для Ubuntu 07.04 нигде не найдешь. А доставлять зависимости точно придётся.

    Тут надо смотреть конкретно каждый случай отдельно, т.е. какие именно зависимости нужны и нужны ли.

    У некоторых дистрибутивов были коллекции образов со всеми пакетами, то есть там можно обойтись без репозиториев вообще.

     
     
  • 5.53, Аноним (57), 15:02, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Вот именно поэтому это и плохо и да с этим надо что-то делать.  И я не знаю что. Что-то есть, а чего-то нет. Надеюсь сабж поможет это все решить в будущем.
     
  • 4.63, _kp (ok), 16:17, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >>Ubuntu 07.04 нигде не найдешь

    https://old-releases.ubuntu.com/releases/7.04

    Скачиваете целиком, и балуйтесь на здоровье

     
     
  • 5.75, Аноним (72), 17:38, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Конченый? Нужен репозиторий, а не дистрибутив.
     
     
  • 6.79, _kp (ok), 18:07, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    И чем не угодил локальный репозиторий с дисков? Мало установочного диска, так скачайте оба. Вряд ли их тогда больше было.

    На установочных дисках не один setup.exe на весь диск, а части репозитория. Это ж Linux. :)

    Речь была о запуске старого ПО.
    Для этого достаточно просто старой ОС.

    Вы с целями определитесь. Что нужно получить в итоге? Нужны какие то пакеты? Исходники пакетов? Пофилософствовать?

     
     
  • 7.88, Аноним (88), 18:26, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    >И чем не угодил локальный репозиторий с дисков?

    Вафель Лапкин не привык к мейкфайлам и сорцам на диске, ему cargo подавай.

    >Что нужно получить в итоге?

    Большую кнопку "Зделать замечательно", а за ней мастер с кнопочками "Далее", "Далее", "Далее" и "Готово". А ваши многочисленные свитчи в манах прогресс не интересуют, прогресс - это когда после 3.2* идёт 4.0, а фич меньше, чем в 1.2. Зато крупные элементы, чтобы можно было тыкать по айпаду (но работать тоже надо). И нескучные обои с цветами в вазе (и полицейскими в УАЗе).

     
  • 6.108, Аноним42 (?), 03:26, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Конченый? Нужен репозиторий, а не дистрибутив.

    Тогда иди вон туда https://old-releases.ubuntu.com/ubuntu/
    И там тебе все версии с 4.10, все на месте, можно любой репозиторий использовать
    А не орать, что враги насpали под диван

     
  • 5.101, Аноним (99), 01:52, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > old-releases.ubuntu.com/releases/7.04

    Не тупи, там только CD-образ, там нет всех репов.

     
  • 4.109, Аноним42 (?), 03:29, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > У что это за дистрибутив 2007 год у которого работают репозитории до
    > сих пор? Ты сейчас даже репу для Ubuntu 07.04 нигде не
    > найдешь. А доставлять зависимости точно придётся.

    Хоть Debian, хоть Ubuntu
    Все репы доступны

    https://old-releases.ubuntu.com/ubuntu/
    http://archive.debian.org/debian

    У Ubuntu с 4.10, у Debian с buzz
    Но ты же об этом не знаешь, потому что ты пришел выдумывать тут «проблемы», ты никогда не использовал GNU/Linux и не знаешь ничего о репах

     
  • 3.92, Аноним (-), 21:05, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >Решается виртуалкой

    А я-то думал, от кого лезла вся эта аргументация за докер уровня "раньше мы использовали виртуалки".

    Дорогой, ты там с луны свалился чи шо?

     
  • 2.65, beck (??), 16:25, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Вот не хотите пользоваться флатпаками, а потом жалуетесь!
     
     
  • 3.77, Аноним (77), 18:03, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Так это как раз ЦА флатпака и жалуется, ведь у неё лапки, а она зачем-то поставила линукс и программирует там на своём System.Windows.Forms на очередном расте.
     
  • 2.76, Аноним (77), 18:00, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    man chroot
     
     
  • 3.80, pic (?), 18:09, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    С подключением давно свернутых зеркал реп.
     
     
  • 4.83, Аноним (-), 18:15, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    У дебиана есть архив. На дисках.

    Если у тебя нет архива на дисках, в холодную зиму ты рискуешь умереть со скуки, лига без интернета об этом позаботится.

    Зато не умрёшь от хентая, ведь он очень опасен для неокрепших умов великовозрастных линуксоидов из альтлинукса.

     
  • 4.85, Аноним (-), 18:17, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >На дисках

    И вроде как не только на дисках.

    Ещё есть другие дистрибутивы, в которых можно компилять программы без девпакетов и сорцы.

     
  • 4.105, Аноним42 (?), 02:57, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > С подключением давно свернутых зеркал реп.

    Куда свернутых?
    http://archive.debian.org/debian
    Все архивы с buzz'а на месте. Я точно методично от 2.1 до 9 обновлял юзая онлайновые репы несколько лет назад
    https://old-releases.ubuntu.com/
    Все версии с 4.10(то есть первого релиза Ubuntu)
    Бросай курить носки, чувак

     
     
  • 5.144, pic (?), 17:05, 12/10/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >> С подключением давно свернутых зеркал реп.
    > Куда свернутых?
    > http://archive.debian.org/debian
    > Все архивы с buzz'а на месте. Я точно методично от 2.1 до
    > 9 обновлял юзая онлайновые репы несколько лет назад
    > https://old-releases.ubuntu.com/
    > Все версии с 4.10(то есть первого релиза Ubuntu)
    > Бросай курить носки, чувак

    Причём тут твой дебиан и убунту?

     
  • 2.82, Аноним42 (?), 18:14, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    >[оверквотинг удален]
    > И что нахожу я тот самый кикад 2007 года выпуска и для
    > Линукса в бинарном виде и для оффтопика. И что толку как
    > не пляши с линуксовым кикадом всех библиотек ты никогда не соберешь
    > и никогда эту фекалию не запустишь.
    > А оффтопик версию кикада 2007 года ставишь в виртуалке оффтопик 10 запускаешь
    > установщики Next Next и всё просто работает. 15 лет прошло и
    > всё просто работает. Почему нельзя сделать чтобы всё просто работало в
    > Линуксе хоть контейнерами хоть слоями хоть чем. Какое мне дело до
    > 5 сэкономленных мегабайтах оперативы если я не могу просто взять и
    > запустить приложение?

    Черт! А у меня игры выпущенные под линуху LokiGames до сих пор запускаются…
    Видимо дело не в линухе, а в твоем какаде

     
     
  • 3.102, Аноним (99), 01:55, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > дело не в линухе, а в твоем какаде

    кикад выкинуть, перейти на pcb/geda - вот и решение проблемы.

     
     
  • 4.106, Аноним42 (?), 02:58, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >> дело не в линухе, а в твоем какаде
    > кикад выкинуть, перейти на pcb/geda - вот и решение проблемы.

    Ну я на это и указал
    Игры выпущенные в 2000-2002 году под линуху LokiGames запускаются до сих пор, с минимальными действиями
    Если кикад не работает, то проблема в нем, а не в линухе

     
     
  • 5.116, Аноним (116), 12:47, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >Игры выпущенные в 2000-2002 году под линуху LokiGames запускаются до сих пор, с минимальными действиями

    Очень хорошо. А какие минимальные действия требуются, например?

     
     
  • 6.117, Аноним42 (?), 13:53, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >>Игры выпущенные в 2000-2002 году под линуху LokiGames запускаются до сих пор, с минимальными действиями
    > Очень хорошо. А какие минимальные действия требуются, например?

    Если я правильно помню, то с Soldier of Fortune у меня был затык в том, что он esd хотел, что ли
    Надо будет ради интереса найти где у меня диски и поставить на чистую систему, что бы воспроизвести все действия
    Но реально игры выпущенные в начале нулевых спокойно работают, те что у меня есть, совместимость на месте

     
  • 6.135, RANDOMIZE USR 15616 (?), 07:14, 09/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    modprobe snd-mixer-oss
     
  • 2.97, mikhailnov (ok), 01:14, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Если бы была собрана грамотно и специально так, чтобы минимально зависеть от системных библиотек, то запускалась бы с большой вероятностью. glibc уже libc.so.6 был? ABI иксовых библиотек разве потеряло совместимость?
     
     
  • 3.103, Аноним (99), 01:56, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > разве потеряло совместимость?

    потеряло совместимость соединение рук с туловищем разработчиков кикада.

     
     
  • 4.104, mikhailnov (ok), 02:25, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Как бы ваши пальцы не потеряли связь с реальностью
     
  • 3.113, Аноним (111), 10:27, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Вот что было найдено в интернете https://kicad-downloads.s3.cern.ch/index.html?prefix=archive/old_versions/ попытка были с последней версией 2007 года (У них до 2015 года версионирование было просто дайтой релиза кикада) есть и для линукса и для XP. libc.so.6 уже используется.
     
     
  • 4.120, mikhailnov (ok), 14:41, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Скачал и запустил в современном линуксе без каких-либо проблем вообще, описал процедуру и выложил скриншоты здесь: https://nixtux.ru/1246
    Если кратко, то просто недостающие 32-битные библиотеки из современного репозитория поставил, и всё.
     
     
  • 5.127, Аноним (43), 02:46, 07/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    А ты хорош...
    Надо будет трюк с ldd запомнить.
     
     
  • 6.129, mikhailnov (ok), 14:19, 07/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Да и без ldd при запуске пишет, чего не хватает, но по одной штуке за итерацию.
     
  • 5.136, Аноним (136), 12:15, 09/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Ой всё уговорил В последней LTS убунте тоже запускается надо к пакетам дописыва... большой текст свёрнут, показать
     
     
  • 6.138, mikhailnov (ok), 18:52, 09/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > Ой всё уговорил. В последней LTS убунте тоже запускается надо к пакетам
    > дописывать :i386, как найти пакет по имени файла в убунте я
    > хз гугл не подсказал. Но гугл по имени файла либы помог
    > определить пакеты.

    На packages.ubuntu.com вторая поисковая строка или apt-file.

    > Но сам факт всех этих приседаний с бубном уже говорит о том
    > что это какой-то позор. Есть же много способов дистрибуции. Можно было
    > положить все эти либы прям все в один пакет с приложением
    > и если их нет в системе использовать запасные. Возможно нужен скрипт
    > чтобы он всё так компоновал.

    Конкретно здесь, я считаю, не нужно. ВСЕ эти либы есть в типовой десктопной системе. "Необычные" либы там не требуются. Ну а то, что через 15 лет системы стали 64-битными... ну извините.

    > Можно сделать общеизвестный и общераспространенный скрипт или тулзу, которая будет искать
    > все эти зависимости по имени и сама ставить в систему. Вести
    > их учёт. Больше того не помешало как у вас это сделать
    > на контейнерах, потому как если этих либ в системе до этого
    > не было значит они не нужны зачем мне этот мусор. В

    Всегда удивлялся и продолжаю удивляться рассуждениям типа "зачем мне тонна библиотек KDE в моем гноме". Жалко что ли? А под хлам в контейнерах не жалко места и прочих ресурсов?

     
     
  • 7.140, Аноним (140), 17:04, 10/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Нет.
     
  • 3.119, Zenitur (ok), 14:16, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Как правило, проприетарные проги собирают грамотно и специально так, чтобы минимально зависеть от системных библиотек. А опенсорсные программы собирают под конкретную версию конкретного дистра.

    Я поднимал эту тему ещё 5 лет назад. Пытался делать сборки опенсорсных программ по правилам проприетарных. Но был поднят на смех на ЛОРе и не нашёл единомышленников.

    Собрал например PCSX2 1.3.1. Эмулятор второй "плойки". Просто создал папку lib, в которую скидал wxWidgets, portaudio, SDL, libCg, libGLEW. Больше всего проблем создавал именно libGLEW, так как он ломает ABI _очень_ часто. Скажем, авторы официальной сборки использовали Ubuntu 16.04 для создания своей сборки, а в 16.10 заменили libGLEW 1.7 на 1.8, и всё отвалилось.

    Так что если бы авторы официальной сборки положили эту либу в архив с программой (либо же собрали эту либу статически), как минимум половину проблем удалось бы решить.

    Система для сборки у меня была CentOS 5. Компилятор GCC 4.8 из репозитория devtoolset. Пришлось немного пропатчить исходники, чтобы не было зависимости от слишком новой версии GTK2. Однако уже в PCSX2 1.4.0 стало _слишком_ много строк кода, которые надо даунгрейдить для совместимости со старым GTK2. Поэтому я просто обновил дистр до CentOS 6.

     
     
  • 4.122, mikhailnov (ok), 14:56, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > по правилам проприетарных

    С правами 777 на /var/log и /etc, LD_LIBRARY_PATH и огромными постустановочными скриптами, которые копируют файлы вместо того, чтоб их сразу правильно разложить внутри пакета?))

     
  • 4.137, Аноним (136), 12:17, 09/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Всё так дело даже не в принципиальной возможности, а в общей системе и подходе по распространению софта. Именно с этим надо что-то делать. Именно об это что-то всё разбивается. Что это за что-то?

    И я на данный момент что контейнеры и сабж одно из лучших решений. Но и не без недостатков.

     
     
  • 5.139, Zenitur (ok), 11:06, 10/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Я с тобой согласен. Я помню времена, когда весь софт пакетировли под Red Hat 7.2, и у всех всё работало. Когда на Mandrake и SUSE эти же самые RPM-пакеты устанавливались и работали.
     
  • 2.118, Zenitur (ok), 14:07, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > И что нахожу я тот самый кикад 2007 года выпуска и для Линукса в бинарном виде и для оффтопика. И что толку как не пляши с линуксовым кикадом всех библиотек ты никогда не соберешь и никогда эту фекалию не запустишь.

    Не, ну в принципе можно. Распаковываешь пакет в папку kicad-2007, создаёшь внутри папку lib, делаешь ldd kicad, узнаёшь названия отсутствующих либ, скидываешь их в папку lib, и запускаешь так:

    LD_LIBRARY_PATH=./lib ./kicad

    Можно даже скрипт ru.sh сделать, в который положить эту команду

     
     
  • 3.121, mikhailnov (ok), 14:54, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Лучше через patchelf поставить RPATH, а то, если из-под Kicad будет запущена какая-то еще программа, например, браузер, то и она, и ее потомки унаследуют LD_LIBRARY_PATH, что может привести к проблемам.
    Но конкретно здесь ни то, ни то не нужно, см. выше.
     

  • 1.54, Аноним (54), 15:05, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Salt (предустановлена) и Ansible (опция)

    Выбор между жутью и ужасом

     
  • 1.68, Аноним (66), 17:13, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Опять изобретают NixOS…
     
     
  • 2.96, Аноним (96), 00:12, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Причём твой NixOS, дело не в пакетах.
     

  • 1.81, Аноним (-), 18:11, 05/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    А ведь я когда-то на соседнем форуме приводил пример системных сервисов в контей... большой текст свёрнут, показать
     
     
  • 2.84, Аноним42 (?), 18:16, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >>Среди системных компонентов, вынесенных в контейнеры, присутствуют yast2, podman, k3s, cockpit, GDM (GNOME Display Manager) и KVM.
    >>GDM
    > А ведь я когда-то на соседнем форуме приводил пример системных сервисов в
    > контейнере как пример того, что контейнеры - это безумие, вот поставите
    > систему из таких вот компонентов и разом закончится память.

    С чего бы памяти заканчиваться, если у тебя в контейнере будет сразу запускаться бинарь gdm'а или яста?
    Оверхэд будет близкий к нулю

    Да, я не вижу смысла запускать gdm или podman в контейнере, но и ты чушь не пори, ей же больно!

     
     
  • 3.86, Аноним (88), 18:21, 05/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >С чего бы памяти заканчиваться

    С практики контейнеризации, когда glib в одном контейнере одной версии, в другом контейнере - другой, в третьем - третьей. В убунте со снапами уже такое спокойненько так вытворяют.

    >если у тебя в контейнере будет сразу
    >Оверхэд будет близкий к нулю

    С Пинки Пай у тебя в голове можно сразу поздороваться или её придётся по слоям собирать с нулевым оверхедом?

     
     
  • 4.114, Аноним (111), 10:41, 06/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    В целом если бы контейнеры еще шерили свои либы между контейнерами было бы получше. Но они не шерят(
     

  • 1.128, Аноним (128), 09:33, 07/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    лучше бы в линукс для десктопа вкладывались, а не вот это все.
     
     
  • 2.141, Аноним (140), 17:04, 10/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Давно пора.
     
  • 2.142, Аноним (-), 11:48, 12/10/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > лучше бы в линукс для десктопа вкладывались, а не вот это все.

    Аноним, если ты такой умный, почему ты еще не вкладываешься сам и не показал миллиардерам чего там у тебя?


     

  • 1.146, Сергей 01802АМ (?), 11:35, 16/10/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    1. сайт ua.opennet.me не работает
    2. https://nobaraproject.org/ — The Nobara Project, to put it simply, is a modified version of Fedora Linux with user-friendly fixes added to it.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру