The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VoIP)
Изначальное сообщение [ Отслеживать ]

"2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от MaximVT (ok) on 15-Май-13, 11:10 
Добрый день.

Столкнулся с проблемой при настройке Cisco 2911 + CUCM, в результате настройки звонки проходят в обе стороны, но при этом в трубке тишина. Исходящие вызовы на внешние номера - тишина, нет даже гудков. Звонки проходят, номера звонящих передаются, отображаются.

Конфигурация следующая:

Cisco Unified CM Administration System version: 8.6.2.20000-2 Unrestricted

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9_NPE-M), Version 15.0(1)M7, RELEASE SOFTWARE (fc2)

VWIC3-2MFT-T1/E1 - 2 штуки

Пока есть 2 PRI потока от Ростелеком

Конфигурация Cisco 2911:


2911b.rb.com#sh run
Building configuration...


!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2911b.rb.com
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
logging buffered 51200 warnings
!
no aaa new-model
clock timezone MOSCOW 4
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 E1 0/0/0
network-clock-select 2 E1 0/0/1
network-clock-select 3 E1 0/1/0
network-clock-select 4 E1 0/1/1
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
no ip domain lookup
ip host cucm-pub 10.20.xxx.xx0
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
isdn voice-call-failure 0
isdn logging
carrier-id source
!
voice-card 0
!
!
voice call send-alert
voice call disc-pi-off
!
voice service voip
dtmf-interworking rtp-nte
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
!
hw-module pvdm 0/0
!
!
controller E1 0/0/0
pri-group timeslots 1-31 service mgcp
!
controller E1 0/0/1
pri-group timeslots 1-31 service mgcp
!
controller E1 0/1/0
pri-group timeslots 1-31 service mgcp
!
controller E1 0/1/1
pri-group timeslots 1-31 service mgcp
!
interface Loopback0
ip address 10.255.255.5 255.255.255.255
!
interface Port-channel1
no ip address
!
interface Port-channel1.6
description Management
encapsulation dot1Q 6
ip address 10.6.xx.xx 255.255.254.0
!
interface Port-channel1.20
description UC-Servers
encapsulation dot1Q 20
ip address 10.20.xxx.xxx 255.255.255.0
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
channel-group 1
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
channel-group 1
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/0/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/1/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
ip forward-protocol nd
!
!
voice-port 0/0/0:15
cptone RU
!
voice-port 0/1/0:15
cptone RU
!
voice-port 0/0/1:15
cptone RU
!
voice-port 0/1/1:15
cptone RU
!
ccm-manager switchback immediate
ccm-manager fallback-mgcp
ccm-manager redundant-host 10.20.xxx.xx1
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 10.20.xxx.xx0
ccm-manager config
!
mgcp
mgcp call-agent cucm-pub 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp codec g711alaw packetization-period 10
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
!
mgcp profile default
!
!
dial-peer voice 900015 pots
service mgcpapp
direct-inward-dial
!
dial-peer voice 900115 pots
service mgcpapp
direct-inward-dial
!
dial-peer voice 901015 pots
service mgcpapp
direct-inward-dial
!
dial-peer voice 901115 pots
service mgcpapp
direct-inward-dial
!
!
gatekeeper
shutdown
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

Еще есть лог звонка, из которого вижу, что rx по нулям, но что с этим делать - ума не приложу:


2911b.rb.com#sh call active voice brief
<ID>: <CallID> <start>ms.<index> +<connect> pid:<peer_id> <dir> <addr> <state>
  dur hh:mm:ss tx:<packets>/<bytes> rx:<packets>/<bytes>
IP <ip>:<udp> rtt:<time>ms pl:<play>/<gap>ms lost:<lost>/<early>/<late>
  delay:<last>/<min>/<max>ms <codec>

media inactive detected:<y/n> media cntrl rcvd:<y/n> timestamp:<time>

long duration call detected:<y/n> long duration call duration :<sec> timestamp:<time>
  MODEMPASS <method> buf:<fills>/<drains> loss <overall%> <multipkt>/<corrected>
   last <buf event time>s dur:<Min>/<Max>s
FR <protocol> [int dlci cid] vad:<y/n> dtmf:<y/n> seq:<y/n>
  <codec> (payload size)
ATM <protocol> [int vpi/vci cid] vad:<y/n> dtmf:<y/n> seq:<y/n>
  <codec> (payload size)
Tele <int> (callID) [channel_id] tx:<tot>/<v>/<fax>ms <codec> noise:<l> acom:<l> i/o:<l>/<l> dBm
  MODEMRELAY info:<rcvd>/<sent>/<resent> xid:<rcvd>/<sent> total:<rcvd>/<sent>/<drops>
         speeds(bps): local <rx>/<tx> remote <rx>/<tx>
Proxy <ip>:<audio udp>,<video udp>,<tcp0>,<tcp1>,<tcp2>,<tcp3> endpt: <type>/<manf>
bw: <req>/<act> codec: <audio>/<video>
  tx: <audio pkts>/<audio bytes>,<video pkts>/<video bytes>,<t120 pkts>/<t120 bytes>
rx: <audio pkts>/<audio bytes>,<video pkts>/<video bytes>,<t120 pkts>/<t120 bytes>


Telephony call-legs: 1
SIP call-legs: 0
H323 call-legs: 0
Call agent controlled call-legs: 1
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 2
11EC : 18 73475360ms.1 +0 pid:0 Originate  connecting
dur 00:00:14 tx:708/113280 rx:0/0
IP 10.21.1.138:22680 SRTP: off rtt:0ms pl:0/0ms lost:0/0/0 delay:65/65/65ms g711ulaw TextRelay: off
media inactive detected:n media contrl rcvd:n/a timestamp:n/a
long duration call detected:n long duration call duration:n/a timestamp:n/a

11EC : 17 73475360ms.2 +0 pid:0 Originate  active
dur 00:00:14 tx:714/114240 rx:0/0
Tele 0/1/0:15 (17) [0/1/0.31] tx:14290/14290/0ms g711ulaw noise:-84 acom:3  i/0:-79/-65 dBm


Telephony call-legs: 1
SIP call-legs: 0
H323 call-legs: 0
Call agent controlled call-legs: 1
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 2

2911b.rb.com#

Ну и debug isdn:


2911b.rb.com#debug isdn q931
debug isdn q931 is              ON.
2911b.rb.com#debug isdn q921
debug isdn q921 is              ON.
2911b.rb.com#
2911b.rb.com#
2911b.rb.com#
May 15 07:14:07.562: ISDN Se0/1/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=14
May 15 07:14:07.562: ISDN Se0/1/0:15 Q921: User RX <- RRp sapi=0 tei=0 nr=10
May 15 07:14:07.566: ISDN Se0/1/0:15 Q921: User TX -> RRf sapi=0 tei=0 nr=14
May 15 07:14:07.566: ISDN Se0/1/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=10
2911b.rb.com#
May 15 07:14:12.566: ISDN Se0/0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=3 nr=5
May 15 07:14:12.566: ISDN Se0/0/0:15 Q931: SETUP pd = 8  callref = 0x0002
        Sending Complete
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9839E
                Exclusive, Channel 30
        Calling Party Number i = 0x2181, '***'
                Plan:ISDN, Type:National
        Called Party Number i = 0xA1, '***'
                Plan:ISDN, Type:National
May 15 07:14:12.578: ISDN Se0/0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=4
May 15 07:14:12.606: ISDN Se0/0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=5 nr=4
May 15 07:14:12.606: ISDN Se0/0/0:15 Q931: CALL_PROC pd = 8  callref = 0x8002
        Channel ID i = 0xA9839E
                Exclusive, Channel 30
May 15 07:14:12.606: ISDN Se0/0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=6
May 15 07:14:15.594: ISDN Se0/0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=6 nr=4
May 15 07:14:15.598: ISDN Se0/0/0:15 Q931: ALERTING pd = 8  callref = 0x8002
May 15 07:14:15.598: ISDN Se0/0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=7
May 15 07:14:17.566: ISDN Se0/1/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=14
May 15 07:14:17.570: ISDN Se0/1/0:15 Q921: User RX <- RRp sapi=0 tei=0 nr=10
May 15 07:14:17.570: ISDN Se0/1/0:15 Q921: User TX -> RRf sapi=0 tei=0 nr=14
May 15 07:14:17.570: ISDN Se0/1/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=10
May 15 07:14:17.622: ISDN Se0/0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=7 nr=4
May 15 07:14:17.622: ISDN Se0/0/0:15 Q931: CONNECT pd = 8  callref = 0x8002
        Date/Time i = 0x0D050F0B05
                Date (dd-mm-yr)   = 13-05-15
                Time (hr:mnt:sec) = 11:05:00
May 15 07:14:17.622: ISDN Se0/0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=8
May 15 07:14:17.626: ISDN Se0/0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=4 nr=8
May 15 07:14:17.626: ISDN Se0/0/0:15 Q931: CONNECT_ACK pd = 8  callref = 0x0002
May 15 07:14:17.630: ISDN Se0/0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=5
May 15 07:14:23.706: ISDN Se0/0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=8 nr=5
May 15 07:14:23.706: ISDN Se0/0/0:15 Q931: DISCONNECT pd = 8  callref = 0x8002
        Cause i = 0x8090 - Normal call clearing
        Progress Ind i = 0x8288 - In-band info or appropriate now available
May 15 07:14:23.706: ISDN Se0/0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=9
May 15 07:14:23.730: ISDN Se0/0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=5 nr=9
May 15 07:14:23.730: ISDN Se0/0/0:15 Q931: RELEASE pd = 8  callref = 0x0002
May 15 07:14:23.734: ISDN Se0/0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=6
May 15 07:14:23.746: ISDN Se0/0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=9 nr=6
May 15 07:14:23.746: ISDN Se0/0/0:15 Q931: RELEASE_COMP pd = 8  callref = 0x8002
May 15 07:14:23.746: ISDN Se0/0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=10
2911b.rb.com#


Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от mdenisov (ok) on 15-Май-13, 13:34 
Проверьте виден ли со шлюза адрес 10.21.1.138. Для дальнейшего удобства рекомендую привязать mgcp к конкретному адресу, например lo0. Тогда проверяйте ping 10.21.1.138 sou lo0 и если ходит - нужно смотреть на втором устройстве (не UCM, а то что он с этим шлюзом соединяет).
И уберите dial-peer'ы, в вашей схеме они все равно не работают. Или пропишите нормально на случай fallback'а. Mgcpapp работает только на аналоговых портах.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от MaximVT (ok) on 15-Май-13, 16:12 
> Проверьте виден ли со шлюза адрес 10.21.1.138. Для дальнейшего удобства рекомендую привязать
> mgcp к конкретному адресу, например lo0. Тогда проверяйте ping 10.21.1.138 sou
> lo0 и если ходит - нужно смотреть на втором устройстве (не
> UCM, а то что он с этим шлюзом соединяет).

Ничего не понял, я не понимаю зачем шлюзу видеть телефон? Есть CUCM, на нем телефон зарегистрирован, звонок совершаю с телефона, CUCM использует шлюз. Как привязать mgcp к конкретному адресу и где, особенно учитывая, что mgcp - это протокол? Вобщем пока ничего не понятно, сорри.

> И уберите dial-peer'ы, в вашей схеме они все равно не работают. Или
> пропишите нормально на случай fallback'а. Mgcpapp работает только на аналоговых портах.

dial-peer убрал.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +1 +/
Сообщение от mdenisov (ok) on 15-Май-13, 16:26 
> Ничего не понял, я не понимаю зачем шлюзу видеть телефон? Есть CUCM,
> на нем телефон зарегистрирован, звонок совершаю с телефона, CUCM использует шлюз.

В данном случае UCM обеспечивает только сигнализацию, RTP идет напрямую между шлюзом и телефоном, в большинстве случаев так и должно быть.

> Как привязать mgcp к конкретному адресу и где, особенно учитывая, что
> mgcp - это протокол? Вобщем пока ничего не понятно, сорри.

MGCP это протокол, по которому UCM управляет шлюзом. В Вашем случае соединение с UCM устанавливается с ближайшего интерфейса согласно таблице маршрутизации. Привязывание адресов к лупбэкам является хорошим тоном и может упростить жизнь. Можно привязать жестко и к физическому интерфейсу, но в случае падения этого интерфейса UCM отвалится, хотя возможно, что до UCM есть маршрут через другие интерфейсы.  Привязывается командами mgcp bind control source-interface Loopback9 и mgcp bind media source-interface Loopback9.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от MaximVT (ok) on 15-Май-13, 18:50 
> В данном случае UCM обеспечивает только сигнализацию, RTP идет напрямую между шлюзом
> и телефоном, в большинстве случаев так и должно быть.

Добавил маршрут:

2911b.rb.com(config)#ip route 10.21.1.0 255.255.255.0 10.20.1.254

результат:


2911b.rb.com#ping 10.21.1.138

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.21.1.138, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms


Телефон доступен, звука при звонках за пределы шлюза по прежнему нет. Мысли кончились.

>MGCP это протокол, по которому UCM управляет шлюзом. В Вашем случае соединение с UCM
>устанавливается с ближайшего интерфейса согласно таблице >маршрутизации. Привязывание
>адресов к лупбэкам является хорошим тоном и может упростить жизнь. Можно привязать
>жестко и к физическому >интерфейсу, но в случае падения этого интерфейса UCM
>отвалится, хотя возможно, что до UCM есть маршрут через другие интерфейсы.
>Привязывается командами mgcp bind control source-interface Loopback9 и mgcp bind
>media source-interface Loopback9.

Про привязку вобще ничего не понял, какой адрес я должен привязать и к какому интерфейсу? У меня уже есть 1 адрес на шлюзе:


!
interface Port-channel1.20
description UC-Servers
encapsulation dot1Q 20
ip address 10.20.xxx.xxx 255.255.255.0
!

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от mdenisov (ok) on 15-Май-13, 19:05 
> 2911b.rb.com#ping 10.21.1.138
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 10.21.1.138, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
>
> Телефон доступен, звука при звонках за пределы шлюза по прежнему нет. Мысли
> кончились.

По идее должно работать. Проверьте не фильтруется ли где-нибудь UDP в диапазоне 16384-32768.

> Про привязку вобще ничего не понял, какой адрес я должен привязать и
> к какому интерфейсу? У меня уже есть 1 адрес на шлюзе:

Добейтесь прохождения пакетов между lo0 и UCM и 10.21.1.138 - ping 10.21.1.138 sou lo0
После этого пропишите
mgcp bind control source-interface Loopback0
mgcp bind media source-interface Loopback0

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от MaximVT (ok) on 15-Май-13, 19:19 
> По идее должно работать. Проверьте не фильтруется ли где-нибудь UDP в диапазоне
> 16384-32768.

Нет, не фильтруется, все в пределах одной локальной (физической) сети.

> Добейтесь прохождения пакетов между lo0 и UCM и 10.21.1.138 - ping 10.21.1.138
> sou lo0

Вот тут, если можно, поподробнее, пожалуйста, т.к. я не совсем понимаю как это осуществить при текущей конфигурации lo0:


!
interface Loopback0
ip address 10.255.255.5 255.255.255.255
!

> После этого пропишите
> mgcp bind control source-interface Loopback0
> mgcp bind media source-interface Loopback0

Пока прописал так:


mgcp bind control source-interface Port-channel1.20
mgcp bind media source-interface Port-channel1.20

Есть небольшой результат, теперь принимаем и передаем:

2911b.rb.com#sh call active voice brief
<ID>: <CallID> <start>ms.<index> +<connect> pid:<peer_id> <dir> <addr> <state>
  dur hh:mm:ss tx:<packets>/<bytes> rx:<packets>/<bytes>
IP <ip>:<udp> rtt:<time>ms pl:<play>/<gap>ms lost:<lost>/<early>/<late>
  delay:<last>/<min>/<max>ms <codec>

media inactive detected:<y/n> media cntrl rcvd:<y/n> timestamp:<time>

long duration call detected:<y/n> long duration call duration :<sec> timestamp:<time>
  MODEMPASS <method> buf:<fills>/<drains> loss <overall%> <multipkt>/<corrected>
   last <buf event time>s dur:<Min>/<Max>s
FR <protocol> [int dlci cid] vad:<y/n> dtmf:<y/n> seq:<y/n>
  <codec> (payload size)
ATM <protocol> [int vpi/vci cid] vad:<y/n> dtmf:<y/n> seq:<y/n>
  <codec> (payload size)
Tele <int> (callID) [channel_id] tx:<tot>/<v>/<fax>ms <codec> noise:<l> acom:<l> i/o:<l>/<l> dBm
  MODEMRELAY info:<rcvd>/<sent>/<resent> xid:<rcvd>/<sent> total:<rcvd>/<sent>/<drops>
         speeds(bps): local <rx>/<tx> remote <rx>/<tx>
Proxy <ip>:<audio udp>,<video udp>,<tcp0>,<tcp1>,<tcp2>,<tcp3> endpt: <type>/<manf>
bw: <req>/<act> codec: <audio>/<video>
  tx: <audio pkts>/<audio bytes>,<video pkts>/<video bytes>,<t120 pkts>/<t120 bytes>
rx: <audio pkts>/<audio bytes>,<video pkts>/<video bytes>,<t120 pkts>/<t120 bytes>


Telephony call-legs: 1
SIP call-legs: 0
H323 call-legs: 0
Call agent controlled call-legs: 1
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 2
11FB : 48 103141120ms.1 +0 pid:0 Originate  connecting
dur 00:00:30 tx:1525/244000 rx:1522/243520
IP 10.21.1.138:23120 SRTP: off rtt:23ms pl:28450/0ms lost:0/0/0 delay:55/55/65ms g711ulaw TextRelay: off
media inactive detected:n media contrl rcvd:n/a timestamp:n/a
long duration call detected:n long duration call duration:n/a timestamp:n/a

11FB : 47 103141120ms.2 +0 pid:0 Originate  active
dur 00:00:30 tx:1531/244960 rx:1524/256032
Tele 0/0/0:15 (47) [0/0/0.31] tx:30620/30620/0ms g711ulaw noise:-84 acom:51  i/0:-79/-35 dBm


Telephony call-legs: 1
SIP call-legs: 0
H323 call-legs: 0
Call agent controlled call-legs: 1
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 2

Но в трубке по прежнему тишина.

Может все-таки кодек? нужен a-law, а не u-law...

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от mdenisov (ok) on 15-Май-13, 19:32 
>> Добейтесь прохождения пакетов между lo0 и UCM и 10.21.1.138 - ping 10.21.1.138
>> sou lo0
> Вот тут, если можно, поподробнее, пожалуйста, т.к. я не совсем понимаю как
> это осуществить при текущей конфигурации lo0:
>
 
> !
> interface Loopback0
>  ip address 10.255.255.5 255.255.255.255
> !
>

У Вас адрес 10.255.255.5 видет адрес UCM а адрес телефона (проверяется ping $ipaddr source lo0)? Если да, то лучше привязывать MGCP к этому адресу.

> Пока прописал так:
>

 
> mgcp bind control source-interface Port-channel1.20
> mgcp bind media source-interface Port-channel1.20
>

Можно и так, но при падении этого интерфейса отвалится UCM.

> Есть небольшой результат, теперь принимаем и передаем:
>

 
> 11FB : 47 103141120ms.2 +0 pid:0 Originate  active
>  dur 00:00:30 tx:1531/244960 rx:1524/256032
>  Tele 0/0/0:15 (47) [0/0/0.31] tx:30620/30620/0ms g711ulaw noise:-84 acom:51  i/0:-79/-35
> dBm
>
Но в трубке по прежнему тишина.
> Может все-таки кодек? нужен a-law, а не u-law...

Нет, не кодек. Какой телефон используется? На цискины можно зайти по http и посмотреть состояние RTP в stream'ах. В какой трубке тишина, на какой стороне? Дозвонитесь так чтобы взяли трубки, отбейте вызов и после этого покажите sh call hist vo last 1.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от MaximVT (ok) on 15-Май-13, 19:48 
> У Вас адрес 10.255.255.5 видет адрес UCM а адрес телефона (проверяется ping
> $ipaddr source lo0)? Если да, то лучше привязывать MGCP к этому
> адресу.

Нет, не видит, и я не представляю как он его увидит:


2911b.rb.com#ping cucm-pub so lo0
Translating "cucm-pub"

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.20.1.100, timeout is 2 seconds:
Packet sent with a source address of 10.255.255.5
.....
Success rate is 0 percent (0/5)

lo0 - интерфейс с сетью с 1 адресом, шлюза нет, роутинга нет, ната нет. CUCM доступен с интерфейса Port-channel1.20

> Нет, не кодек. Какой телефон используется? На цискины можно зайти по http
> и посмотреть состояние RTP в stream'ах. В какой трубке тишина, на
> какой стороне? Дозвонитесь так чтобы взяли трубки, отбейте вызов и после
> этого покажите sh call hist vo last 1.

Cisco 6921:


Remote Address   10.20.1.2/24764
Local Address   10.21.1.138/23152
Start Time   19:33:28
Stream Status   Not Ready
Host Name   SEPF0F
Sender Packets   851
Sender Octets   136000
Sender Codec   G.711U
Sender Reports Sent   2
Sender Report Time Sent   19:33:45
Rcvr Lost Packets   0
Avg Jitter   1
Rcvr Codec   G.711U
Rcvr Reports Sent   0
Rcvr Report Time Sent   00:00:00
Rcvr Packets   850
Rcvr Octets   136000
Cumulative Conceal Ratio   0.0000
Interval Conceal Ratio   0.0000
Max Conceal Ratio   0.0000
Conceal Secs   0
Severely Conceal Secs   0
Latency   0
Max Jitter   25
Sender Size   10
Sender Reports Received   4
Sender Report Time Received   19:33:44
Rcvr Size   10
Rcvr Discarded   0
Rcvr Reports Received   1
Rcvr Report Time Received   19:33:45
MOS LQK   4.5000
Avg MOS LQK   4.5000
Min MOS LQK   4.5000
Max MOS LQK   4.5000
MOS LQK Version   0.9500

я не могу сказать в какой трубке тишина, я осуществляю звонок со станционарного телефона на сотовый, оба по громкой связи - нигде себя не слышу.

2911b.rb.com#sh call hist vo last 1

GENERIC:
SetupTime=104505510 ms
Index=52
PeerAddress=
PeerSubAddress=
PeerId=0
PeerIfIndex=0
LogicalIfIndex=39
DisconnectCause=10
DisconnectText=normal call clearing (16)
ConnectTime=104505510 ms
DisconnectTime=104522730 ms
CallDuration=00:00:17 sec
CallOrigin=1
ReleaseSource=2
ChargedUnits=0
InfoType=speech
TransmitPackets=859
TransmitBytes=137440
ReceivePackets=853
ReceiveBytes=143304
TELE:
ConnectionId=[0xDFF2BCAD 0xBCAD11E2 0x801B2894 0xFB61A30]
IncomingConnectionId=[0xDFF2BCAD 0xBCAD11E2 0x801B2894 0xFB61A30]
CallID=51
Port=0/0/0:15 (51)
BearerChannel=0/0/0.31
TxDuration=17200 ms
VoiceTxDuration=17200 ms
FaxTxDuration=0 ms
CoderTypeRate=g711ulaw
NoiseLevel=-84
ACOMLevel=51
SessionTarget=
ImgPages=0
CallerName=
CallerIDBlocked=False
LongDurationCallDetected=no
LongDurCallTimeStamp=
LongDurCallDuration=
OriginalCallingNumber=
OriginalCallingOctet=0x0
OriginalCalledNumber=
OriginalCalledOctet=0x0
OriginalRedirectCalledNumber=
OriginalRedirectCalledOctet=0x0
TranslatedCallingNumber=
TranslatedCallingOctet=0x0
TranslatedCalledNumber=
TranslatedCalledOctet=0x0
TranslatedRedirectCalledNumber=
TranslatedRedirectCalledOctet=0x0
DSPIdentifier=0/1:1
MlppServiceDomain=0 (NO_MLPP_DOMAIN)
PrecedenceLevel=-1 (PRECEDENCE_LEVEL_NONE)


Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

10. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от mdenisov (ok) on 16-Май-13, 13:37 
> lo0 - интерфейс с сетью с 1 адресом, шлюза нет, роутинга нет,
> ната нет. CUCM доступен с интерфейса Port-channel1.20

Похоже что Вы плохо представляете как работает маршрутизация.

Судя по тому что у вас концы RTP правильные и видно входящие пакеты на обоих концах, проблема в конечных устройствах. Попробуйте в UCM ткнуть в reset на телефоне и шлюзе. Если не поможет - надо смотреть debug rtp. Вы случаем в UCM шифрование не используете?

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

11. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от MaximVT (ok) on 16-Май-13, 18:33 
> Судя по тому что у вас концы RTP правильные и видно входящие
> пакеты на обоих концах, проблема в конечных устройствах. Попробуйте в UCM
> ткнуть в reset на телефоне и шлюзе. Если не поможет -
> надо смотреть debug rtp. Вы случаем в UCM шифрование не используете?

Шифрование не используем.

Что именно нужно смотреть в debug rtp?

Входящие вызовы с внешних номеров идут со звуком через раз, тоже не совсем понятная ситуация.


Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от mdenisov (ok) on 16-Май-13, 19:02 
> Что именно нужно смотреть в debug rtp?

Честно говоря сейчас уже не вспомню, у себя под нагрузкой включать и смотреть не готов (тяжелый дебаг), смотрите сами.

> Входящие вызовы с внешних номеров идут со звуком через раз, тоже не
> совсем понятная ситуация.

Какая версия IOS? Попробуйте обновиться на более другую из стабильных. Теоретически есть еще шанс глюков DSP. Кстати, Вы уверены что TDM часть беспроблемная? Такое конечно редко бывает, но мало ли. По идее все должно работать.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

9. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от MaximVT (ok) on 16-Май-13, 09:33 
Добавлю немного новой информации:

Удалось добиться нормальных входящих звонков, т.е. при звонке с сотового номера на городской звонок проходит нормально, гудки слышны, голос слышен в обеих трубках, обратно пока можем только звонить, голоса нет. Никаких настроек не делал, просто переприменил конфигурацию с CUCM на гейтвей и сделал рестарт гейтвея.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

13. "2911 (2 x VWIC3-2MFT-T1/E1) + CUCM (MGCP) - тишина в трубке"  +/
Сообщение от Andry (??) on 20-Май-16, 08:50 
> Добавлю немного новой информации:
> Удалось добиться нормальных входящих звонков, т.е. при звонке с сотового номера на
> городской звонок проходит нормально, гудки слышны, голос слышен в обеих трубках,
> обратно пока можем только звонить, голоса нет. Никаких настроек не делал,
> просто переприменил конфигурацию с CUCM на гейтвей и сделал рестарт гейтвея.

  Я бы добавил на войс-порт

cptone RU
bearer-cap Speech


Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру