The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"cisco nat"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"cisco nat" 
Сообщение от retro emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 08-Июл-04, 11:30  (MSK)
Имеется:
     Интернет---(serial0/1)cisco5350(fastethernet0/1)-----локальная сеть.
     IOS 12.2T
Требуется:
     Настроить на cisco nat таким образом, чтобы локлаьные машины (192.168.4.0.24)могли выходить в инет.

sh run
!
interface FastEthernet0/1
ip address 192.168.4.1 255.255.255.0
ip nat inside
!
!
interface Serial0/1
ip address 110.110.110.99 255.255.255.252
ip nat outside
!

ip nat pool nat_pool 100.1.1.100 100.1.1.100 prefix-length 24
ip nat inside source list 7 pool nat_pool
!
access-list 7 permit 192.168.4.0 0.0.0.255
!
При этом с локальной машины 192.168.4.10 выход в интернет осуществляется нормально. Со всех остальных - доступа нет. При этом отладка на cisco говорит следующее (в этот момент с машины 192.168.4.77 запускается
ping 193.233.86.162):

4d02h: NAT: failed to allocate address for 192.168.4.77, list/map 7
4d02h: NAT: translation failed (A), dropping packet s=192.168.4.77 d=192.168.1.

Теперь на cisco делаем:
clear ip nat transaction *
После чего пинг с машины 192.168.4.77 идет нормально, ... но теперь с других машин нет доступа во вне (в т.ч. и у 192.168.4.10).

Т.е. при данной конфигурации нат работает только для одной машины (которая первая отправит запрос в интернет. )

Может подскажете - в чем дело?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

  • cisco nat, Citrin, 11:40 , 08-Июл-04, (1)  
    • cisco nat, retro, 11:45 , 08-Июл-04, (3)  
  • cisco nat, ВОЛКА, 11:41 , 08-Июл-04, (2)  
    • cisco nat, retro, 11:46 , 08-Июл-04, (4)  
  • cisco nat, Jethro_Tull, 14:42 , 08-Июл-04, (5)  

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "cisco nat" 
Сообщение от Citrin emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 08-Июл-04, 11:40  (MSK)
>ip nat inside source list 7 pool nat_pool

Замените эту строчку на
ip nat inside source list 7 pool nat_pool overload

  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "cisco nat" 
Сообщение от retro emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 08-Июл-04, 11:45  (MSK)
>>ip nat inside source list 7 pool nat_pool
>
>Замените эту строчку на
>ip nat inside source list 7 pool nat_pool overload

Большое спасибо. Все работает.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "cisco nat" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 08-Июл-04, 11:41  (MSK)
no ip nat pool nat_pool 100.1.1.100 100.1.1.100 prefix-length 24
no ip nat inside source list 7 pool nat_pool

ip nat inside source list 7 int s0/1 overload


  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "cisco nat" 
Сообщение от retro emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 08-Июл-04, 11:46  (MSK)
>no ip nat pool nat_pool 100.1.1.100 100.1.1.100 prefix-length 24
>no ip nat inside source list 7 pool nat_pool
>
>ip nat inside source list 7 int s0/1 overload
Спасибо. И это тоже работает.


  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "cisco nat" 
Сообщение от Jethro_Tull emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 08-Июл-04, 14:42  (MSK)
На примере конфига своей киски: сделаешь по аналогии:

!
interface FastEthernet0/0
ip address x.x.x.x y.y.y.y   (ip и маска внешнего интерфейса в инет)
ip nat outside
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1
ip address a.b.c.d e.f.g.h  (ip и маска внутреннего интерф.)
ip nat inside
duplex auto
speed auto
no cdp enable
!
ip default-gateway k.l.m.n (шлюз провайдера)

ip nat pool EXT az.bz.cz.dz aaz.bb.z cc.z.ddz prefix-length X (диапазон адресов ("белых"), которые должны транслироваться в инет.

ip nat inside source list 10 pool EXT overload
ip classless
ip route 0.0.0.0 0.0.0.0 k.l.m.n
no ip http server
ip pim bidir-enable
!
Должен работать...

  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру