The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"IP/MPLS в GNS3 - маршрут есть, пинга нет."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 27-Фев-12, 12:02 
Добрый день. Приспичило настроить тестовую сеть ip/mpls на GNS3. Есть клиент, сидит в VRF под именем, допустим, vpn1. Настроил всё, маршруты до сетей этого клиента на PE-роутерах (с той и с другой стороны) есть, а пинг не идет - не пойму в чем проблема?  
Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от fantom (ok) on 27-Фев-12, 12:32 
> Добрый день. Приспичило настроить тестовую сеть ip/mpls на GNS3. Есть клиент, сидит
> в VRF под именем, допустим, vpn1. Настроил всё, маршруты до сетей
> этого клиента на PE-роутерах (с той и с другой стороны) есть,
> а пинг не идет - не пойму в чем проблема?

Конфиги де?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 27-Фев-12, 12:53 
>> Добрый день. Приспичило настроить тестовую сеть ip/mpls на GNS3. Есть клиент, сидит
>> в VRF под именем, допустим, vpn1. Настроил всё, маршруты до сетей
>> этого клиента на PE-роутерах (с той и с другой стороны) есть,
>> а пинг не идет - не пойму в чем проблема?
> Конфиги де?

PE1
hostname R9
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
ip vrf vpn1
rd 1:1
route-target export 1:10
route-target import 1:11
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip vrf forwarding vpn1
ip address 10.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
mpls ip
!
router rip
version 2
network 192.168.1.0
!
address-family ipv4 vrf vpn1
  redistribute bgp 1 metric transparent
  network 10.0.0.0
  no auto-summary
  version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
redistribute rip
neighbor 192.168.1.6 remote-as 1
no auto-summary
!
address-family vpnv4
  neighbor 192.168.1.6 activate
  neighbor 192.168.1.6 send-community both
  neighbor 192.168.1.6 next-hop-self
exit-address-family
!
address-family ipv4 vrf vpn1
  redistribute rip
  no synchronization
exit-address-family
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!

control-plane
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end
_______________________
PE2

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R10
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
ip vrf vpn1
rd 1:1
route-target export 1:11
route-target import 1:10
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!

interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip vrf forwarding vpn1
ip address 10.3.0.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 192.168.1.6 255.255.255.252
duplex auto
speed auto
mpls ip
!
router rip
version 2
network 192.168.1.0
!
address-family ipv4 vrf vpn1
  redistribute bgp 1 metric transparent
  network 10.0.0.0
  no auto-summary
  version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
redistribute rip
neighbor 192.168.1.1 remote-as 1
no auto-summary
!
address-family vpnv4
  neighbor 192.168.1.1 activate
  neighbor 192.168.1.1 send-community both
  neighbor 192.168.1.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf vpn1
  redistribute rip
  no synchronization
exit-address-family
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server

!
control-plane

!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end


таблица маршрутов vrf vpn1
PE1:
R    99.0.0.0/8 [120/1] via 10.1.1.1, 00:00:02, FastEthernet1/0
     10.0.0.0/30 is subnetted, 2 subnets
B       10.3.0.0 [200/0] via 192.168.1.6, 01:00:12
C       10.1.1.0 is directly connected, FastEthernet1/0
B    88.0.0.0/8 [200/1] via 192.168.1.6, 01:00:12

PE2
B    99.0.0.0/8 [200/1] via 192.168.1.1, 01:00:09
     10.0.0.0/30 is subnetted, 2 subnets
C       10.3.0.0 is directly connected, FastEthernet1/0
B       10.1.1.0 [200/0] via 192.168.1.1, 01:00:09
R    88.0.0.0/8 [120/1] via 10.3.0.2, 00:00:19, FastEthernet1/0


99.1.1.1 и 88.1.1.1 - лупбеки у клиентов, которые не пингуются.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от fantom (ok) on 27-Фев-12, 13:32 
>[оверквотинг удален]
> B       10.3.0.0 [200/0] via 192.168.1.6, 01:00:12
> C       10.1.1.0 is directly connected, FastEthernet1/0
> B    88.0.0.0/8 [200/1] via 192.168.1.6, 01:00:12
> PE2
> B    99.0.0.0/8 [200/1] via 192.168.1.1, 01:00:09
>      10.0.0.0/30 is subnetted, 2 subnets
> C       10.3.0.0 is directly connected, FastEthernet1/0
> B       10.1.1.0 [200/0] via 192.168.1.1, 01:00:09
> R    88.0.0.0/8 [120/1] via 10.3.0.2, 00:00:19, FastEthernet1/0
> 99.1.1.1 и 88.1.1.1 - лупбеки у клиентов, которые не пингуются.

И что с кого пингуете?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от fantom (ok) on 27-Фев-12, 13:34 
>[оверквотинг удален]
>> B       10.3.0.0 [200/0] via 192.168.1.6, 01:00:12
>> C       10.1.1.0 is directly connected, FastEthernet1/0
>> B    88.0.0.0/8 [200/1] via 192.168.1.6, 01:00:12
>> PE2
>> B    99.0.0.0/8 [200/1] via 192.168.1.1, 01:00:09
>>      10.0.0.0/30 is subnetted, 2 subnets
>> C       10.3.0.0 is directly connected, FastEthernet1/0
>> B       10.1.1.0 [200/0] via 192.168.1.1, 01:00:09
>> R    88.0.0.0/8 [120/1] via 10.3.0.2, 00:00:19, FastEthernet1/0
>> 99.1.1.1 и 88.1.1.1 - лупбеки у клиентов, которые не пингуются.

10.3.0.2 и 10.1.1.1 пингаются или нет?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 27-Фев-12, 14:05 
>[оверквотинг удален]
>>> C       10.1.1.0 is directly connected, FastEthernet1/0
>>> B    88.0.0.0/8 [200/1] via 192.168.1.6, 01:00:12
>>> PE2
>>> B    99.0.0.0/8 [200/1] via 192.168.1.1, 01:00:09
>>>      10.0.0.0/30 is subnetted, 2 subnets
>>> C       10.3.0.0 is directly connected, FastEthernet1/0
>>> B       10.1.1.0 [200/0] via 192.168.1.1, 01:00:09
>>> R    88.0.0.0/8 [120/1] via 10.3.0.2, 00:00:19, FastEthernet1/0
>>> 99.1.1.1 и 88.1.1.1 - лупбеки у клиентов, которые не пингуются.
> 10.3.0.2 и 10.1.1.1 пингаются или нет?

10.3.0.2 - интерфейс клиента в сторону PE2
10.1.1.1 - интерфейс на PE1 в сторону клиента
10.1.1.2 - интерфейс клиента в сторону PE1

на PE1 команда ping vrf vpn1 10.1.1.2 проходит
на PE2 таже команда не проходит
тоже самое наоборот 10.3.0.2 на PE2 пингует, c PE1 не пингует. Traceroute не показывает ничего - с первого хопа * * *

топология:
клиент-----PE1---P---PE2---клиент

на P только подняты два интерфейса и на них mpls

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

8. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от fantom (ok) on 27-Фев-12, 14:18 
>[оверквотинг удален]
>>>> R    88.0.0.0/8 [120/1] via 10.3.0.2, 00:00:19, FastEthernet1/0
>>>> 99.1.1.1 и 88.1.1.1 - лупбеки у клиентов, которые не пингуются.
>> 10.3.0.2 и 10.1.1.1 пингаются или нет?
> 10.3.0.2 - интерфейс клиента в сторону PE2
> 10.1.1.1 - интерфейс на PE1 в сторону клиента
> 10.1.1.2 - интерфейс клиента в сторону PE1
> на PE1 команда ping vrf vpn1 10.1.1.2 проходит
> на PE2 таже команда не проходит
> тоже самое наоборот 10.3.0.2 на PE2 пингует, c PE1 не пингует. Traceroute
> не показывает ничего - с первого хопа * * *

А что выступает клиентом? покажите таблицу маршрутизации клиента.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от jied83 on 27-Фев-12, 14:19 
>[оверквотинг удален]
>>>> R    88.0.0.0/8 [120/1] via 10.3.0.2, 00:00:19, FastEthernet1/0
>>>> 99.1.1.1 и 88.1.1.1 - лупбеки у клиентов, которые не пингуются.
>> 10.3.0.2 и 10.1.1.1 пингаются или нет?
> 10.3.0.2 - интерфейс клиента в сторону PE2
> 10.1.1.1 - интерфейс на PE1 в сторону клиента
> 10.1.1.2 - интерфейс клиента в сторону PE1
> на PE1 команда ping vrf vpn1 10.1.1.2 проходит
> на PE2 таже команда не проходит
> тоже самое наоборот 10.3.0.2 на PE2 пингует, c PE1 не пингует. Traceroute
> не показывает ничего - с первого хопа * * *

с pe1 ping vrf vpn1 10.3.0.1

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

10. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 27-Фев-12, 14:26 
>[оверквотинг удален]
>>>>> 99.1.1.1 и 88.1.1.1 - лупбеки у клиентов, которые не пингуются.
>>> 10.3.0.2 и 10.1.1.1 пингаются или нет?
>> 10.3.0.2 - интерфейс клиента в сторону PE2
>> 10.1.1.1 - интерфейс на PE1 в сторону клиента
>> 10.1.1.2 - интерфейс клиента в сторону PE1
>> на PE1 команда ping vrf vpn1 10.1.1.2 проходит
>> на PE2 таже команда не проходит
>> тоже самое наоборот 10.3.0.2 на PE2 пингует, c PE1 не пингует. Traceroute
>> не показывает ничего - с первого хопа * * *
> с pe1 ping vrf vpn1 10.3.0.1

не пингует.

Маршруты на клиентах (клиентом у меня выступает роутер с поднятым лупбеком - при успехе лупбек должен пинговаться на обоих концах топологии)

клиент (loopback 99.1.1.1)------PE1-----P------PE2-------клиент(lo1 88.1.1.1)

конфиг клиентов:
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R11
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!

interface Loopback1
ip address 99.1.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 10.0.0.0
network 99.0.0.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

-=---------------------------
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R12
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!

interface Loopback1
ip address 88.1.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.3.0.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 10.0.0.0
network 88.0.0.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

Маршруты на втором клиенте:
R    99.0.0.0/8 [120/2] via 10.3.0.1, 00:00:08, FastEthernet1/0 (получил от PE2 по редистрибьюции из bgp в rip)
     10.0.0.0/30 is subnetted, 2 subnets
C       10.3.0.0 is directly connected, FastEthernet1/0
R       10.1.1.0 [120/1] via 10.3.0.1, 00:00:08, FastEthernet1/0
     88.0.0.0/24 is subnetted, 1 subnets
C       88.1.1.0 is directly connected, Loopback1

На первом:
     99.0.0.0/24 is subnetted, 1 subnets
C       99.1.1.0 is directly connected, Loopback1
     10.0.0.0/30 is subnetted, 2 subnets
R       10.3.0.0 [120/1] via 10.1.1.2, 00:00:24, FastEthernet1/0
C       10.1.1.0 is directly connected, FastEthernet1/0
R    88.0.0.0/8 [120/2] via 10.1.1.2, 00:00:24, FastEthernet1/0 (получил от PE1 по редистрибьюции из bgp в rip)

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от fantom (ok) on 27-Фев-12, 14:43 
>[оверквотинг удален]
> C       88.1.1.0 is directly connected, Loopback1
> На первом:
>      99.0.0.0/24 is subnetted, 1 subnets
> C       99.1.1.0 is directly connected, Loopback1
>      10.0.0.0/30 is subnetted, 2 subnets
> R       10.3.0.0 [120/1] via 10.1.1.2, 00:00:24,
> FastEthernet1/0
> C       10.1.1.0 is directly connected, FastEthernet1/0
> R    88.0.0.0/8 [120/2] via 10.1.1.2, 00:00:24, FastEthernet1/0 (получил от
> PE1 по редистрибьюции из bgp в rip)

На первом клиенте
ping 10.1.1.2 so 99.1.1.1

ping 10.3.0.2 so 99.1.1.1

ping 10.3.0.2 so 10.1.1.1

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 27-Фев-12, 14:51 
>[оверквотинг удален]
>>      10.0.0.0/30 is subnetted, 2 subnets
>> R       10.3.0.0 [120/1] via 10.1.1.2, 00:00:24,
>> FastEthernet1/0
>> C       10.1.1.0 is directly connected, FastEthernet1/0
>> R    88.0.0.0/8 [120/2] via 10.1.1.2, 00:00:24, FastEthernet1/0 (получил от
>> PE1 по редистрибьюции из bgp в rip)
> На первом клиенте

ping 10.1.1.2 so 99.1.1.1 пингует
ping 10.3.0.2 so 99.1.1.1  нет
ping 10.3.0.2 so 10.1.1.1 нет

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от jied83 on 27-Фев-12, 15:09 
>[оверквотинг удален]
>>>      10.0.0.0/30 is subnetted, 2 subnets
>>> R       10.3.0.0 [120/1] via 10.1.1.2, 00:00:24,
>>> FastEthernet1/0
>>> C       10.1.1.0 is directly connected, FastEthernet1/0
>>> R    88.0.0.0/8 [120/2] via 10.1.1.2, 00:00:24, FastEthernet1/0 (получил от
>>> PE1 по редистрибьюции из bgp в rip)
>> На первом клиенте
>  ping 10.1.1.2 so 99.1.1.1 пингует
>  ping 10.3.0.2 so 99.1.1.1  нет
>  ping 10.3.0.2 so 10.1.1.1 нет

вы попробуйте на ПЕ сделать лупбеки и БГП делать через них

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 27-Фев-12, 15:27 
>[оверквотинг удален]
>>>> R       10.3.0.0 [120/1] via 10.1.1.2, 00:00:24,
>>>> FastEthernet1/0
>>>> C       10.1.1.0 is directly connected, FastEthernet1/0
>>>> R    88.0.0.0/8 [120/2] via 10.1.1.2, 00:00:24, FastEthernet1/0 (получил от
>>>> PE1 по редистрибьюции из bgp в rip)
>>> На первом клиенте
>>  ping 10.1.1.2 so 99.1.1.1 пингует
>>  ping 10.3.0.2 so 99.1.1.1  нет
>>  ping 10.3.0.2 so 10.1.1.1 нет
> вы попробуйте на ПЕ сделать лупбеки и БГП делать через них

Заработало!! А в чем проблема, почему только так работает?? о_О

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от fantom (ok) on 27-Фев-12, 15:35 
>[оверквотинг удален]
>>>>> FastEthernet1/0
>>>>> C       10.1.1.0 is directly connected, FastEthernet1/0
>>>>> R    88.0.0.0/8 [120/2] via 10.1.1.2, 00:00:24, FastEthernet1/0 (получил от
>>>>> PE1 по редистрибьюции из bgp в rip)
>>>> На первом клиенте
>>>  ping 10.1.1.2 so 99.1.1.1 пингует
>>>  ping 10.3.0.2 so 99.1.1.1  нет
>>>  ping 10.3.0.2 so 10.1.1.1 нет
>> вы попробуйте на ПЕ сделать лупбеки и БГП делать через них
> Заработало!! А в чем проблема, почему только так работает?? о_О

кстати у циски есть рекомендация - iBGP строить через loop интерфейсы. (что впринципе логично)

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

16. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 27-Фев-12, 15:36 
>[оверквотинг удален]
>>>>>> R    88.0.0.0/8 [120/2] via 10.1.1.2, 00:00:24, FastEthernet1/0 (получил от
>>>>>> PE1 по редистрибьюции из bgp в rip)
>>>>> На первом клиенте
>>>>  ping 10.1.1.2 so 99.1.1.1 пингует
>>>>  ping 10.3.0.2 so 99.1.1.1  нет
>>>>  ping 10.3.0.2 so 10.1.1.1 нет
>>> вы попробуйте на ПЕ сделать лупбеки и БГП делать через них
>> Заработало!! А в чем проблема, почему только так работает?? о_О
> кстати у циски есть рекомендация - iBGP строить через loop интерфейсы. (что
> впринципе логично)

Ну я понимаю, что лучше через лупбеки для отказоустойчивости, тут просто не стал - на скорую руку конфиг накатил. Просто не понятно почему так не работает - не через лупбеки....


Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

17. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от jied83 on 27-Фев-12, 16:55 
>[оверквотинг удален]
>>>>>  ping 10.1.1.2 so 99.1.1.1 пингует
>>>>>  ping 10.3.0.2 so 99.1.1.1  нет
>>>>>  ping 10.3.0.2 so 10.1.1.1 нет
>>>> вы попробуйте на ПЕ сделать лупбеки и БГП делать через них
>>> Заработало!! А в чем проблема, почему только так работает?? о_О
>> кстати у циски есть рекомендация - iBGP строить через loop интерфейсы. (что
>> впринципе логично)
> Ну я понимаю, что лучше через лупбеки для отказоустойчивости, тут просто не
> стал - на скорую руку конфиг накатил. Просто не понятно почему
> так не работает - не через лупбеки....

http://www.cisco.com/en/US/docs/ios/system/messages/guide/sm...

ищем %BGP-4-VPN_NH_IF: Nexthop **** may not be reachable from neighbor **** - not a loopback

грубо говоря PHP произошло на 1 хоп раньше...и твой P роутер не знал что делать с пакетом без метки

и да если циска ругается, то лучше прислушаться )

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

18. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 29-Фев-12, 16:49 
Теперь аналогичная ситуация возникла, но стык между PE и клиентами по BGP, а не по RIP.
Также маршруты отдаются между двумя PE, но трафик не идет.

PE1
---------------
ip vrf vpn1
rd 1:1
--More--
*Feb 29 15:49:00.223: %SYS-5-CONFIG_I: Configured from console by console
route-target export 1:10
route-target import 1:11
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3

interface Loopback1
ip address 88.1.1.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip vrf forwarding vpn1
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 88.1.1.1 remote-as 65001
neighbor 88.1.1.1 update-source Loopback1
no auto-summary
!
address-family vpnv4
  neighbor 88.1.1.1 activate
  neighbor 88.1.1.1 send-community both
  neighbor 88.1.1.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf vpn1
  neighbor 10.1.1.1 remote-as 65000 (стык по ip-интерфейса - всё поднимается)
  neighbor 10.1.1.1 activate
  no synchronization
exit-address-family
!
ip forward-protocol nd
ip route 88.1.1.1 255.255.255.255 FastEthernet1/1
ip route vrf vpn1 99.1.1.1 255.255.255.255 10.1.1.1 (пытался поднять BGP между PE и клинтом через лупбек - не получается, маршрут удалять не стал.)
!
no ip http server
no ip http secure-server

-----------------------
PE2

ip vrf vpn1
rd 1:1
route-target export 1:11
route-target import 1:10
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface Loopback1
ip address 88.1.1.1 255.255.255.255
!
interface Loopback10
ip address 55.55.55.55 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/1
ip vrf forwarding vpn1
ip address 10.3.1.1 255.255.255.0
duplex auto
speed auto
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 88.1.1.2 remote-as 65001
neighbor 88.1.1.2 update-source Loopback1
no auto-summary
!
address-family vpnv4
  neighbor 88.1.1.2 activate
  neighbor 88.1.1.2 send-community both
  neighbor 88.1.1.2 next-hop-self
exit-address-family
!
address-family ipv4 vrf vpn1
  neighbor 66.66.66.66 remote-as 64000 (здесь стык через лупбеки - не работает)
  neighbor 66.66.66.66 update-source Loopback10
  neighbor 66.66.66.66 activate
  no synchronization
exit-address-family
!
ip forward-protocol nd
ip route 88.1.1.2 255.255.255.255 FastEthernet1/0
ip route vrf vpn1 66.66.66.66 255.255.255.255 10.3.1.2
!
no ip http server
no ip http secure-server

---------------------------

клиент1

ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!

interface Loopback1
ip address 99.1.1.1 255.255.255.0
!
interface Loopback10
ip address 33.33.33.33 255.255.255.0 (типа сеть какая-то, которая должна быть доступна со второго клиента на другой стороне)
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 33.33.33.0 0.0.0.255 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
redistribute ospf 1
neighbor 10.1.1.2 remote-as 65001
no auto-summary
!
ip forward-protocol nd
ip route 99.1.1.2 255.255.255.255 10.1.1.2 (маршрут до лупбека на PE1 для поднятия BGP)
!
no ip http server
no ip http secure-server
!

---------------------------------

клиент2
interface Loopback1
ip address 66.66.66.66 255.255.255.255
!
interface Loopback10
ip address 44.44.44.44 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.3.1.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 44.44.44.0 0.0.0.255 area 0
!
router bgp 64000  (здесь пытаюсь сделать стык через лупбеки - не работает)
no synchronization
bgp log-neighbor-changes
redistribute ospf 1
neighbor 55.55.55.55 remote-as 65001
neighbor 55.55.55.55 update-source Loopback1
no auto-summary
!
ip forward-protocol nd
ip route 55.55.55.55 255.255.255.255 10.3.1.1
!
no ip http server
no ip http secure-server
!


В прошлый раз достаточно было поднять iBGP между двумя PE через лупбеки - и всё заработало.
Здесь, как видите, между PE через лупбеки все поднято...пытался поднять между PE и клиентом - не выходит.

С таким конфигом стык по BGP между клиентом1 и PE1 есть, а между PE2 и клиентом 2 нету.

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

19. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от jied83 on 01-Мрт-12, 08:51 
>[оверквотинг удален]
> !
> no ip http server
> no ip http secure-server
> !
> В прошлый раз достаточно было поднять iBGP между двумя PE через лупбеки
> - и всё заработало.
> Здесь, как видите, между PE через лупбеки все поднято...пытался поднять между PE
> и клиентом - не выходит.
> С таким конфигом стык по BGP между клиентом1 и PE1 есть, а
> между PE2 и клиентом 2 нету.

а вы с клиента2 видите 55.55.55.55 255.255.255.255? скорее всего нет, потому что лупбек10 у вас находится в глобальной таблице маршрутизации, поэтому и не получается соседства.
Можно попробывать воспользоваться route leak'ами

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

20. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 01-Мрт-12, 09:07 
>[оверквотинг удален]
>> В прошлый раз достаточно было поднять iBGP между двумя PE через лупбеки
>> - и всё заработало.
>> Здесь, как видите, между PE через лупбеки все поднято...пытался поднять между PE
>> и клиентом - не выходит.
>> С таким конфигом стык по BGP между клиентом1 и PE1 есть, а
>> между PE2 и клиентом 2 нету.
> а вы с клиента2 видите 55.55.55.55 255.255.255.255? скорее всего нет, потому что
> лупбек10 у вас находится в глобальной таблице маршрутизации, поэтому и не
> получается соседства.
> Можно попробывать воспользоваться route leak'ами

С клиента 2 55.55.55.55 не вижу, но с PE2 66.66.66.66 пингуется через ping vrf vpn1 66.66.66.66. Соседство по bgp не устанавливается, естественно, как только делаю обычным методом (без лупбеков) - соседство устанавливается. Не могли бы описать процесс с route leak-ами?

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

21. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от jied83 (ok) on 01-Мрт-12, 09:35 
>[оверквотинг удален]
>>> С таким конфигом стык по BGP между клиентом1 и PE1 есть, а
>>> между PE2 и клиентом 2 нету.
>> а вы с клиента2 видите 55.55.55.55 255.255.255.255? скорее всего нет, потому что
>> лупбек10 у вас находится в глобальной таблице маршрутизации, поэтому и не
>> получается соседства.
>> Можно попробывать воспользоваться route leak'ами
> С клиента 2 55.55.55.55 не вижу, но с PE2 66.66.66.66 пингуется через
> ping vrf vpn1 66.66.66.66. Соседство по bgp не устанавливается, естественно, как
> только делаю обычным методом (без лупбеков) - соседство устанавливается. Не могли
> бы описать процесс с route leak-ами?

по мне так лучше так не делать, делайте как на клиенте 1
можно запихать сам лупбек в vrf
а по поводу роутликов:
ip route vrf vpn1 55.55.55.55 255.255.255.255 FastEthernet1/0 192.168.1.1 global
ip route 66.66.66.66 255.255.255.255 FastEthernet1/1
55.55.55.55 и 66.66.66.66 будут видеть друг друга при условии что 192.168.1.1 знает, где искать 55.55.55.55

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

22. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 01-Мрт-12, 10:07 
блин...что-то не выходит..
Упростил схему: один PE, к нему два CE. Один из них отдает сеть 88.88.88.0. На другом в sh ip bgp она присутствует, но пинг не идет - останавливается на PE.

PE:
interface FastEthernet1/0
ip vrf forwarding vpn1
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip vrf forwarding vpn1
ip address 10.2.1.2 255.255.255.0
duplex auto
speed auto
!
router bgp 2
no synchronization
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf vpn1
  neighbor 10.1.1.1 remote-as 1
  neighbor 10.1.1.1 activate
  neighbor 10.2.1.1 remote-as 3
  neighbor 10.2.1.1 activate
  no synchronization
exit-address-family
-----------
CE1 отдает 88.88.88.88 по bgp PE-роутеру
interface Loopback1
ip address 88.88.88.88 255.255.255.255
!
interface FastEthernet1/0
ip address 10.2.1.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 88.88.88.0 0.0.0.255 area 0
!
router bgp 3
no synchronization
bgp log-neighbor-changes
redistribute ospf 1
neighbor 10.2.1.2 remote-as 2
no auto-summary
---------
CE2
!
interface FastEthernet1/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.2 remote-as 2
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server


В глобальной таблице маршрутизации на PE пусто..
88.88.88.88 не пингуется с CE2. С PE ping vrf vpn1 88.88.88.88 проходит.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

23. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от jied83 (ok) on 01-Мрт-12, 11:46 
>[оверквотинг удален]
>  bgp log-neighbor-changes
>  neighbor 10.1.1.2 remote-as 2
>  no auto-summary
> !
> ip forward-protocol nd
> !
> no ip http server
> no ip http secure-server
> В глобальной таблице маршрутизации на PE пусто..
> 88.88.88.88 не пингуется с CE2. С PE ping vrf vpn1 88.88.88.88 проходит.

PE
sh ip route vrf vpn1
CE2
sh ip route

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

24. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 01-Мрт-12, 12:27 
>[оверквотинг удален]
>> ip forward-protocol nd
>> !
>> no ip http server
>> no ip http secure-server
>> В глобальной таблице маршрутизации на PE пусто..
>> 88.88.88.88 не пингуется с CE2. С PE ping vrf vpn1 88.88.88.88 проходит.
>  PE
> sh ip route vrf vpn1
> CE2
> sh ip route

CE2
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet1/0
     88.0.0.0/32 is subnetted, 1 subnets
B       88.88.88.88 [20/0] via 10.1.1.2, 00:00:39

PE
     10.0.0.0/24 is subnetted, 2 subnets
C       10.2.1.0 is directly connected, FastEthernet1/1
C       10.1.1.0 is directly connected, FastEthernet1/0
     88.0.0.0/32 is subnetted, 1 subnets
B       88.88.88.88 [20/0] via 10.2.1.1, 00:00:33

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

25. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от jied83 (ok) on 01-Мрт-12, 12:30 
>[оверквотинг удален]
>>> 88.88.88.88 не пингуется с CE2. С PE ping vrf vpn1 88.88.88.88 проходит.
>>  PE
>> sh ip route vrf vpn1
>> CE2
>> sh ip route
> CE2
>      10.0.0.0/24 is subnetted, 1 subnets
> C       10.1.1.0 is directly connected, FastEthernet1/0
>      88.0.0.0/32 is subnetted, 1 subnets
> B       88.88.88.88 [20/0] via 10.1.1.2, 00:00:39

ну и на СЕ1
sh ip route

> PE
>      10.0.0.0/24 is subnetted, 2 subnets
> C       10.2.1.0 is directly connected, FastEthernet1/1
> C       10.1.1.0 is directly connected, FastEthernet1/0
>      88.0.0.0/32 is subnetted, 1 subnets
> B       88.88.88.88 [20/0] via 10.2.1.1, 00:00:33

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

26. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 01-Мрт-12, 12:32 
>[оверквотинг удален]
>>> sh ip route vrf vpn1
>>> CE2
>>> sh ip route
>> CE2
>>      10.0.0.0/24 is subnetted, 1 subnets
>> C       10.1.1.0 is directly connected, FastEthernet1/0
>>      88.0.0.0/32 is subnetted, 1 subnets
>> B       88.88.88.88 [20/0] via 10.1.1.2, 00:00:39
>  ну и на СЕ1
> sh ip route

CE1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.2.1.0 is directly connected, FastEthernet1/0
     88.0.0.0/32 is subnetted, 1 subnets
C       88.88.88.88 is directly connected, Loopback1

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

27. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от jied83 (ok) on 01-Мрт-12, 12:38 
>[оверквотинг удален]
>>> C       10.1.1.0 is directly connected, FastEthernet1/0
>>>      88.0.0.0/32 is subnetted, 1 subnets
>>> B       88.88.88.88 [20/0] via 10.1.1.2, 00:00:39
>>  ну и на СЕ1
>> sh ip route
> CE1
>      10.0.0.0/24 is subnetted, 1 subnets
> C       10.2.1.0 is directly connected, FastEthernet1/0
>      88.0.0.0/32 is subnetted, 1 subnets
> C       88.88.88.88 is directly connected, Loopback1

как вы думаете куда роутер СЕ1 отправит пакет с дестинейшеном 10.1.1.1?

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

28. "IP/MPLS в GNS3 - маршрут есть, пинга нет."  +/
Сообщение от Huaweiboy (ok) on 01-Мрт-12, 12:43 
>[оверквотинг удален]
>>>>      88.0.0.0/32 is subnetted, 1 subnets
>>>> B       88.88.88.88 [20/0] via 10.1.1.2, 00:00:39
>>>  ну и на СЕ1
>>> sh ip route
>> CE1
>>      10.0.0.0/24 is subnetted, 1 subnets
>> C       10.2.1.0 is directly connected, FastEthernet1/0
>>      88.0.0.0/32 is subnetted, 1 subnets
>> C       88.88.88.88 is directly connected, Loopback1
> как вы думаете куда роутер СЕ1 отправит пакет с дестинейшеном 10.1.1.1?

Всё, работает) тупанул - бывает)))

Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру