The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"nat и маршрутизация"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"nat и маршрутизация"  +/
Сообщение от sash555 email(ok) on 09-Фев-10, 12:58 
Здравствуй многоуважаемый ALL.
Давно меня мучил вопрос. Есть некий CISCO. У него, например, самый простенький конфиг для ната:
interface FastEthernet0/0
ip address 10.10.10.14 255.255.255.0
ip nat inside

interface FastEthernet0/1
ip address 212.152.XX.XX 255.255.255.192
ip nat outside

ip nat inside source list 1 interface FastEthernet0/1 overload

access-list 1 permit 10.10.10.0 0.0.0.255

как видно из него натятся адреса из внутренней подсети 10.10.10.0/24. За ним стоит роутер, который имеет 2 интерфейса один из подсети 10.10.10.0/24 другой, например из 192.168.1.0/24. На роутере ната нет. На циске прописан маршрут в подсеть 192.168.1.0/24. И интернет есть у клиентов живущих за роутером, из подсети 192.168.1.0/24.

Вроде совершенно понятная схема. Но для меня все это время было совершенной загадкой почему же все таки она работает? Ведь у клиентов IP адреса из подсети 192.168.1.0/24 и циска их видит такими же. А на ней правило (для ната) для подсети 10.10.10.0/24 той, что перед роутером. Так что получается ей на правило пофиг или что? Прошу объяснить поконкретней. Спасибо.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "nat и маршрутизация"  +/
Сообщение от sash555 email(ok) on 09-Фев-10, 14:43 
Может я что не так спрашиваю? Или может не достаточно понятен мой вопрос. Я просто хотел его уточнить. Вопрос состоит в том, что мне бы было бы понятнее если бы эта схема не работала, или работала, но при добавлении в акцес-лист подсети 192.168.1.0/24

Вопрос то вроде для спеца элементарный... Разъясните уж, не сочтите за труд.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "nat и маршрутизация"  +/
Сообщение от shadow_alone (ok) on 09-Фев-10, 16:10 
а Вы уверены что 192.168** не натиться?

включите debug ip nat

и смотрите, кто как ходит.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "nat и маршрутизация"  +/
Сообщение от sash555 email(ok) on 09-Фев-10, 16:14 
я уверен что как раз натится, иначе бы интернета не было, но вот почему оно натится? У меня как раз в этом вопрос

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "nat и маршрутизация"  +/
Сообщение от shadow_alone (ok) on 09-Фев-10, 16:22 
ну вот и разбирайтесь тогда не в циске, а на рутере, если натиться, то ничего непонятного здесь нет
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "nat и маршрутизация"  +/
Сообщение от sash555 email(ok) on 09-Фев-10, 16:25 
На роутере нат выключен, что в нем разбираться?

>ну вот и разбирайтесь тогда не в циске, а на рутере, если
>натиться, то ничего непонятного здесь нет

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "nat и маршрутизация"  +/
Сообщение от shadow_alone (ok) on 09-Фев-10, 16:30 
я ж сказал, включите debug на циске, и посмотрите, натиться ли?
или Ваше "уверен" на чем то конкретном основано?
"я сам настраивал" - не в счет.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "nat и маршрутизация"  +/
Сообщение от sash555 email(ok) on 09-Фев-10, 17:03 
Ну основано как раз на этом в первую очередь (что сам настраивал)
sho ip nat tra | i 192.168.1
tcp 212.152.XX.XX:1027 192.168.1.155:1104 208.117.241.150:80 208.117.241.150:80
tcp 212.152.XX.XX:1377 192.168.1.155:1293 208.117.241.150:80 208.117.241.150:80
tcp 212.152.XX.XX:1166 192.168.1.156:1060 208.117.241.164:80 208.117.241.164:80
tcp 212.152.XX.XX:3582 192.168.1.198:3582 81.177.34.139:80   81.177.34.139:80
tcp 212.152.XX.XX:3690 192.168.1.198:3690 81.177.34.139:80   81.177.34.139:80
tcp 212.152.XX.XX:3997 192.168.1.198:3997 74.125.87.139:80   74.125.87.139:80
.....
>я ж сказал, включите debug на циске, и посмотрите, натиться ли?
>или Ваше "уверен" на чем то конкретном основано?
>"я сам настраивал" - не в счет.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру