The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"HELP ---OSPF на GRE туннеле"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"HELP ---OSPF на GRE туннеле"  +/
Сообщение от Axellll email(ok) on 04-Авг-09, 08:08 
Приветствую всех. Народ, помогите, пожалуйста. Такая проблема, есть 2 канала связи- основной и резервный. Есть 2 циски одна в головном офисе вторая в филиале. Между ними поднят GRE туннель. Теперь настраиваю OSPF. Как только вношу в в Router ospf: network{адрес туннеля} маска area id, интерфейс Tunnel0 падает в down. Удаляю этот network из router ospf --поднимается. Что за фигня такая? не подскажите?Может что то забываю сделать?
Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от GolDi (??) on 04-Авг-09, 09:13 
>Приветствую всех. Народ, помогите, пожалуйста. Такая проблема, есть 2 канала связи- основной
>и резервный. Есть 2 циски одна в головном офисе вторая в
>филиале. Между ними поднят GRE туннель. Теперь настраиваю OSPF. Как только
>вношу в в Router ospf: network{адрес туннеля} маска area id, интерфейс
>Tunnel0 падает в down. Удаляю этот network из router ospf --поднимается.
>Что за фигня такая? не подскажите?Может что то забываю сделать?

А зачем вы так делаете? Туннель не может принадлежать какой-либо области.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от fantom (??) on 04-Авг-09, 09:23 
>Приветствую всех. Народ, помогите, пожалуйста. Такая проблема, есть 2 канала связи- основной
>и резервный. Есть 2 циски одна в головном офисе вторая в
>филиале. Между ними поднят GRE туннель. Теперь настраиваю OSPF. Как только
>вношу в в Router ospf: network{адрес туннеля} маска area id, интерфейс
>Tunnel0 падает в down. Удаляю этот network из router ospf --поднимается.
>Что за фигня такая? не подскажите?Может что то забываю сделать?

Приходит маршрут, который "перебивает" маршрут необходимый для построения тунеля.
Если подождать подольше - должны увидеть как тунель дергается up-down и следом OSPF колбасит (тоже up-down).

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Axellll email(ok) on 04-Авг-09, 10:22 
>>Приветствую всех. Народ, помогите, пожалуйста. Такая проблема, есть 2 канала связи- основной
>>и резервный. Есть 2 циски одна в головном офисе вторая в
>>филиале. Между ними поднят GRE туннель. Теперь настраиваю OSPF. Как только
>>вношу в в Router ospf: network{адрес туннеля} маска area id, интерфейс
>>Tunnel0 падает в down. Удаляю этот network из router ospf --поднимается.
>>Что за фигня такая? не подскажите?Может что то забываю сделать?
>
>Приходит маршрут, который "перебивает" маршрут необходимый для построения тунеля.
>Если подождать подольше - должны увидеть как тунель дергается up-down и следом
>OSPF колбасит (тоже up-down).

И что посоветуете?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от GolDi (??) on 04-Авг-09, 10:37 
>[оверквотинг удален]
>>>филиале. Между ними поднят GRE туннель. Теперь настраиваю OSPF. Как только
>>>вношу в в Router ospf: network{адрес туннеля} маска area id, интерфейс
>>>Tunnel0 падает в down. Удаляю этот network из router ospf --поднимается.
>>>Что за фигня такая? не подскажите?Может что то забываю сделать?
>>
>>Приходит маршрут, который "перебивает" маршрут необходимый для построения тунеля.
>>Если подождать подольше - должны увидеть как тунель дергается up-down и следом
>>OSPF колбасит (тоже up-down).
>
>И что посоветуете?

покажите конфиг в части ospf

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Axellll email(ok) on 05-Авг-09, 08:00 
>[оверквотинг удален]
>>>>Tunnel0 падает в down. Удаляю этот network из router ospf --поднимается.
>>>>Что за фигня такая? не подскажите?Может что то забываю сделать?
>>>
>>>Приходит маршрут, который "перебивает" маршрут необходимый для построения тунеля.
>>>Если подождать подольше - должны увидеть как тунель дергается up-down и следом
>>>OSPF колбасит (тоже up-down).
>>
>>И что посоветуете?
>
>покажите конфиг в части ospf

router ospf 100
log-adjacency-changes
network 10.10.... 0.0.0.0 area 0  - это адрес туннеля
network 192.168.1.2 0.0.0.0 area 0 - это loopback, он же является Router ID
network 192.168.2.. 0.0.0.0 area 0 - это LAN филиала
network 192.168.3.. 0.0.0.0 area 0 - это спутник
Это конфиг филиальского маршрутизатора. Здесь не падает интерфейс Tunnel0

router ospf 100
log-adjacency-changes
network 192.168.1.1 0.0.0.0 area 0- это loopback, он же является Router ID
network 192.168.3.2 0.0.0.0 area 0 - спутник
Это конфиг  маршрутизатора в центральном офисе. Именно здесь как только добавляю интерфейс Tunnel0 он падает в down

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от GolDi (??) on 05-Авг-09, 10:44 
>[оверквотинг удален]
>>>И что посоветуете?
>>
>>покажите конфиг в части ospf
>
>router ospf 100
> log-adjacency-changes
> network 10.10.... 0.0.0.0 area 0  - это адрес туннеля
> network 192.168.1.2 0.0.0.0 area 0 - это loopback, он же является
>Router ID
> network 192.168.2.. 0.0.0.0 area 0 - это LAN филиала

  А что у LAN такая маска?
>[оверквотинг удален]
> network 192.168.3.. 0.0.0.0 area 0 - это спутник
>Это конфиг филиальского маршрутизатора. Здесь не падает интерфейс Tunnel0
>
>router ospf 100
> log-adjacency-changes
> network 192.168.1.1 0.0.0.0 area 0- это loopback, он же является Router
>ID
> network 192.168.3.2 0.0.0.0 area 0 - спутник
> Это конфиг  маршрутизатора в центральном офисе. Именно здесь как только
>добавляю интерфейс Tunnel0 он падает в down

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Axellll email(ok) on 05-Авг-09, 12:17 
>[оверквотинг удален]
>> network 192.168.3.. 0.0.0.0 area 0 - это спутник
>>Это конфиг филиальского маршрутизатора. Здесь не падает интерфейс Tunnel0
>>
>>router ospf 100
>> log-adjacency-changes
>> network 192.168.1.1 0.0.0.0 area 0- это loopback, он же является Router
>>ID
>> network 192.168.3.2 0.0.0.0 area 0 - спутник
>> Это конфиг  маршрутизатора в центральном офисе. Именно здесь как только
>>добавляю интерфейс Tunnel0 он падает в down

там 255.255.255.0 --  я просто такую поставил

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Serb on 04-Авг-09, 16:57 
создать опорный маршрут на tunnel destination с маской 32


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Terebok (ok) on 24-Авг-09, 18:20 
> создать опорный маршрут на tunnel destination с маской 32

На Central office и Branch роутерах нужно прописать статические маршруты для tunnel destination.

Примерно так:

R1(config)# ip route 10.3.3.3 255.255.255.255  serial 0
R3(config)# ip route 10.1.1.1 255.255.255.255 serial 1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Terebok (ok) on 24-Авг-09, 18:23 
>> создать опорный маршрут на tunnel destination с маской 32
>
>На Central office и Branch роутерах нужно прописать статические маршруты для tunnel
>destination.
>
>Примерно так:
>
>R1(config)# ip route 10.3.3.3 255.255.255.255  serial 0
>R3(config)# ip route 10.1.1.1 255.255.255.255 serial 1

На сколько я понимаю, проблема в рекурсивном роутинге

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Николай (??) on 21-Сен-09, 12:40 
>[оверквотинг удален]
>>
>>На Central office и Branch роутерах нужно прописать статические маршруты для tunnel
>>destination.
>>
>>Примерно так:
>>
>>R1(config)# ip route 10.3.3.3 255.255.255.255  serial 0
>>R3(config)# ip route 10.1.1.1 255.255.255.255 serial 1
>
>На сколько я понимаю, проблема в рекурсивном роутинге

Я не пойму какой диапазон подсети для тунеля покажите маску сети используемую на туннельных окончаниях. Анонсирование IP тунеля с маской 32 смысла не имеет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Николай (??) on 21-Сен-09, 12:50 
проблема в неправильном анонсе туля в оспф какой смысл анонсить IP тунелся c маской 32.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Axellll email(ok) on 11-Ноя-09, 14:39 
>[оверквотинг удален]
>>
>>На Central office и Branch роутерах нужно прописать статические маршруты для tunnel
>>destination.
>>
>>Примерно так:
>>
>>R1(config)# ip route 10.3.3.3 255.255.255.255  serial 0
>>R3(config)# ip route 10.1.1.1 255.255.255.255 serial 1
>
>На сколько я понимаю, проблема в рекурсивном роутинге

Да, Спасибо, проблема действительно была в рекурсивном роутинге. Смысл в том, что нельзя настраивая динамическую маршрутизацию через туннель, объявлять там же и адреса начала и конца туннеля.  Это те адреса, которые смотрят в сторону спутника и являются для туннелей sorce и destination.
Чтобы исправить, можно сделать два варианта -
1. либо оставить их в процессе ospf , но тогда применять сложные полиси, чтобы фильтровать
2. Убрать эту строчку везде в процессе ospf, но прописать статику, чтобы мрашрутизатор знал, как строить туннель .
  Вообщем интерфейс перестал падать, соседи видят друг друга, но анонсы маршрутов не получаем, т.е.перключения с основного на резервный не происходит.
Не знаю уже что делать, ПОМОГИТЕ ПОЖАЛУЙСТА.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Николай (??) on 11-Ноя-09, 15:01 
>  Вообщем интерфейс перестал падать, соседи видят друг друга, но анонсы
>маршрутов не получаем, т.е.перключения с основного на резервный не происходит.
>Не знаю уже что делать, ПОМОГИТЕ ПОЖАЛУЙСТА.

Давай конфиги двух соседей снова :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Axellll email(ok) on 12-Ноя-09, 07:02 
Вот Конфиги:
192.168.xx.0 -сеть основного провайдера
192.168.уу.0 - сеть резервного провайдера
Маршрутизатор в центральном офисе:

interface Loopback0
ip address 192.168.3.100 255.255.255.240
!
interface Tunnel1
description GRE Tunnel to filial 1
ip address 10.10.40.5 255.255.255.252
ip tcp adjust-mss 1436
tunnel source FastEthernet0/2/0
tunnel destination 192.168.yy.38
!
interface Tunnel2
description GRE Tunnel to filial 2
ip address 10.10.40.25 255.255.255.252
ip tcp adjust-mss 1436
tunnel source FastEthernet0/2/0
tunnel destination 192.168.yy.18

interface FastEthernet0/2/0
ip address 192.168.yy.2 255.255.255.252
duplex auto
speed auto  ----- спутниковый канал
!
router ospf 100
log-adjacency-changes
network 10.0.3.0 0.0.0.255 area 0
network 10.10.40.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
network 192.168.5.0 0.0.0.255 area 0
network 192.168.7.0 0.0.0.255 area 0
network 192.168.11.24 0.0.0.7 area 0
network 192.168.xx.0 0.0.0.3 area 0

!
interface FastEthernet0/1
no ip address
logging event subif-link-status
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1.46
encapsulation dot1Q 46
ip address 10.3.0.2 255.255.0.0
!
interface FastEthernet0/1.925
description Connect to ISP- IP/VPN
encapsulation dot1Q 925
ip address 192.168.xx.2 255.255.255.252 - основной канал

Также в статических маршрутах присутствует
ip route 192.168.43.0 255.255.255.0 192.168.37.1 ( 192.168.43.0 сеть№1 в филиале 1)
ip route 192.168.yy.0 255.255.255.0 192.168.yy.1 ( спутник)
ip route 192.168.84.0 255.255.255.0 192.168.37.10 ( 192.168.84.0 сеть№2 в филиале 1)
ip route 192.168.85.0 255.255.255.0 192.168.37.10 ( 192.168.85.0 сеть№3 в филиале 1)

Вот сосед которого видит центр:
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.3.103     0   FULL/  -        00:00:31    10.10.40.6      Tunnel1

Маршрутизатор в филиале:

interface Loopback0
ip address 192.168.3.103 255.255.255.240 – Router ID
!
interface Tunnel1
ip address 10.10.40.6 255.255.255.252
ip tcp adjust-mss 1436
tunnel source FastEthernet0/0/0
tunnel destination 192.168.yy.2
!
interface FastEthernet0/0
ip address 192.168.xx.10 255.255.255.252
ip accounting output-packets
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.84.2 255.255.255.252 secondary
ip address 192.168.43.1 255.255.255.0
ip access-group INCOMING in
ip accounting output-packets
ip route-cache flow
duplex auto
speed auto
!
interface FastEthernet0/0/0
ip address 192.168.yy.38 255.255.255.252
duplex auto
speed auto
!
router ospf 100
log-adjacency-changes
network 10.10.40.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
network 192.168.xx.8 0.0.0.3 area 0
network 192.168.xx.0 0.0.0.255 area 0
network 192.168.43.0 0.0.0.255 area 0
network 192.168.84.0 0.0.0.255 area 0
network 192.168.85.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 192.168.xx.9
ip route 192.168.5.103 255.255.255.255 10.10.40.5
ip route 192.168.xx.0 255.255.255.252 192.168.xx.9
ip route 192.168.yy.0 255.255.255.0 192.168.yy.37
ip route 192.168.84.0 255.255.255.0 192.168.84.1
ip route 192.168.85.0 255.255.255.0 192.168.84.1

Вот сосед которого видит филиал:
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.3.100     0   FULL/  -        00:00:32    10.10.40.5      Tunnel1


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "HELP ---OSPF на GRE туннеле"  +/
Сообщение от Myxa (??) on 11-Ноя-09, 15:29 
>Приветствую всех. Народ, помогите, пожалуйста. Такая проблема, есть 2 канала связи- основной
>и резервный. Есть 2 циски одна в головном офисе вторая в
>филиале. Между ними поднят GRE туннель. Теперь настраиваю OSPF. Как только
>вношу в в Router ospf: network{адрес туннеля} маска area id, интерфейс
>Tunnel0 падает в down. Удаляю этот network из router ospf --поднимается.
>Что за фигня такая? не подскажите?Может что то забываю сделать?

Попробую угадать: у вас отсутствует статический ip route на tunnel destination сеть с обеих сторон?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру