The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"cisco ospf - Quagga"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"cisco ospf - Quagga"  
Сообщение от den68 email(ok) on 14-Фев-07, 02:44 
В процессе скрещивания назрели следующие вопосы:
1. как забороть:
OSPF: Packet[DD]: Neighbor 194.xxx.xxx.241 MTU 1500 is larger than [eth1.4:194.xxx.xxx.250]'s MTU 1496

2. как обьяснить Quagga что интерфейс eth1.4 тот самый куда надо слушать/пихать информацию OSPF, без учета вставления ИП сети расположенной на этом интерфейсе в area 0.0.0.0, и вообще в area ?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

  • cisco ospf - Quagga, Мозжевилов Анатолий, 08:11 , 14-Фев-07, (1)  
    • cisco ospf - Quagga, ruff, 10:18 , 14-Фев-07, (2)  
      • cisco ospf - Quagga, den68, 18:38 , 14-Фев-07, (3)  
        • cisco ospf - Quagga, Мозжевилов Анатолий, 08:05 , 15-Фев-07, (4)  
          • cisco ospf - Quagga, Мозжевилов Анатолий, 08:08 , 15-Фев-07, (5)  
          • cisco ospf - Quagga, Alexey, 10:53 , 15-Фев-07, (7)  
            • cisco ospf - Quagga, Мозжевилов Анатолий, 13:29 , 15-Фев-07, (8)  
              • cisco ospf - Quagga, den68, 17:18 , 15-Фев-07, (9)  
                • cisco ospf - Quagga, Мозжевилов Анатолий, 07:59 , 16-Фев-07, (10)  

Сообщения по теме [Сортировка по времени, UBB]


1. "cisco ospf - Quagga"  
Сообщение от Мозжевилов Анатолий email on 14-Фев-07, 08:11 
>В процессе скрещивания назрели следующие вопосы:
>1. как забороть:
> OSPF: Packet[DD]: Neighbor 194.xxx.xxx.241 MTU 1500 is larger than [eth1.4:194.xxx.xxx.250]'s MTU
>1496

наверно выставить одинаковые MTU/MRU в настройках интерфейса...

>2. как обьяснить Quagga что интерфейс eth1.4 тот самый куда надо слушать/пихать
>информацию OSPF, без учета вставления ИП сети расположенной на этом интерфейсе
>в area 0.0.0.0, и вообще в area ?

вроде не как, судя по документации на Quaggu...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "cisco ospf - Quagga"  
Сообщение от ruff email(ok) on 14-Фев-07, 10:18 
>>В процессе скрещивания назрели следующие вопосы:
>>1. как забороть:
>> OSPF: Packet[DD]: Neighbor 194.xxx.xxx.241 MTU 1500 is larger than [eth1.4:194.xxx.xxx.250]'s MTU
>>1496
>
>наверно выставить одинаковые MTU/MRU в настройках интерфейса...
>
>>2. как обьяснить Quagga что интерфейс eth1.4 тот самый куда надо слушать/пихать
>>информацию OSPF, без учета вставления ИП сети расположенной на этом интерфейсе
>>в area 0.0.0.0, и вообще в area ?
>
>вроде не как, судя по документации на Quaggu...

не на квагу а согласно спецификации оспф: OSPF supports addressless interfaces on PPP links.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "cisco ospf - Quagga"  
Сообщение от den68 (ok) on 14-Фев-07, 18:38 
>>>В процессе скрещивания назрели следующие вопосы:
>>наверно выставить одинаковые MTU/MRU в настройках интерфейса...
Одинаковые не получаються, и вообще какая ей разница какой MTU у следующего роутера.
Неполучаеться потому что на одном тегированный влан = мту 1496, на другом антегированный влан, просто эзернет = мту 1500

>>
>не на квагу а согласно спецификации оспф: OSPF supports addressless interfaces on
>PPP links.

это не ппп линк, - эзернет. Вопрос, нельзя ли как-то заставить слушать/отсылать именно по этому интерфейсу, непрописывая в ареа сеть которая прописана на этом интерфейсе, например с помощью point-multipoint, или еще как либо ? есть ли реальные наработки ?

Вопрос №3 - как заставить Quagga писать весь роутинг полученный по ospf в таблицу № 200, например.
В zebra.conf указал table 200, но по "ip route list table 200" там пусто :(
может есть какой либо патч для писания разных area в разные таблицы, с учетом использования policy routing ?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "cisco ospf - Quagga"  
Сообщение от Мозжевилов Анатолий email on 15-Фев-07, 08:05 
>>>>В процессе скрещивания назрели следующие вопосы:
>>>наверно выставить одинаковые MTU/MRU в настройках интерфейса...
>Одинаковые не получаються, и вообще какая ей разница какой MTU у следующего
>роутера.
>Неполучаеться потому что на одном тегированный влан = мту 1496, на другом
>антегированный влан, просто эзернет = мту 1500

если мы говорим про 0.99.6, то разница вот какая:

/* OSPF Database Description message read -- RFC2328 Section 10.6. */
static void
ospf_db_desc (struct ip *iph, struct ospf_header *ospfh,
              struct stream *s, struct ospf_interface *oi, u_int16_t size)
{
...
  /* Check MTU. */
  if ((OSPF_IF_PARAM (oi, mtu_ignore) == 0) &&
      (ntohs (dd->mtu) > oi->ifp->mtu))
    {
      zlog_warn ("Packet[DD]: Neighbor %s MTU %u is larger than [%s]'s MTU %u",
                 inet_ntoa (nbr->router_id), ntohs (dd->mtu),
                 IF_NAME (oi), oi->ifp->mtu);
      return;
    }
...

или ставишь mtu_ignore=1, или правишь исходникик...

>>>
>>не на квагу а согласно спецификации оспф: OSPF supports addressless interfaces on
>>PPP links.

RFC-2328 это конечно хорошо, но если мы говорим про Quaggu0.99.6, то поддержка в Quagge реализована не полностью, и не совсем корректно...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "cisco ospf - Quagga"  
Сообщение от Мозжевилов Анатолий email on 15-Фев-07, 08:08 
>>>>>В процессе скрещивания назрели следующие вопосы:
>>>>наверно выставить одинаковые MTU/MRU в настройках интерфейса...
>>Одинаковые не получаються, и вообще какая ей разница какой MTU у следующего
>>роутера.
>>Неполучаеться потому что на одном тегированный влан = мту 1496, на другом
>>антегированный влан, просто эзернет = мту 1500
>
>если мы говорим про 0.99.6, то разница вот какая:
>
>/* OSPF Database Description message read -- RFC2328 Section 10.6. */
>static void
>ospf_db_desc (struct ip *iph, struct ospf_header *ospfh,
>            
>  struct stream *s, struct ospf_interface *oi, u_int16_t size)
>{
>...
>  /* Check MTU. */
>  if ((OSPF_IF_PARAM (oi, mtu_ignore) == 0) &&
>      (ntohs (dd->mtu) > oi->ifp->mtu))
>    {
>      zlog_warn ("Packet[DD]: Neighbor %s MTU %u
>is larger than [%s]'s MTU %u",
>                 inet_ntoa (nbr->router_id), ntohs (dd->mtu),
>                 IF_NAME (oi), oi->ifp->mtu);
>      return;
>    }
>...
>
>или ставишь mtu_ignore=1, или правишь исходникик...
>
>>>>
>>>не на квагу а согласно спецификации оспф: OSPF supports addressless interfaces on
>>>PPP links.
>
>RFC-2328 это конечно хорошо, но если мы говорим про Quaggu0.99.6, то поддержка
>в Quagge реализована не полностью, и не совсем корректно...


ps:

RFC-2328:
        If the Interface MTU field in the Database Description packet
        indicates an IP datagram size that is larger than the router can
        accept on the receiving interface without fragmentation, the
        Database Description packet is rejected.  Otherwise, if the
        neighbor state is:

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "cisco ospf - Quagga"  
Сообщение от ruff email(ok) on 15-Фев-07, 10:02 
>
>ps:
>
>RFC-2328:
>        If the Interface MTU
>field in the Database Description packet
>        indicates an IP datagram
>size that is larger than the router can
>        accept on the receiving
>interface without fragmentation, the
>        Database Description packet is
>rejected.  Otherwise, if the
>        neighbor state is:

вот вот. ненравится ограничения оспф - выбирайте другой протокол. А то как говорится и рыбку сьесть и... стандарты есть стандарты, и выдумывались они не для того чтоб усложныть жизнь конкретно взятому человеку. меня например оспф вполне устраивает в его стандартном поведении. хотя пришлось поменять немного топологию для его полнофункционального развертывания.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "cisco ospf - Quagga"  
Сообщение от Alexey (??) on 15-Фев-07, 10:53 
>>>>>В процессе скрещивания назрели следующие вопосы:
>>>>наверно выставить одинаковые MTU/MRU в настройках интерфейса...
>>Одинаковые не получаються, и вообще какая ей разница какой MTU у следующего
>>роутера.
>>Неполучаеться потому что на одном тегированный влан = мту 1496, на другом
>>антегированный влан, просто эзернет = мту 1500
>
>если мы говорим про 0.99.6, то разница вот какая:
>
>/* OSPF Database Description message read -- RFC2328 Section 10.6. */
>    }
>...
>
>или ставишь mtu_ignore=1, или правишь исходникик...
>

Зачем сразу кувалда и такаято мать?

на интерфейсе ip ospf mtu-ignore

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "cisco ospf - Quagga"  
Сообщение от Мозжевилов Анатолий email on 15-Фев-07, 13:29 
>
>Зачем сразу кувалда и такаято мать?
>
>на интерфейсе ip ospf mtu-ignore

согласен,что нежнее надо! возможно в доке не Quaggu не заметил этого параметра, а в исходниках об был прописан...

была ещё неприятна проблема, когда ospfd и zebra стартовали одновременно с устанвкой линков. В этом случае zebra c вероятностью 30% выдавала, что MTU на интерфейсе равен 0 и ospfd курил бамбук...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "cisco ospf - Quagga"  
Сообщение от den68 (ok) on 15-Фев-07, 17:18 
>>
>>Зачем сразу кувалда и такаято мать?
>>
>>на интерфейсе ip ospf mtu-ignore

Ok, спасибо за ответы.
Остался еще вопрос:
как заставить анансировать сеть такого вида:
на машине 194.10.2.250 (0.0.0.10)
net 194.10.2.104 netmask 255.255.255.248 gw 192.168.251.169

на машине 194.10.2.241
                Type-5 AS External Link States
Link ID         ADV Router      Age         Seq#       Checksum Tag
194.10.2.104 0.0.0.10        327         0x80000032 0x0018F9 0

но в роутинг оно на 194.10.2.241 (0.0.0.100) не добавляеться.

конфиг 194.10.2.241 (0.0.0.100):

router ospf 10
router-id 0.0.0.100
log-adjacency-changes
redistribute connected subnets route-map EXPOSPFAREA
redistribute static subnets route-map EXPOSPFAREA
passive-interface FastEthernet1/0
passive-interface FastEthernet2/0
passive-interface FastEthernet2/0.2
passive-interface FastEthernet2/0.3
passive-interface FastEthernet2/0.5
passive-interface Ethernet4/0
passive-interface Ethernet4/1
passive-interface Ethernet4/2
passive-interface Ethernet4/3
passive-interface Loopback0
passive-interface Loopback1
passive-interface Tunnel1
passive-interface Tunnel2
network 192.168.50.4 0.0.0.3 area 0.0.0.10
network 194.10.2.0 0.0.0.31 area 0.0.0.10
network 194.10.2.32 0.0.0.15 area 0.0.0.10
network 194.10.2.48 0.0.0.15 area 0.0.0.10
network 194.10.2.240 0.0.0.15 area 0.0.0.10

access-list 90 permit 194.10.2.0 0.0.0.255
access-list 90 deny   any

route-map EXPOSPFAREA permit 10
match ip address 90


конфиг 194.10.2.250 (0.0.0.10):

router ospf
ospf router-id 0.0.0.10
log-adjacency-changes detail
compatible rfc1583
!
redistribute kernel
redistribute connected
redistribute static
distribute-list ospfexport1 out kernel
distribute-list ospfexport1 out connected
distribute-list ospfexport1 out static
!
no default-information originate
!
passive-interface eth0
passive-interface eth0.20
passive-interface eth0.25
passive-interface eth1
passive-interface eth1.5
passive-interface eth1.6
passive-interface gre0
passive-interface lo
passive-interface rshaper
passive-interface dummy0
passive-interface dummy1
!
network 192.168.19.0/24 area 0.0.0.20
network 192.168.20.0/24 area 0.0.0.20
network 192.168.21.0/24 area 0.0.0.20
network 192.168.22.0/24 area 0.0.0.20
network 192.168.23.0/24 area 0.0.0.20
network 192.168.24.0/24 area 0.0.0.20
network 192.168.25.0/24 area 0.0.0.20
network 192.168.50.0/30 area 0.0.0.20
!
network 194.10.2.96/29 area 0.0.0.10
network 194.10.2.104/29 area 0.0.0.10
network 194.10.2.112/28 area 0.0.0.10
network 194.10.2.240/28 area 0.0.0.10
!
area 0.0.0.10 import-list ospfimport1
area 0.0.0.20 import-list ospfimport2

access-list ospfimport1 permit 194.10.2.0/24
access-list ospfimport1 deny any
!
access-list ospfimport2 permit 192.168.0.0/16
access-list ospfimport2 deny any
!
access-list ospfexport1 permit 194.10.2.96/29
access-list ospfexport1 permit 194.10.2.104/29
access-list ospfexport1 permit 194.10.2.112/28
access-list ospfexport1 deny any

и на 0.0.0.100
sh ip ospf database router 0.0.0.10

            OSPF Router with ID (0.0.0.100) (Process ID 10)

                Router Link States (Area 0.0.0.10)

  Routing Bit Set on this LSA
  LS age: 755
  Options: (No TOS-capability, No DC)
  LS Type: Router Links
  Link State ID: 0.0.0.10
  Advertising Router: 0.0.0.10
  LS Seq Number: 80000054
  Checksum: 0x7C84
  Length: 60
  AS Boundary Router
  Number of Links: 3

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 194.10.2.96
     (Link Data) Network Mask: 255.255.255.248
      Number of TOS metrics: 0
       TOS 0 Metrics: 10

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 194.10.2.112
     (Link Data) Network Mask: 255.255.255.240
      Number of TOS metrics: 0
       TOS 0 Metrics: 10

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 194.10.2.241
     (Link Data) Router Interface address: 194.10.2.250
      Number of TOS metrics: 0
       TOS 0 Metrics: 10

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "cisco ospf - Quagga"  
Сообщение от Мозжевилов Анатолий email on 16-Фев-07, 07:59 
а у тебя с 194.10.2.250 есть доступ до сети 194.10.2.104/255.255.255.248, т.е. маршрут прописан?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "cisco ospf - Quagga"  
Сообщение от den68 email(ok) on 17-Фев-07, 02:43 
>а у тебя с 194.10.2.250 есть доступ до сети 194.10.2.104/255.255.255.248, т.е. маршрут
>прописан?

# traceroute 194.10.2.105
traceroute to 194.10.2.105 (194.10.2.105), 30 hops max, 38 byte packets
1  192.168.251.169 (192.168.251.169)  1.396 ms  1.627 ms  1.285 ms

# route -n
194.10.2.104 192.168.251.169 255.255.255.248 UG    0      0        0 eth0.250


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру