The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco 1811 NAT failover при помощи двух WAN интерфейсов"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Антон email(??) on 12-Дек-06, 21:13 
Здравствуйте,

у Cisco 1811 есть два WAN интерфейса. К fe0, соответственно, подключен канал от одного провайдера со статическим ip-адресом, к fe1 - другой со статическим IP. Хотелось-бы настроить конфигурацию таким образом, чтобы fe0 рассматривался как "основной", а fe1 - как "дополнительный", и трафик через него шел только при отказе fe0.

Отказ fe0, конечно, нужно "мониторить" не через физическое отключение интерфейсного кабеля (line protocol down), а, например, нужно отслеживать "доступность" некоего хоста в Интернет именно через fe0.

Соотвественно, NAT должен работать таким же образом: в случае "отказа" fe0 чтобы трафик NAT-ился через другой.

Пожалуйста, помогите с конфигурацией.

Заранее признателен,
Антон

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Vlad (??) on 13-Дек-06, 07:45 
PBR
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Антон email(??) on 13-Дек-06, 09:24 
>PBR


А в PBR можно отслеживать доступность хоста именно через определенный интерфейс?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от gj on 15-Дек-06, 20:19 
>>PBR
>
>
>А в PBR можно отслеживать доступность хоста именно через определенный интерфейс?

tracking

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от EtherDen email on 17-Дек-06, 00:06 
Лично у меня так и не получилось, настроить 1811 на полный автоном... сделал так:

!
ip cef
!
ip sla 1
icmp-echo х.х.х.209 (шлюз провайдера 1)
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo у.у.у.193 (шлюз провайдера 2)
ip sla schedule 2 life forever start-time now
!
!
track 123 rtr 1 reachability
!
track 124 rtr 2 reachability
!
interface FastEthernet0
ip address х.х.х.211 255.255.255.х
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
ip address у.у.у.196 255.255.255.у
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.0.z 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 х.х.х.209 10 track 123
ip route 0.0.0.0 0.0.0.0 у.у.у.193 20 track 124
!
ip nat inside source route-map ISP1-NAT interface FastEthernet0 overload
ip nat inside source route-map ISP2-NAT interface FastEthernet1 overload
!
ip access-list standard locallan
permit 192.168.0.0 0.0.0.255
!
!
route-map ISP1-NAT permit 10
match ip address locallan
match interface FastEthernet0
!
route-map ISP2-NAT permit 10
match ip address locallan
match interface FastEthernet1
!
end

Вобщем для полного счастья надо PI сетку, и нумер AS, а это стоит денех...вот...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Shod (??) on 18-Дек-06, 07:45 
http://www.cisco.com/en/US/products/ps6350/products_configur...
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Антон email(??) on 18-Дек-06, 12:29 
А так NAT fail-over работать отказывается. Один route-map назначает next-hop

set ip next-hop verify-availability 10.1.1.1 10 track 123


А второй должен его проверять, чтобы NAT-илось через правильный интерфейс

route-map NAT_ISP1

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Антон email(??) on 18-Дек-06, 12:34 
Не окончил сообщение..

Так вот:

А так NAT fail-over работать отказывается. Например, пишем route-map, который назначает next-hop-ы

route-map alpha

set ip next-hop verify-availability 10.1.1.1 10 track 123
set ip next-hop verify-availability 10.2.2.2 20 track 124


А "вторые" route-map-ы должны его проверять, чтобы NAT-илось через правильный интерфейс

ip nat inside source route-map ISP1-NAT interface FastEthernet0 overload
ip nat inside source route-map ISP2-NAT interface FastEthernet1 overload
!
ip access-list standard locallan
permit 192.168.0.0 0.0.0.255
!
!
route-map ISP1-NAT permit 10
match ip address locallan
match interface FastEthernet0
!
route-map ISP2-NAT permit 10
match ip address locallan
match interface FastEthernet1

Так вот у меня так не получилось. Видимо, дело в порядке обработки этих карт. Карты NAT-а отрабатывют, когда еще карта alpha не назначила next-hop

У меня получилось только как у товарища в предыдущем посте
ip route 0.0.0.0 0.0.0.0 х.х.х.209 10 track 123
ip route 0.0.0.0 0.0.0.0 у.у.у.193 20 track 124


Спасибо,
Антон

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Антон email(??) on 18-Дек-06, 12:26 
ОК,

а тогда что значит "настроить 1811 на полный автоном"? По твоему конфигу роутер будет отслеживать доступность шлюзов-по-умолчанию от двух провайдеров, соответственно, в случае "поломки" "основного" будет задействован "резервный" канал, NAT также будет работать через "основного" или через "резервного". Т.е. думаю, что вполне можно говорить именно о "полном автономе".

Спасибо,
Антон

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от EtherDen email on 19-Дек-06, 00:12 
Для меня "полный автоном" - когда я сплю ночью, и на работе :), а в данном случае у меня зачастую бывает так, что оба шлюза провайдера доступны, а инета нет! ибо обрыв где-то через два хопа после шлюза прова...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Антон email(??) on 19-Дек-06, 01:57 
Так а собственно... что мешает контролировать доступность именно "нужного" хоста через определенный интерфейс, подключенный через определенного провайдера? А если оба провайдера одновременно отказывают в доступе к определенному "нужному" хосту, то одно из двух: а) проблема у "нужного" хоста б) провайдеры зависят друг от друга


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Shod (??) on 19-Дек-06, 09:54 
>Для меня "полный автоном" - когда я сплю ночью, и на работе
>:), а в данном случае у меня зачастую бывает так, что
>оба шлюза провайдера доступны, а инета нет! ибо обрыв где-то через
>два хопа после шлюза прова...

ну пропиши 2 статика для двух удаленных хостов, один через 1ый интерфейс, другой соответственно ...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Антон email(??) on 19-Дек-06, 12:10 
>ну пропиши 2 статика для двух удаленных хостов, один через 1ый интерфейс,
>другой соответственно ...


Боюсь, что я не понял мысль. Статический маршрут - он на то и статический... И даже в случае отказа канала одного из провайдеров пакеты будут туда ломиться по статическому маршруту...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от Shod (??) on 19-Дек-06, 12:19 
>>ну пропиши 2 статика для двух удаленных хостов, один через 1ый интерфейс,
>>другой соответственно ...
>
>Боюсь, что я не понял мысль. Статический маршрут - он на то
>и статический... И даже в случае отказа канала одного из провайдеров
>пакеты будут туда ломиться по статическому маршруту...

вопервых статика работать будет только для самого роутера
поскольку весь рабочий траффик у вас идет по роут-мапу, статик там не сработает
а так пропишите статический маршрут 1го только хоста, по маске 255.255.255.255
к примеру какогонибудь роутера дальше по маршруту
никто кроме вашего трекинга туда ломится не будет никогда

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "Cisco 1811 NAT failover при помощи двух WAN интерфейсов"  +/
Сообщение от fantomaty123 on 31-Авг-10, 13:18 
Продажа различного оборудования фирмы Cisco, подробнее можно узнать:
ICQ: 598294638; 567623046; 563397602;
тел.: (812) 325-92-30
http://it-1.ru


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру