The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"PIX525 VPN Interface"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"PIX525 VPN Interface"  
Сообщение от Z_M email(ok) on 09-Окт-06, 15:18 
Уважаемые, подскажите, пожалуйста, как пробросить VPN на внутренний интерфейс PIX525, ато у меня только на внешний кое как получается, тоесть в туннеле вижу свой адрес из пула и на другом конце адрес внешнего интерфейса (OS FreeBSD 6.0):

ng0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> mtu 1500
        inet 10.0.3.1 --> 10.0.1.1 netmask 0xffffffff
        inet6 fe80::213:d4ff:feeb:b784%ng0 prefixlen 64 scopeid 0x7

а хочу 10.0.3.1 --> 10.0.0.1

Вот конфиг от PIX:

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
interface gb-ethernet0 1000auto shutdown
interface gb-ethernet1 1000auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif gb-ethernet0 intf2 security4
nameif gb-ethernet1 intf3 security6
hostname FW-1
domain-name RRR
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip any any
pager lines 24
mtu outside 1500
mtu inside 1500
mtu intf2 1500
mtu intf3 1500
ip address outside 10.0.1.1 255.255.255.0
ip address inside 10.0.0.1 255.255.255.0
no ip address intf2
no ip address intf3
ip audit info action alarm
ip audit attack action alarm
ip local pool ipvpnpool 10.0.3.0-10.0.4.0
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address intf2
no failover ip address intf3
pdm location 10.0.0.2 255.255.255.255 inside
pdm location 10.0.0.3 255.255.255.255 inside
pdm location 10.0.1.2 255.255.255.255 outside
pdm history enable
arp timeout 14400
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server radius-authport 1812
aaa-server radius-acctport 1813
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server RADIUS (inside) host 10.0.0.2 testing123 timeout 10
aaa-server LOCAL protocol local
http server enable
http 10.0.0.2 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt radius ignore-secret
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group vpnpptp accept dialin pptp
vpdn group vpnpptp ppp authentication pap
vpdn group vpnpptp client configuration address local ipvpnpool
vpdn group vpnpptp client authentication aaa RADIUS
vpdn group vpnpptp client accounting RADIUS
vpdn group vpnpptp pptp echo 300
vpdn enable outside
vpdn enable inside
terminal width 80

Спасибо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "PIX525 VPN Interface"  
Сообщение от ilya email(ok) on 09-Окт-06, 15:31 
сделать site-to-site тунель?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "PIX525 VPN Interface"  
Сообщение от Z_M email(ok) on 09-Окт-06, 15:36 
>сделать site-to-site тунель?

для начала бы да !

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "PIX525 VPN Interface"  
Сообщение от ilya email(ok) on 09-Окт-06, 15:47 
>>сделать site-to-site тунель?
>
>для начала бы да !


http://www.cisco.com/univercd/cc/td/doc/product/iaabu/pix/pix_sw/v_63/config/sit2site.htm

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "PIX525 VPN Interface"  
Сообщение от Z_M email(ok) on 13-Окт-06, 12:41 
не выходит у меня пробросить туннель во внутреннюю сеть устанавливается как то странно туннель с внешним айпи(313.334.396.3):

ng0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> mtu 1500
        inet6 fe80::213:d4ff:feeb:b784%ng0 prefixlen 64 scopeid 0x7
        inet 10.0.3.0 --> 313.334.396.3 netmask 0xffffffff

а надо чтобы во внутреннюю сетку туннель был

ng0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> mtu 1500
        inet6 fe80::213:d4ff:feeb:b784%ng0 prefixlen 64 scopeid 0x7
        inet 10.0.3.0 --> 10.0.3.1 netmask 0xffffffff

подскажите чего ,пожалуйста.

>>>сделать site-to-site тунель?
>>
>>для начала бы да !
>
>
>http://www.cisco.com/univercd/cc/td/doc/product/iaabu/pix/pix_sw/v_63/config/sit2site.htm


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "PIX525 VPN Interface"  
Сообщение от ilya email(ok) on 13-Окт-06, 17:36 
>не выходит у меня пробросить туннель во внутреннюю сеть устанавливается как то
>странно туннель с внешним айпи(313.334.396.3):
>
>ng0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> mtu 1500
>        inet6 fe80::213:d4ff:feeb:b784%ng0 prefixlen 64
>scopeid 0x7
>        inet 10.0.3.0 --> 313.334.396.3 netmask 0xffffffff
>
>а надо чтобы во внутреннюю сетку туннель был
>
>ng0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> mtu 1500
>        inet6 fe80::213:d4ff:feeb:b784%ng0 prefixlen 64
>scopeid 0x7
>        inet 10.0.3.0 --> 10.0.3.1 netmask 0xffffffff
>
>подскажите чего ,пожалуйста.
телепаты сегодня уже не принимают. конфиг пикса в студию.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "PIX525 VPN Interface"  
Сообщение от Z_M email(ok) on 16-Окт-06, 09:14 
на телепатов я и не рассчитываю, а вот немного внимания можно было бы проявить и прочитать первый пост :)
единственное  что внешний адрес я сейчас использую 313.334.396.3
Спасибо.

>>не выходит у меня пробросить туннель во внутреннюю сеть устанавливается как то
>>странно туннель с внешним айпи(313.334.396.3):
>>
>>ng0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> mtu 1500
>>        inet6 fe80::213:d4ff:feeb:b784%ng0 prefixlen 64
>>scopeid 0x7
>>        inet 10.0.3.0 --> 313.334.396.3 netmask 0xffffffff
>>
>>а надо чтобы во внутреннюю сетку туннель был
>>
>>ng0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> mtu 1500
>>        inet6 fe80::213:d4ff:feeb:b784%ng0 prefixlen 64
>>scopeid 0x7
>>        inet 10.0.3.0 --> 10.0.3.1 netmask 0xffffffff
>>
>>подскажите чего ,пожалуйста.
>телепаты сегодня уже не принимают. конфиг пикса в студию.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "PIX525 VPN Interface"  
Сообщение от ilya email(ok) on 16-Окт-06, 10:04 
>на телепатов я и не рассчитываю, а вот немного внимания можно было
>бы проявить и прочитать первый пост :)
>единственное  что внешний адрес я сейчас использую 313.334.396.3
>Спасибо.


я присылал вам ссылку для организации ipsec site-to-site тунеля. поэтому конфиг в соответствии с этим мог поменяться.

если конфиг не менялся - то:
1. как происходит трансляция адресов (в конфиге ничего нет)?
2. включите дебаг и посмотрите что пишется в лог.
3. ИМХО vpdn enable inside лишнее если у вас изнутри нет pptp клиентов.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "PIX525 VPN Interface"  
Сообщение от Z_M email(ok) on 16-Окт-06, 10:19 
трансляции нет, если это нужно чтобы pptp клиентов во внутреннюю сетку пробросить, покажите, пожалуйста, как.
а чего на дебаг смотреть-все коннектится, только на конце туннеля pptp клиента внешний IP рисуется:
inet 10.0.3.0 --> 313.334.396.3 netmask 0xffffffff
а я хочу чтобы было так
inet 10.0.3.0 --> 10.66.66.1 netmask 0xffffffff,
ну к примеру, чтобы он видел внутреннюю сеть.

vpnd у меня на внешнем ифейсе, вот привлжу последний конфиг:

: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet1 vlan1 logical
interface gb-ethernet0 1000auto shutdown
interface gb-ethernet1 1000auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 intf4 security8
nameif gb-ethernet0 intf2 security4
nameif gb-ethernet1 intf3 security6
nameif vlan1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname CO-FW-1
domain-name RPS
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 80 permit ip 10.66.66.0 255.255.255.0 10.0.0.0 255.255.0.0
pager lines 58
mtu outside 1500
mtu intf4 1500
mtu intf2 1500
mtu intf3 1500
ip address outside 313.334.396.3 255.255.255.0
ip address intf4 192.168.3.69 255.255.255.0
no ip address intf2
no ip address intf3
ip address inside 10.66.66.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ipvpnpool 10.0.3.0-10.0.4.0
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address intf4
no failover ip address intf2
no failover ip address intf3
no failover ip address inside
pdm location 10.0.0.2 255.255.255.255 intf4
pdm location 10.0.0.3 255.255.255.255 intf4
pdm location 10.0.1.2 255.255.255.255 outside
pdm location 192.168.3.69 255.255.255.255 intf4
pdm location 192.168.3.66 255.255.255.255 intf4
pdm location 192.168.3.67 255.255.255.255 intf4
pdm location 10.0.0.0 255.255.0.0 outside
pdm location 10.0.0.0 255.0.0.0 outside
pdm history enable
arp timeout 14400
global (inside) 1 10.10.66.0-10.10.66.254
nat (inside) 0 access-list 80
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server radius-authport 1812
aaa-server radius-acctport 1813
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server RADIUS (intf4) host 192.168.3.66 testing123 timeout 10
aaa-server LOCAL protocol local
http server enable
http 192.168.3.67 255.255.255.255 intf4
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt radius ignore-secret
crypto ipsec transform-set strong-des esp-3des esp-sha-hmac
crypto dynamic-map cisco 4 set transform-set strong-des
crypto map partner-map 20 ipsec-isakmp dynamic cisco
crypto map partner-map interface outside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group vpnpptp accept dialin pptp
vpdn group vpnpptp ppp authentication mschap
vpdn group vpnpptp ppp encryption mppe 128 required
vpdn group vpnpptp client configuration address local ipvpnpool
vpdn group vpnpptp client authentication aaa RADIUS
vpdn group vpnpptp client accounting RADIUS
vpdn group vpnpptp pptp echo 60
vpdn enable outside
terminal width 80
Cryptochecksum:6c74d14967b13ff7ae71702ef6d29cb4
: end

Спасибо!

>я присылал вам ссылку для организации ipsec site-to-site тунеля. поэтому конфиг в
>соответствии с этим мог поменяться.
>
>если конфиг не менялся - то:
>1. как происходит трансляция адресов (в конфиге ничего нет)?
>2. включите дебаг и посмотрите что пишется в лог.
>3. ИМХО vpdn enable inside лишнее если у вас изнутри нет pptp
>клиентов.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "PIX525 VPN Interface"  
Сообщение от ilya email(ok) on 16-Окт-06, 10:41 
http://www.cisco.com/warp/public/110/pptppix.html

логи смотреть на пиксе
logg on
logg con 7
logg mon 7

term mon - по необходимости.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "PIX525 VPN Interface"  
Сообщение от 1 (??) on 16-Окт-06, 10:46 
Интересный адрес 313.334.396.3 - это как?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "PIX525 VPN Interface"  
Сообщение от Z_M email(ok) on 17-Окт-06, 17:01 
сделал все как по по ману, но всеравно на конце туннеля внешний айпи,
подскажите, что прописать чтобы во внутреннюю сетку загнать пптп юзеров?
может трансляцию какую?
спасибо.

>http://www.cisco.com/warp/public/110/pptppix.html
>
>логи смотреть на пиксе
>logg on
>logg con 7
>logg mon 7
>
>term mon - по необходимости.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "PIX525 VPN Interface"  
Сообщение от ilya email(ok) on 18-Окт-06, 09:52 
>сделал все как по по ману, но всеравно на конце туннеля внешний
>айпи,
>подскажите, что прописать чтобы во внутреннюю сетку загнать пптп юзеров?
>может трансляцию какую?
>спасибо.
>
>>http://www.cisco.com/warp/public/110/pptppix.html
>>
>>логи смотреть на пиксе
>>logg on
>>logg con 7
>>logg mon 7
>>
>>term mon - по необходимости.


ну и ладно, тунель поднялся - трафик не идет во внутреннюю сеть?
может тогда еще строчку маршрутизации на frebsd прописать что такая то сеть доступна через адрес вашего виртуального интерфейса?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "PIX525 VPN Interface"  
Сообщение от Z_M email(ok) on 18-Окт-06, 09:58 
ну получается, что на стороне пикса в туннеле не адрес внутренней сети а внешний айпи,тут маршрутизацией не разрулить.
я ж печатал уже там...
тоесть вместо 10.0.3.1->10.66.66.1
у меня  10.0.3.1->313.334.222.66 (реальный айпи)
я думаю надо на пиксе что то прописать, но не пойму что, делал как по этим ссылкам а всеравно в туннеле внешний айпи.

>>сделал все как по по ману, но всеравно на конце туннеля внешний
>>айпи,
>>подскажите, что прописать чтобы во внутреннюю сетку загнать пптп юзеров?
>>может трансляцию какую?
>>спасибо.
>>
>>>http://www.cisco.com/warp/public/110/pptppix.html
>>>
>>>логи смотреть на пиксе
>>>logg on
>>>logg con 7
>>>logg mon 7
>>>
>>>term mon - по необходимости.
>
>
>ну и ладно, тунель поднялся - трафик не идет во внутреннюю сеть?
>
>может тогда еще строчку маршрутизации на frebsd прописать что такая то сеть
>доступна через адрес вашего виртуального интерфейса?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "PIX525 VPN Interface"  
Сообщение от ilya email(ok) on 18-Окт-06, 12:25 
>ну получается, что на стороне пикса в туннеле не адрес внутренней сети
>а внешний айпи,тут маршрутизацией не разрулить.
>я ж печатал уже там...
>тоесть вместо 10.0.3.1->10.66.66.1
>у меня  10.0.3.1->313.334.222.66 (реальный айпи)
>я думаю надо на пиксе что то прописать, но не пойму что,
>делал как по этим ссылкам а всеравно в туннеле внешний айпи.
>
>
>>>сделал все как по по ману, но всеравно на конце туннеля внешний
>>>айпи,
>>>подскажите, что прописать чтобы во внутреннюю сетку загнать пптп юзеров?
>>>может трансляцию какую?
>>>спасибо.
>>>
>>>>http://www.cisco.com/warp/public/110/pptppix.html
>>>>
>>>>логи смотреть на пиксе
>>>>logg on
>>>>logg con 7
>>>>logg mon 7
>>>>
>>>>term mon - по необходимости.
>>
>>
>>ну и ладно, тунель поднялся - трафик не идет во внутреннюю сеть?
>>
>>может тогда еще строчку маршрутизации на frebsd прописать что такая то сеть
>>доступна через адрес вашего виртуального интерфейса?


ИМХО вы не туда смотрите.
поднял аналогичную конфигурацию на пиксе.
в качестве клиента - винда.
убрал опцию использовать pptp соединение в качестве дефаулт-гейта, прописал маршрут через pptp-адрес и все - все работает. так что ковыряйте bsd.

конфиг:
vpdn group 1 accept dialin pptp
vpdn group 1 client configuration address local my-pool
vpdn group 1 pptp echo 60
vpdn username test password *********
vpdn enable outside
access-list nat-0 permit ip 192.168.1.0 255.255.255.0 10.1.1.0 255.255.255.0
nat (inside) 0 access-list nat-0
pixx(config)# sh ip
System IP Addresses:
        ip address outside 192.168.113.45 255.255.255.0
        ip address inside 192.168.1.1 255.255.255.0

но если вы хотите что бы у вас показывало следующее:
тоесть вместо 10.0.3.1->10.66.66.1
делайте IPSEC site-to-site. ссылка на доку выше по топику (именно IPSEC а не PPTP).
может быть и в pptp такой вид можно получить - только зачем если все и так работает...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "PIX525 VPN Interface"  
Сообщение от Z_M email(ok) on 18-Окт-06, 13:02 
тоесть у вас на вин-клиенте на конце туннеля тоже айпи внешнего интерейса пикса?
Спасибо, буду пробовать ipsec.

>>ну получается, что на стороне пикса в туннеле не адрес внутренней сети
>>а внешний айпи,тут маршрутизацией не разрулить.
>>я ж печатал уже там...
>>тоесть вместо 10.0.3.1->10.66.66.1
>>у меня  10.0.3.1->313.334.222.66 (реальный айпи)
>>я думаю надо на пиксе что то прописать, но не пойму что,
>>делал как по этим ссылкам а всеравно в туннеле внешний айпи.
>>
>>
>>>>сделал все как по по ману, но всеравно на конце туннеля внешний
>>>>айпи,
>>>>подскажите, что прописать чтобы во внутреннюю сетку загнать пптп юзеров?
>>>>может трансляцию какую?
>>>>спасибо.
>>>>
>>>>>http://www.cisco.com/warp/public/110/pptppix.html
>>>>>
>>>>>логи смотреть на пиксе
>>>>>logg on
>>>>>logg con 7
>>>>>logg mon 7
>>>>>
>>>>>term mon - по необходимости.
>>>
>>>
>>>ну и ладно, тунель поднялся - трафик не идет во внутреннюю сеть?
>>>
>>>может тогда еще строчку маршрутизации на frebsd прописать что такая то сеть
>>>доступна через адрес вашего виртуального интерфейса?
>
>
>ИМХО вы не туда смотрите.
>поднял аналогичную конфигурацию на пиксе.
>в качестве клиента - винда.
>убрал опцию использовать pptp соединение в качестве дефаулт-гейта, прописал маршрут через pptp-адрес
>и все - все работает. так что ковыряйте bsd.
>
>конфиг:
>vpdn group 1 accept dialin pptp
>vpdn group 1 client configuration address local my-pool
>vpdn group 1 pptp echo 60
>vpdn username test password *********
>vpdn enable outside
>access-list nat-0 permit ip 192.168.1.0 255.255.255.0 10.1.1.0 255.255.255.0
>nat (inside) 0 access-list nat-0
>pixx(config)# sh ip
>System IP Addresses:
>        ip address outside 192.168.113.45
>255.255.255.0
>        ip address inside 192.168.1.1
>255.255.255.0
>
>
>
>но если вы хотите что бы у вас показывало следующее:
>тоесть вместо 10.0.3.1->10.66.66.1
>делайте IPSEC site-to-site. ссылка на доку выше по топику (именно IPSEC а
>не PPTP).
>может быть и в pptp такой вид можно получить - только зачем
>если все и так работает...


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру