The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Ограничение скорости на интерфейсах Catalyst 3560"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от Sergei email(??) on 28-Апр-06, 16:18 
Помогите разобраться почему следующие варианты по ограничению скорости на интерфейсах не работают и как решить данную проблему?
Желеска WS-C3560-24PS
ИОС C3560-IPSERVICES-M (c3560-ipservices-mz.122-25.SEE.bin)

первый вариант:

interface FastEthernet0/14
description Server-1
no switchport
ip address 195.125.3.145 255.255.255.248
rate-limit input 1024000 102400 204800 conform-action transmit exceed-action drop
rate-limit output 1024000 102400 204800 conform-action transmit exceed-action drop

второй вариант:

interface Vlan200
description Customs
ip address 192.168.255.169 255.255.255.252
rate-limit input 256000 25600 48000 conform-action transmit exceed-action drop
rate-limit output 256000 25600 48000 conform-action transmit exceed-action drop

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от bda (??) on 01-Май-06, 23:28 
>Помогите разобраться почему следующие варианты по ограничению скорости на интерфейсах не работают
>и как решить данную проблему?
>Желеска WS-C3560-24PS
>ИОС C3560-IPSERVICES-M (c3560-ipservices-mz.122-25.SEE.bin)
>
>первый вариант:
>
>interface FastEthernet0/14
> description Server-1
> no switchport
> ip address 195.125.3.145 255.255.255.248
> rate-limit input 1024000 102400 204800 conform-action transmit exceed-action drop
> rate-limit output 1024000 102400 204800 conform-action transmit exceed-action drop
>
>второй вариант:
>
>interface Vlan200
> description Customs
> ip address 192.168.255.169 255.255.255.252
> rate-limit input 256000 25600 48000 conform-action transmit exceed-action drop
> rate-limit output 256000 25600 48000 conform-action transmit exceed-action drop


Самому интересно, сейчас данные аппараты использую только как свичи... Не думал что IP-портами такая засада...
А в манах что-нить написано?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от Олег email(??) on 01-Май-06, 23:47 

>А в манах что-нить написано?

Да, данная команда не поддерживается.
См. здесь: http://www.cisco.com/en/US/products/hw/switches/ps5528/produ...
Проблему решать необходимо через QoS.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от bda email(ok) on 02-Май-06, 00:22 
>
>>А в манах что-нить написано?
>
>Да, данная команда не поддерживается.
>См. здесь: http://www.cisco.com/en/US/products/hw/switches/ps5528/produ...
>Проблему решать необходимо через QoS.

Т.е. через полисер?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от Lacunacoil (??) on 02-Май-06, 21:39 
>>
>>>А в манах что-нить написано?
>>
>>Да, данная команда не поддерживается.
>>См. здесь: http://www.cisco.com/en/US/products/hw/switches/ps5528/produ...
>>Проблему решать необходимо через QoS.
>
>Т.е. через полисер?


да через QOS на 3550 та же фигня

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от Sergei email(??) on 03-Май-06, 09:16 
>>>
>>>>А в манах что-нить написано?
>>>
>>>Да, данная команда не поддерживается.
>>>См. здесь: http://www.cisco.com/en/US/products/hw/switches/ps5528/produ...
>>>Проблему решать необходимо через QoS.
>>
>>Т.е. через полисер?
>
>
>да через QOS на 3550 та же фигня


Спасибо! Действительно работает. Интересно, а в будущих релизах ИОСов будет подедержка rate-limit?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от marten email on 19-Май-07, 02:07 
>>>>Проблему решать необходимо через QoS.
есть примеры у кого-нибудь?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от Олег email(??) on 21-Май-07, 11:26 
>>>>>Проблему решать необходимо через QoS.
>есть примеры у кого-нибудь?

Есть.
Схема пользователи -> FastEthernet0/24 -> коммутатор ->  FastEthernet0/1 -> Сеть назначения

Ограничение исходящего трафика на 1 Мбит.

Определяем классы:

Для выходящих с комм. пакетов (предварительно размеченные):

class-map match-all ->
  match ip dscp af11

Для разметки ограничиваемого траффика:

class-map match-all from
  match access-group name ->

!
Ограничение на 1 мбит:

policy-map ->(main)
  class ->
    police 1000000 8000 exceed-action drop

Разметка пакетов:

policy-map from
  class from
   set dscp af11

Назначение политики для исходящего, интересующего нас трафика:

interface FastEthernet0/1
description Link (primary)
no switchport
bandwidth 2000
ip address x.x.x.x x.x.x.x
service-policy output ->(main)

Разметка трафика:

interface FastEthernet0/24
description Connection to users
switchport access vlan x
switchport mode access
service-policy input from

Чего хотим ограничить:

ip access-list extended ->
permit ip x.x.x.x x.x.x.x any

Работает на 3550, должно работать и на 3560. Не проверял.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от marten email on 21-Май-07, 15:03 
>>>>>>Проблему решать необходимо через QoS.
>>есть примеры у кого-нибудь?
>
>interface FastEthernet0/1
> description Link (primary)
> no switchport
> bandwidth 2000
> ip address x.x.x.x x.x.x.x
> service-policy output ->(main)
>
>
>Работает на 3550, должно работать и на 3560. Не проверял.

в том-то и дело, на 3560, в отличие от 3550, полисинга нет на выходе интерфейса:

interface fa0/4
service-policy output TEST
police command is not supported for this interface
Configuration failed!
Warning: Assigning a policy map to the output side of an interface not supported

пришлось выворачиваться с помощью srr-queue:
speed 10
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
srr-queue bandwidth limit 20
вот таким образом 2Мбита отрезал :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от kan5300 email(??) on 13-Ноя-07, 00:20 
>[оверквотинг удален]
>Warning: Assigning a policy map to the output side of an interface
>not supported
>
>пришлось выворачиваться с помощью srr-queue:
> speed 10
> srr-queue bandwidth share 10 10 60 20
> srr-queue bandwidth shape  10  0  0  0
>
> srr-queue bandwidth limit 20
>вот таким образом 2Мбита отрезал :)

Спасибо, а то мы весь день фтыкаем +)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от sav (??) on 21-Дек-07, 06:44 
Способ ограничения скосроти в любом пределе скорости порта

interface FastEthernet0/5
speed 10
srr-queue bandwidth shape  80  80  80  80

Полоса shape-ра для каждой очереди при этом составит 10*1024*1024/80=128кбит/с
Обратная величина значение веса (1/80) характеризует выделенную полосу относительно скосрти инетрефейса. Вес может изменяется в пределах 1-65535

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от da_predator email(??) on 29-Дек-07, 18:56 
Подсакажите плиз, мне нужно сделать например 10-ку на порте, не ставя speed 10, это делается так?
interface FastEthernet0/2
description ***inet***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,3
switchport mode trunk
srr-queue bandwidth shape  256  256  256  256 ! здесь получается примерно 409 кб/сек ??
spanning-tree bpdufilter enable
spanning-tree bpduguard enable

начего не получилось....

#sh int fa 0/2
FastEthernet0/2 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0015.6348.3704 (bia 0015.6348.3704)
  Description: ***inet***
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:27, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
#sh int fa 0/2
FastEthernet0/2 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0015.6348.3704 (bia 0015.6348.3704)
  Description: ***inet plus***
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:27, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 684000 bits/sec, 158 packets/sec
  5 minute output rate 197000 bits/sec, 161 packets/sec

явно выше скорость

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от chuvy (??) on 08-Янв-08, 06:29 
На сколько я знаю shape работает только на аут и в 3550 шейп ставится только на аут - см. в опсаниях 3550, в 3560 возможно так же?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Ограничение скорости на интерфейсах Catalyst 3560"  
Сообщение от chuvy (??) on 08-Янв-08, 06:38 
Для 3550 написано что есть output QoS - то есть только аут.
На 3524 тоже есть много команд которые не работают(это по поводу rate-limit). Смотрите описание вашей модели.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру