The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OpenNews: web-браузер Epiphany будет использовать WebKit по ..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [ Отслеживать ]

"OpenNews: web-браузер Epiphany будет использовать WebKit по ..."  
Сообщение от opennews (??) on 01-Апр-08, 22:59 
Разработчики web-браузера Epiphany объявили (http://mail.gnome.org/archives/epiphany-list/2008-April/msg0...), что начиная со следующего релиза GNOME 2.24, Epiphany будет использовать WebKit для рендеринга HTML страниц, а поддержка движка Mozilla Geko будет прекращена. В качестве причин называется неприемлемо растянутый цикл подготовки релизов Geko, нехватка человеческих ресурсов на поддержание двух бэкендов. Из достоинств WebKit подчёркивается качественный API и GObject биндинг, как и Gnome в webKit используются библиотеки Cairo, Pango, libsoup и GStreamer.  


Подозрения в первоапрельском розыгрыше были развеяны упоминанием, того, что сообщать о больших изменениях в GNOME первого апреля стало уже традицией.


Напомню, что в релизе GNOME 2.22 в Epiphany была представлена экспериментальная поддержка движка WebKit.

URL: http://mail.gnome.org/archives/epiphany-list/2008-April/msg0...
Новость: https://www.opennet.ru/opennews/art.shtml?num=15067

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от vitek (??) on 01-Апр-08, 22:59 
давно пора!!!

из-за подобных разглагольствований предпочитаю KDE.
будет вменяемые стандарты на GNOME - с удовольствием буду пользоваться им (и проги писать тоже)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от Аноним (??) on 01-Апр-08, 23:31 
если честно, то так и не понял почему Firefox нормальный браузер на базе Gecko, а  Epiphany какой-то отстойный.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от RNZ email(ok) on 02-Апр-08, 01:20 
>если честно, то так и не понял почему Firefox нормальный браузер на
>базе Gecko, а  Epiphany какой-то отстойный.

Да вот не сказал бы, Epiphany быстрее запускается, меньше памяти жрёт, имеет поддержку плагинов, нет проблем с копированием/вставкой при русской расскладке, ctrl+mousewheel тоже пашет как положено (не инвертировано как firefox) да zoom быстрее.  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от Noa on 01-Апр-08, 23:45 
видимо дело не в Gecko... хоть на тридент его переводи, лажа пожизненная как была, так и останетяся
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от Аноним (??) on 02-Апр-08, 00:04 
>будет вменяемые стандарты на GNOME - с удовольствием буду пользоваться им (и проги писать тоже)

Так есть уже - mono! Пиши на сешарп-mono!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от vitek (??) on 02-Апр-08, 16:41 
>>будет вменяемые стандарты на GNOME - с удовольствием буду пользоваться им (и проги писать тоже)
>
>Так есть уже - mono! Пиши на сешарп-mono!

есть QT. На нем KDE. стандарты там вменяемые. документации хоть отбавляй.
а mono - .... короче, сам на нем пиши. и я, даже искренне, желаю удачи.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от Аноним (??) on 02-Апр-08, 05:53 
фигасе новости, уже фирефокс оказывается "нормальный" браузер О_о
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от Kamashev Max email on 02-Апр-08, 07:58 
Очень хорошо, что будет альтернатива.. Я сам пользуюсь firefox, но то, что будет будет браузер нативно использующий webkit - просто замечательно!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от Аноним (??) on 02-Апр-08, 08:35 
Когда уже firefox будет Webkit использовать?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от пИнгвин on 02-Апр-08, 11:07 
>Когда уже firefox будет Webkit использовать?

Да они удавятся в своей мозилле фандейшн... :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от ddc on 02-Апр-08, 12:16 
У меня есть одна система с GNOME, и по итогам попыток использовать разные браузеры я пришёл к выводу, что Epiphany - наиболее равновесный вариант. С поддержкой WebKit поэкспериментировать я ещё не успел, но возможность избавиться от тяжеловесного XULrunner'а меня крайне радует.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от Аноним (??) on 02-Апр-08, 12:28 
и взятка(грант) от Mozillы (https://www.opennet.ru/opennews/art.shtml?num=14577) не прокатила =)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от Gular (??) on 02-Апр-08, 12:53 
Дак вот FF 3 beta 4 уже не потребляет много. Подождём релиза.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от Аноним (??) on 02-Апр-08, 13:16 
Хотел на midori посмотреть, но в портах фри webkit зависит какого-то хрена от gnomevfs (и, соответственно, от помойки гномовских либ). Это она такая больная, или maintainer порта сплоховал? В любом случае, гномеров надо убивать.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "web-браузер Epiphany будет использовать WebKit по умолчанию"  
Сообщение от Аноним (??) on 02-Апр-08, 17:33 
"Using Gecko has always felt like surgically extracting pieces of another application, rather than using a well-designed library."

Увы, так оно и есть. XUL и Gecko сейчас одна большая толстая библиотека.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру