The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от opennews (?), 11-Июн-22, 13:14 
Опубликован релиз HTTP-сервера Apache 2.4.53, в котором представлено 19 изменений и устранено 8 уязвимостей:...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=57334

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  –7 +/
Сообщение от Онаним (?), 11-Июн-22, 13:14 
Так, проксю не юзаю, не интересно.
mod_http2 вообще можно выкинуть. Если нужен http/2 - проще haproxy на фронт навесить.
Но в целом годно, пойду соберу что-ли.
Ответить | Правка | Наверх | Cообщить модератору

35. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 00:54 
> Если нужен http/2 - проще haproxy на фронт навесить.

А ещё проще - взять nginx и перестать глумиться над скелетом индейца.

Ответить | Правка | Наверх | Cообщить модератору

38. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  –5 +/
Сообщение от Онаним (?), 12-Июн-22, 08:52 
И как, nginx уже научился внутрь модули динамических языков подключать, или всё ещё надо CGI костылить?
Ответить | Правка | Наверх | Cообщить модератору

39. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 08:53 
(вопрос совершенно не требует ответа, принцип обработки запросов в nginx годится только для отдачи статики, и чуть-чуть для прокси, но если мы о прокси - специализированные прокси типа haproxy гораздо удобнее)
Ответить | Правка | Наверх | Cообщить модератору

48. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +1 +/
Сообщение от Аноним (35), 12-Июн-22, 11:40 
> И как, nginx уже научился внутрь модули динамических языков подключать

Да, например, Lua.

> или всё ещё надо CGI костылить

Nginx не поддерживает CGI.

А если вы путаете CGI и FastCGI, то от админства в целом и юникс-подобных систем вы явно далеки.

Ответить | Правка | К родителю #38 | Наверх | Cообщить модератору

56. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 14:32 
Поиск CGI в слове FastCGI даёт мне true.
Фикси голову.
Ответить | Правка | Наверх | Cообщить модератору

63. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 16:43 
Ага, а PCI bus - это что-то вроде автобуса. Не, нуачо, похоже же звучит!
Ответить | Правка | Наверх | Cообщить модератору

66. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 17:25 
Ладно, для особо одарённых поясню.

Так что, нгинх уже внутрь себя может затянуть движки для динамики (индеец-то может очень много таковых), или до сих пор надо внешние процессы городить с отдельным протоколом для обмена между ними?

Ответить | Правка | Наверх | Cообщить модератору

67. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 17:33 
>  Ладно, для особо одарённых поясню.

А можно (для особо одарённых) пояснить, как вы ухитрились попасть в обсуждение новости о вебсервере, если вы не понимаете разницы между CGI и FastCGI (на том основании, что звучат похоже).

Это как к нам на собес приходил "опытный юниксовый админ", который утверждал, что UDP обязательно должен икапсулироваться в TCP (раскопки в каше внутри его головы показали, что он так воспринял услышанную где-то фразу "протокол UDP входит в стек TCP/IP").

> Так что, нгинх уже внутрь себя может затянуть движки для динамики (индеец-то может очень много таковых),

Может, но получится такая же хня, как и с апачом. А nginx потому и порешал на рыночке, что оказался на голову круче апача. Геморный в поддержке монолит с проблемами производительности.

> или до сих пор надо внешние процессы городить с отдельным протоколом для обмена между ними?

Это называется "модульность". Очень часто даёт бонусы по сравнению с подходом "зафигачим всё в один монолит и ещё утрамбуем сверху".

Ответить | Правка | Наверх | Cообщить модератору

69. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 21:52 
Я понимаю что тебе голоса в голове это всё нашептали. Но удивись, я знаю разницу между CGI и FastCGI.
Просто в контексте - вообще не принципиально. Одно дело когда у нас свой менеджер процессов готовый, и другое дело, когда мы по сути вёбсервер превращаем в прокси (а ничего кроме прокси и статики нгинх и не умеет), и навешиваем какие-то внешние костыли.
Ответить | Правка | Наверх | Cообщить модератору

79. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 13-Июн-22, 13:17 
> Я понимаю что тебе голоса в голове это всё нашептали.

Пожалуйста, не проецируйте на других свои проблемы.

> Но удивись, я знаю разницу между CGI и FastCGI.

А по вашим репликам и не скажешь.
Может быть, в еще PCI bus от автобуса отличить можете?

> Просто в контексте - вообще не принципиально. Одно дело когда у нас свой менеджер процессов готовый

Очень даже принципиально. У CGI модель управления процессами _всегда_ одна - пришёл запрос, процесс запустился, выплюнул что-то в stdout, это ушло клиенту, а процесс завершился.
FastCGI позволяет работать с долгоживущими пулами воркеров - то, ради чего когда-то люди добровольно садились на бутылку mod_php, но без бутылки.

> когда мы по сути вёбсервер превращаем в прокси (а ничего кроме прокси и статики нгинх и не умеет), и навешиваем какие-то внешние костыли.

Ага, костыли. Зависший пых может уронить отдачу статики, проблемы со статикой - завесить пых.

Ответить | Правка | Наверх | Cообщить модератору

70. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 21:54 
FastCGI, ещё удивись, внезапно умеет haproxy.
Поэтому твой нгинх даже в этом контексте в общем и целом вообще не нужен, это скорее религия.
Ответить | Правка | К родителю #67 | Наверх | Cообщить модератору

80. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 13-Июн-22, 18:44 
> FastCGI, ещё удивись, внезапно умеет haproxy.

И толку от этого, если у большинства пыхосайтов статика и скипты лежат в одном руте?
Веб-сервер может отдать статику сам, а динамику спроксировать в php-fpm.

Чистый FastCGI proxy - это API-сервисов, написанных более-менее квалифицированными разработчиками, а не стреднестатистическими пыхерами.

Ответить | Правка | Наверх | Cообщить модератору

2. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 11-Июн-22, 13:16 
Из важного, но не указанного

*) MPM event: Restart children processes killed before idle maintenance.
*) MPM event: Fix accounting of active/total processes on ungraceful restart

Ответить | Правка | Наверх | Cообщить модератору

3. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  –4 +/
Сообщение от Аноним (3), 11-Июн-22, 14:53 
Еще забыли написать что это единственный нормальный вебсервер.  
Ответить | Правка | Наверх | Cообщить модератору

7. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (7), 11-Июн-22, 16:14 
Особенно для пыхеров.  
Ответить | Правка | Наверх | Cообщить модератору

34. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 00:53 
Да, как говорил Лёня П., "хорошо, когда всё в одном".
Ответить | Правка | Наверх | Cообщить модератору

14. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +4 +/
Сообщение от Аноним (14), 11-Июн-22, 18:23 
А Caddy?
Ответить | Правка | К родителю #3 | Наверх | Cообщить модератору

17. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (17), 11-Июн-22, 18:45 
А про caddy искать "caddy Caddy-Sponsors headers" или читать https://web.archive.org/web/20190930230747/https://caddyserv... , чтобы понять что на уме у разрабов.
Ответить | Правка | Наверх | Cообщить модератору

28. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 11-Июн-22, 22:29 
Это был Caddy 1, он закономерно утонул.
Сейчас caddyserver - это caddy 2, полностью опенсорсный и без еулы.
Ответить | Правка | Наверх | Cообщить модератору

19. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  –8 +/
Сообщение от Онаним (?), 11-Июн-22, 18:56 
Оно на игого.
Так, поржать?
Ответить | Правка | К родителю #14 | Наверх | Cообщить модератору

33. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 00:52 
Ваша аргументация, боюсь, лишь негативно характеризует ваш интеллектуальный уровень.
Ответить | Правка | Наверх | Cообщить модератору

40. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 08:55 
Честно? Мне абсолютно фиолетово, что вы там себе придумываете об этой аргументации.
Меня больше волнуют вопросы выбора решений на долгосрок, в которые что угодно на го, растах и прочих руби - не входит.
Ответить | Правка | Наверх | Cообщить модератору

46. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +1 +/
Сообщение от Аноним (46), 12-Июн-22, 10:06 
Если тебе все равно зачем об этом писать. Значит тебе не все равно и ты внутри себя осознаешь свою пхпшную ничтожность.  
Ответить | Правка | Наверх | Cообщить модератору

49. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 11:42 
> Честно? Мне абсолютно фиолетово, что вы там себе придумываете об этой аргументации.

Вы просто выставляете на обозрение уровень своей глупости.

> Меня больше волнуют вопросы выбора решений на долгосрок, в которые что угодно на го, растах и прочих руби - не входит.

Ну да, логика как у блондинки - "эта машинка мне нравится больше, потому что она розовенькая".

Ответить | Правка | К родителю #40 | Наверх | Cообщить модератору

55. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 14:31 
Shoo.
Ответить | Правка | Наверх | Cообщить модератору

60. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 16:40 
Эта реплика, очевидно, символизирует апекс ваших интеллектуальных способностей?
Ответить | Правка | Наверх | Cообщить модератору

71. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 22:06 
Очевидно, что ты её понять не смог.
Ответить | Правка | Наверх | Cообщить модератору

57. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (57), 12-Июн-22, 14:38 
Когда языку уже 13 лет, есть устоявшийся стек, и стабильный спрос по вакансиям, а анонимы до сих пор то ли на пыху намекают, то ли на шарпы с жабой. "Долгосрок", кек.
Ответить | Правка | К родителю #40 | Наверх | Cообщить модератору

58. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 15:07 
На вакансии дворников тоже есть стабильный спрос.
Но это не значит.
Ответить | Правка | Наверх | Cообщить модератору

73. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (73), 13-Июн-22, 09:26 
Ну пока у тебя "не значит", у других уже легаси на голанге пятилетнее, которое приносит владельцам конскую маржу и саппортится джунами за копейки, которые благодаря дубовости языка ничего не могут сломать, даже если очень захотят.
Ответить | Правка | Наверх | Cообщить модератору

74. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 13-Июн-22, 09:27 
Пятилетнее легаси - это феерично :D
Ответить | Правка | Наверх | Cообщить модератору

75. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 13-Июн-22, 09:28 
(да не, я понимаю, что для однодневок пять лет - это вечность, но у меня как-то легаси от 10-15 начинается)
Ответить | Правка | К родителю #73 | Наверх | Cообщить модератору

16. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (16), 11-Июн-22, 18:40 
> children

Sjwшники детей любят? Когда поставит на место этих извратителей!

children > smaller

Я здесь власть!!!

Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

18. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 11-Июн-22, 18:54 
Не закусил в этот раз?
Сочувствую.
Ответить | Правка | Наверх | Cообщить модератору

43. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (43), 12-Июн-22, 09:37 
А они делали ранее типичные black/white/slave/mistress/итд? Если нет, то мимо. Если да - поддерживаю, на горох разработчиков за такое, занимаются угнетением подростков.
Ответить | Правка | К родителю #16 | Наверх | Cообщить модератору

4. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (3), 11-Июн-22, 14:54 
Проблема, которая появляется только на Windows это пять я считаю.  
Ответить | Правка | Наверх | Cообщить модератору

5. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +1 +/
Сообщение от Онаним (?), 11-Июн-22, 15:37 
Таких полно в каждом софте, который и там и сям работает.
Ответить | Правка | Наверх | Cообщить модератору

6. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  –1 +/
Сообщение от Аноним (7), 11-Июн-22, 16:13 
Да это ОС отстой, а не софт.  
Ответить | Правка | Наверх | Cообщить модератору

37. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +1 +/
Сообщение от Аноним (37), 12-Июн-22, 08:38 
В случае же, когда баг есть только на линуксе, то "это другое"?
Ответить | Правка | Наверх | Cообщить модератору

47. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (46), 12-Июн-22, 10:07 
Линукс то не отстой головой то думай иногда.  
Ответить | Правка | Наверх | Cообщить модератору

8. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (8), 11-Июн-22, 16:23 
>mod_lua

На луа можно сайты делать?

Ответить | Правка | Наверх | Cообщить модератору

9. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +2 +/
Сообщение от Аноним (-), 11-Июн-22, 16:30 
А почему, собственно, нет?
Ответить | Правка | Наверх | Cообщить модератору

10. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +5 +/
Сообщение от Аноним (10), 11-Июн-22, 16:59 
Это может показаться диким бредом, но даже на JavaScript можно
Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

22. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от gone (?), 11-Июн-22, 19:31 
Вы из нулевых заглянули сюда на минуточку что-ли? Node.js-у 13 лет, версий аж 18.
Ответить | Правка | Наверх | Cообщить модератору

24. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +2 +/
Сообщение от Аноним (24), 11-Июн-22, 21:05 
Популярен он не так давно лет 7-10.  
Ответить | Правка | Наверх | Cообщить модератору

11. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +1 +/
Сообщение от Аноним (11), 11-Июн-22, 18:09 
Хоть на чём, умеющем в хеловорлд.
Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

13. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (13), 11-Июн-22, 18:13 
Есть такое слово «целесообразность»
Ответить | Правка | Наверх | Cообщить модератору

15. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (14), 11-Июн-22, 18:24 
Есть еще слово "безопасность". Поэтому сайты нужно делать на C++ (Wt).
Ответить | Правка | Наверх | Cообщить модератору

21. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от brain_bug (?), 11-Июн-22, 19:29 
>сайты нужно делать на C++

Включая фронтенд.

Ответить | Правка | Наверх | Cообщить модератору

29. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Анонимчик (?), 11-Июн-22, 22:44 
Ну wasm же есть, почему нет если надо портануть приложение в веб?
Ответить | Правка | Наверх | Cообщить модератору

32. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 00:50 
> Есть еще слово "безопасность". Поэтому сайты нужно делать на C++ (Wt).

И сразу делать по центру поле ввода с рутовым шеллом?

Ответить | Правка | К родителю #15 | Наверх | Cообщить модератору

12. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  –2 +/
Сообщение от Аноним (13), 11-Июн-22, 18:12 
На луа нет библиотек. Без библиотек никто не умеет работать. Это тебе не npm.
Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

20. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 11-Июн-22, 19:01 
Это да, ныне пробелы слева в строку подставить без лефтпада мало кто умеет.
Ответить | Правка | Наверх | Cообщить модератору

23. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (24), 11-Июн-22, 21:04 
Скажи не подглядывая как сделать лефтпад в луа? Ха не смог, а туда же.  
Ответить | Правка | Наверх | Cообщить модератору

25. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 11-Июн-22, 21:21 
Если именно в луа и не изголяться - то string.format. Не самый оптимальный способ конечно.
А если изголяться - то len, rep, конкатенация.
Ответить | Правка | Наверх | Cообщить модератору

27. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (27), 11-Июн-22, 22:05 
Напишите реализацию leftpad без Гугла и подсказок IDE
Ответить | Правка | Наверх | Cообщить модератору

41. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  –1 +/
Сообщение от Онаним (?), 12-Июн-22, 08:56 
В чём проблема-то? Две строковых функции и оператор конкатенации вспомнить не можете?
Ответить | Правка | Наверх | Cообщить модератору

42. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 09:01 
В том, на чём я в основном пишу, "лефтпад" встроен. str_pad() называется.
В сях проще выделить буфер и скопировать.

А так - псевдокод для почти любого языка:
if ((strLength = length(string)) < paddedLength)
  string = repeat(' ', paddedLength - strLength) + string;

В чём проблемо-то?

Ответить | Правка | К родителю #27 | Наверх | Cообщить модератору

44. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (46), 12-Июн-22, 09:51 
Всё ясно то на чём ты пишешь сказалось на том как ты думаешь.
Ответить | Правка | Наверх | Cообщить модератору

51. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 11:45 
Я, кажется, начинаю понимать, почему JS-разработчики стараются не думать.
Ответить | Правка | Наверх | Cообщить модератору

59. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 15:10 
Ну извини, думать ещё не разучился, да.
Ответить | Правка | К родителю #44 | Наверх | Cообщить модератору

61. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  –2 +/
Сообщение от Аноном (?), 12-Июн-22, 16:41 
У всех пыхеров есть синдром даннинга-крюгера. Они на столько глупы что даже не могут этого понять. Потому как даже не знают как это «думать».  
Ответить | Правка | Наверх | Cообщить модератору

64. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 16:46 
По моим наблюдениям, среднестатистический пыхер на несколько пунктов IQ умнее среднестатистического JS-ера. Просто потому, что очень сложно выглядеть глупее JS-ера.
Но вот конкретно данный экземпляр - очень старательно пытается :)
Ответить | Правка | Наверх | Cообщить модератору

65. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 12-Июн-22, 17:23 
К счастью, пыхеры несколько умнее тебя, и поэтому "настолько" - пишут слитно.
Ответить | Правка | К родителю #61 | Наверх | Cообщить модератору

84. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (84), 14-Июн-22, 16:07 
Главное чтоб у тебя самого не было синдрома даннинга-крюгера...
Ответить | Правка | К родителю #61 | Наверх | Cообщить модератору

76. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +1 +/
Сообщение от Аноним (27), 13-Июн-22, 09:43 
В том что здесь рассуждают про ум "пыхеров" и "jsников", но ни одной рабочей реализации простейшей функции leftpad на любом языке не привели

Из чего можно сделать вывод: комментаторы оторваны от реальности, пытаются самоутверждаться в собственных глазах вываливая продукты жизнедеятельности на opennet.

Ответить | Правка | К родителю #42 | Наверх | Cообщить модератору

77. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Онаним (?), 13-Июн-22, 10:02 
Вероятно, да.
Я выше псевдокод привёл, легко транслируется почти на любой нынешний сверхвысокоуровневый язык.
В чистых сях и на ассемблере, правда, повторюсь, делается немножко по-иному, но там и строки - тупо массив байт.
Ответить | Правка | Наверх | Cообщить модератору

82. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (84), 14-Июн-22, 15:46 
Приходит opennetовец на собеседование на junior разработчика Си. Конечно, opennetовец с его IQ пойдет минимум на сеньора, но мало ли как сложатся обстоятельства...
Дают ему задание реализовать функцию, дополняющую строку пробелами, на листке бумаги или в простом онлайн редакторе.
opennetовец такой, вот вам псевдокод, транслируйте в любой высокоуровневый язык и даже в ассемблер.
На этом месте интервьюеры понимают, что перед ними сеньор с несравнимы с каким-нибудь пыхером или JS-ером IQ

Ответить | Правка | Наверх | Cообщить модератору

83. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (84), 14-Июн-22, 15:49 
я думаю, opennetовца не примут на работу по абсолютно понятной причине.
Потому что слишком умный и быстро займет место интервьюеров.
Ответить | Правка | Наверх | Cообщить модератору

30. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +4 +/
Сообщение от Анонимчик (?), 11-Июн-22, 22:45 
Luarocks
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

36. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 01:11 
Да ладно, это же фронтендщик. Они искренне верят, что JS - единственный язык, у которого есть собственный пакетный менеджер.

Соответственно, слова pip, luarocks, composer, cpan, gem - ни о чём им не говорят, в лучшем случае можно добиться "это какая-то старая фигня, которой дедушки пользовались за двадцать лет до моего рождения".

Ответить | Правка | Наверх | Cообщить модератору

45. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (46), 12-Июн-22, 09:52 
Да ладно расскажи почему луа так и не обогнал ноду? И почему сайтовый бекенд на луа никто не делает?
Ответить | Правка | Наверх | Cообщить модератору

50. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (35), 12-Июн-22, 11:43 
Потому, что JS-разработчиков на рынке столько, что нанимать их можно буквально за еду.
Ответить | Правка | Наверх | Cообщить модератору

52. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +2 +/
Сообщение от Аноним (52), 12-Июн-22, 13:26 
Сед бат тру.
Ответить | Правка | Наверх | Cообщить модератору

31. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +1 +/
Сообщение от Аноним (31), 11-Июн-22, 22:47 
Роутерные интерфейсы же делают, чё б и сайты не делать. На чём угодно можно, хоть баш, хоть ассемблер.
Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

53. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (52), 12-Июн-22, 13:27 
Ассемблер это все равно что на говнокоде писать.  
Ответить | Правка | Наверх | Cообщить модератору

54. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноним (31), 12-Июн-22, 13:28 
> Ассемблер это все равно что на говнокоде писать.

А в чём проблема? Возьмёшь готовый веб-фреймворк, если сам красиво сделать не можешь.

Ответить | Правка | Наверх | Cообщить модератору

62. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от Аноном (?), 12-Июн-22, 16:42 
Фреймворк на ассемблере? Чето ржу.  
Ответить | Правка | Наверх | Cообщить модератору

78. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +1 +/
Сообщение от mikhailnov (ok), 13-Июн-22, 10:11 
Благодаря CGI сайты можно делать на чем угодно, что умеет выводить текст в stdout.
Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

81. "Релиз http-сервера Apache 2.4.54 с устранением уязвимостей"  +/
Сообщение от 1 (??), 14-Июн-22, 10:13 
так-то да ...
Но если, например, придёт 1000000 запросов, то запустятся 1000000 /bin/sh для CGI. Это если CGI на /bin/sh сделан ... А если на perl, или не дай Б-г на питоне ?
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру