The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Нарушение обратной совместимости в популярном NPM-пакете привело к сбоям в различных проектах"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Нарушение обратной совместимости в популярном NPM-пакете привело к сбоям в различных проектах"  +/
Сообщение от opennews (ok), 16-Янв-22, 11:11 
В репозитории NPM наблюдается очередной массовый сбой в работе проектов из-за возникновения пробоем в новой версии одной из популярных зависимостей. Источником проблем стал новый выпуск пакета...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=56517

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +27 +/
Сообщение от Linuxoid85 (ok), 16-Янв-22, 11:11 
Никогда такого не было, и вот опять
Ответить | Правка | Наверх | Cообщить модератору

3. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Корец (?), 16-Янв-22, 11:14 
Не, в этот раз что-то новенькое, обычно только про уязвимости пишут.
Ответить | Правка | Наверх | Cообщить модератору

11. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от . (?), 16-Янв-22, 11:58 
Помнити leftpad!

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

19. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +11 +/
Сообщение от anonymous (??), 16-Янв-22, 12:29 
Он и так весь помятый.
Ответить | Правка | Наверх | Cообщить модератору

69. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от AKTEON (?), 17-Янв-22, 00:08 
Надо откатить на предыдущий интерфейс и заблокировать автора, чтоб неповадно было .хе-хе
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

2. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +18 +/
Сообщение от Онаним (?), 16-Янв-22, 11:14 
Отличная новость, побольше таких.
Ответить | Правка | Наверх | Cообщить модератору

10. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –4 +/
Сообщение от OpenBotNET (ok), 16-Янв-22, 11:45 
Вы - мазохист? Или любите на Gentoo экстримом заниматся?
Ответить | Правка | Наверх | Cообщить модератору

12. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +9 +/
Сообщение от КО (?), 16-Янв-22, 11:59 
Больше факапов с одной и той же нерешенной проблемой всегда приносит улыбку
Ответить | Правка | Наверх | Cообщить модератору

17. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –1 +/
Сообщение от onanim (?), 16-Янв-22, 12:16 
"эту" проблему может решить только глобальный катаклизм типа термоядерной войны или какого-нибудь супервируса. но мало кто согласится на такое.
Ответить | Правка | Наверх | Cообщить модератору

14. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (14), 16-Янв-22, 12:08 
>экстримом заниматся?

Это вы так круто "ждать ебилдов" завуалировали.

Ответить | Правка | К родителю #10 | Наверх | Cообщить модератору

4. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +2 +/
Сообщение от бугурма (?), 16-Янв-22, 11:32 
вот это вот всё показывает на сколько беспечны бывают вот эти вот люди
Ответить | Правка | Наверх | Cообщить модератору

6. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +6 +/
Сообщение от псевдонимус (?), 16-Янв-22, 11:35 
Да им просто похер.
Ответить | Правка | Наверх | Cообщить модератору

5. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +3 +/
Сообщение от псевдонимус (?), 16-Янв-22, 11:34 
>очередной массовый сбой в работе проектов из-за возникновения проблем в новой версии одной из популярных зависимостей.

Не может быть!

Ответить | Правка | Наверх | Cообщить модератору

7. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +2 +/
Сообщение от псевдонимус (?), 16-Янв-22, 11:40 
>В числе пострадавших оказались пользователи развиваемого компанией Facebook пакета

Прекрасная новость!
Пойду боярки накачу.

Ответить | Правка | Наверх | Cообщить модератору

8. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +12 +/
Сообщение от Аноним (8), 16-Янв-22, 11:41 
Гитхаб уже заблокировал его аккаунт?
Ответить | Правка | Наверх | Cообщить модератору

30. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +5 +/
Сообщение от Аноним (30), 16-Янв-22, 12:54 
Ещё можно принять закон, чтобы наказывать опенсорсных и работающих за бесплатно программистов рублём и тюремным заключением. Только потом не надо удивляться, что программировать вообще никто не захочет.
Ответить | Правка | Наверх | Cообщить модератору

40. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Аноним (-), 16-Янв-22, 15:23 
наказывать погромистов за убытки, если херак херак и прокдашин.
Ответить | Правка | Наверх | Cообщить модератору

53. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +4 +/
Сообщение от Онаним (?), 16-Янв-22, 19:14 
В смысле начинать выплачивать им рублёвые зарплаты?
Да, это достаточно страшная кара.
Ответить | Правка | К родителю #30 | Наверх | Cообщить модератору

9. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +6 +/
Сообщение от pashev.me (?), 16-Янв-22, 11:43 
Террористическое программирование.
Ответить | Правка | Наверх | Cообщить модератору

36. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +3 +/
Сообщение от псевдонимус (?), 16-Янв-22, 14:05 
Экстремистское же! "13000000 экстремистов" ;-)
Ответить | Правка | Наверх | Cообщить модератору

37. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –1 +/
Сообщение от Аноним (37), 16-Янв-22, 14:06 
Нет, это копипасторское программирование. Если есть пример на stackoverflow, то читать документацию не нужно.
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

80. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от pashev.me (?), 17-Янв-22, 07:03 
А ты читал документацию? Что там написано по главной ссылке к новости?
Ответить | Правка | Наверх | Cообщить модератору

96. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –1 +/
Сообщение от Злой Аноним (?), 17-Янв-22, 15:08 
JS-макак, JS-макак, кодер-террорист
держит lint огромный в руке неоджесист
JS-макак, JS-макак, делает push в npm
дебаг без остановки выбирает мэн
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

13. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Аноним (13), 16-Янв-22, 12:01 
аминь
Ответить | Правка | Наверх | Cообщить модератору

58. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Аноним (58), 16-Янв-22, 20:39 
земля пухом
Ответить | Правка | Наверх | Cообщить модератору

15. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +5 +/
Сообщение от kusb (?), 16-Янв-22, 12:13 
Башня из зависимостей. Глобальная. Связанная.
Ответить | Правка | Наверх | Cообщить модератору

52. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –2 +/
Сообщение от Аноним (52), 16-Янв-22, 18:52 
UNIX-way же.
Ответить | Правка | Наверх | Cообщить модератору

56. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +2 +/
Сообщение от Аноним (56), 16-Янв-22, 20:18 
dll-hell пошёл от микрософта.
Ответить | Правка | Наверх | Cообщить модератору

64. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –3 +/
Сообщение от Аноним (64), 16-Янв-22, 22:33 
А туда, в свою очередь, пришёл из кучи разрозненных проектов, попадающих под определение так называемого "UNIX way"
Ответить | Правка | Наверх | Cообщить модератору

59. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +2 +/
Сообщение от Аноним (58), 16-Янв-22, 20:40 
Это не юникс вей - это маразм.
Ответить | Правка | К родителю #52 | Наверх | Cообщить модератору

97. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Злой Аноним (?), 17-Янв-22, 15:11 
unix-way - это когда suckless.org, а не когда leftpad.js.
Ответить | Правка | К родителю #52 | Наверх | Cообщить модератору

16. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +4 +/
Сообщение от onanim (?), 16-Янв-22, 12:14 
не перестаю офигевать с объёмов загрузок.

все эти "популярные NPM пакеты" качаются 10-100 раз _в секунду_. это ж охренеть можно, насколько быдлокодеры обыдлились, что не поставляют пакет со своим софтом, а каждый раз выкачивают заново.

Ответить | Правка | Наверх | Cообщить модератору

21. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –4 +/
Сообщение от Аноним (21), 16-Янв-22, 12:32 
Нормальные пакеты ставятся в систему и поддерживают совместимость только с последней версией.
Ответить | Правка | Наверх | Cообщить модератору

29. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Аноним (29), 16-Янв-22, 12:52 
Нормальные пакеты не меняют свои интерфейсы спонтанно.
А если меняют - выкатывают новую версию(грубо говоря сменил интерфейсы, сломал совместимость, сделал версию n+1).
Ответить | Правка | Наверх | Cообщить модератору

39. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от JL2001 (ok), 16-Янв-22, 14:39 
> Нормальные пакеты не меняют свои интерфейсы спонтанно.
> А если меняют - выкатывают новую версию(грубо говоря сменил интерфейсы, сломал совместимость,
> сделал версию n+1).

так там версия сменилась
но зависимые не указали версию либы и пакетменеджер скачал последнюю доступную

Ответить | Правка | Наверх | Cообщить модератору

49. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +2 +/
Сообщение от Аноним (49), 16-Янв-22, 17:58 
Там автор сменил не мажорную, а минорную версию.
Ответить | Правка | Наверх | Cообщить модератору

74. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от x3who (?), 17-Янв-22, 01:19 
так при мажорном апгрейле там может вовсе арзитектуру зависимых проектов поменять придется.
Ответить | Правка | Наверх | Cообщить модератору

31. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +6 +/
Сообщение от another_one (ok), 16-Янв-22, 12:55 
Это скорее всего системы непрерывной интеграции, которые собирают проект с нуля на каждый коммит (тестирование). Почему они не поднимают кэш пакетов локально - это вопрос к администраторам этих систем (привет, GitHub).
Ответить | Правка | К родителю #16 | Наверх | Cообщить модератору

51. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Роман (??), 16-Янв-22, 18:21 
понятно почему - в статье на StackOverflow написано что скопипастить в .gitlab-ci.yml для запуска yarn на бесплатном gitlab-runner'e в докере, а как менеджить кэш, ttl и как вообще это вот всё - уже начинает "парить", интернет быстрый, проще скачать.
Ответить | Правка | Наверх | Cообщить модератору

18. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (18), 16-Янв-22, 12:20 
Костыльщики. Сначала всё в 1 упаковывают, потом экстрагируют. Но оно всё равно по нескольку мегабайт выкачивать будет при запуске сайта, да еще и это в браузер встраивают под видом приложений. "После нас хоть потоп. Я могу всё что угодно разработать, но только с импортами".
Ответить | Правка | Наверх | Cообщить модератору

20. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (20), 16-Янв-22, 12:31 
> Сначала всё в 1 упаковывают, потом экстрагируют

Логика в этом есть. Видишь ли, содержание CSS-файла прямо зависит от того, как его использует JavaScript. Именно JavaScript-часть приложения диктует, какие стили понадобятся в CSS, а какие нет. Если писать CSS вручную (даже при помощи SASS), в нем постепенно начнут накапливаться стили, которые в JavaScript никак не задействуются.

Ответить | Правка | Наверх | Cообщить модератору

25. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (29), 16-Янв-22, 12:40 
Вообще, логика использования такого объема JS - сомнительна.
Это не маразм типа нынешнего "майнинга"(не путать с нормальным(дата майнингом)) но тоже и море ресурсов в никуда, и толку мало.

Не говоря уже о том что браузеры стали монстрами что жрут ресурсов(при 1 пустой странице) больше чем вся ОС.

Ответить | Правка | Наверх | Cообщить модератору

26. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Аноним (20), 16-Янв-22, 12:48 
> логика использования такого объема JS - сомнительна

Большинство пакетов в node_modules (включая сабж) нужны только при сборке и в финальный бандл не попадают, а оставшаяся часть попадет в усеченном виде.

Ответить | Правка | Наверх | Cообщить модератору

98. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –1 +/
Сообщение от Аноним (98), 17-Янв-22, 16:37 
>Большинство пакетов в node_modules (включая сабж) нужны только для того, чтобы было где спрятаться бэкдору.
Ответить | Правка | Наверх | Cообщить модератору

22. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от лолшто (?), 16-Янв-22, 12:34 
В проекте должен быть свой .npmrc, содержащий строку

save-exact = true

А так, конечно, веб - это карточный домик.

Ответить | Правка | Наверх | Cообщить модератору

54. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Онаним (?), 16-Янв-22, 19:15 
Картонная будка уже.
Ответить | Правка | Наверх | Cообщить модератору

73. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (73), 17-Янв-22, 01:06 
Кто внутри?
Ответить | Правка | Наверх | Cообщить модератору

81. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от псевдонимус (?), 17-Янв-22, 09:47 
Почти все пользователи интернет.
Ответить | Правка | Наверх | Cообщить модератору

99. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Онаним (?), 17-Янв-22, 20:44 
> Кто внутри?

Хомячок. Возможно даже хомячки. И имя им - легион.

Ответить | Правка | К родителю #73 | Наверх | Cообщить модератору

23. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +2 +/
Сообщение от YetAnotherOnanym (ok), 16-Янв-22, 12:35 
Поэтому, если рассудок и жизнь дороги вам, держитесь подальше от средств, позволяющих программировать, не включая голову.
Ответить | Правка | Наверх | Cообщить модератору

24. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –3 +/
Сообщение от Аноним (29), 16-Янв-22, 12:35 
Я до реального погромирования так и не добрался(да и вообще все еще учусь), но везде в книгах и туторах говорится что как только "API"(в том числе и интерфейсы классов\библиотек) устаканен - его внезапно менять верх непрофессионализма.
Тут или сиди на старой, или делай новую версию ПО, или новую версию API(v2, v3, ... vN). Ну или хотя-бы долби пол года ворнингами.
Но лучше не менять.

Почему все эти борцы за свободное ПО, GNUсы и прочие гитхабы не борются с плохим качеством опенсурса?

Оно так то прикольно(я про гитхаб) - сломал удалив пакет - бан, сломал сменил API - пофиг(хотя-бы ачивку "мудак" давали бы).

Ответить | Правка | Наверх | Cообщить модератору

70. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Ordu (ok), 17-Янв-22, 00:22 
Читай внимательно новость:

> Проблема проявилась в проектах, не применяющих явную привязку к номеру версии при подключении зависимостей. В качестве обходного пути решения проблемы рекомендовано зафиксировать привязку к прошлой версии 2.4.5

Изменилось API, изменилась версия. Но разрабам ведь влом следить за версиями, так? Они ж надеются, что оно само как-нибудь работать будет. И это в НЕ-компилируемом языке, в котором все фейлы происходят в рантайме.

Да и вообще, книги и туторы -- это хорошо, но я тебе по секрету скажу одну вещь, которую книги и туторы обычно забывают сказать: теория и практика хоть и идут рука об руку, но всё ж разными путями. Теория она потому и теория, что она начинает с выкидывания из рассмотрения тех аспектов предметной области, которые усложняют мыслительный процесс теоретика настолько, что ему не удаётся придумать стройную теорию. Это конечно же тоже теория -- теория о теориях -- но мне приходилось в несколько разных областей человеческой деятельности погружаться, и в каждой я на практике находил расхождения теории и практики.

Ответить | Правка | Наверх | Cообщить модератору

71. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Урри (ok), 17-Янв-22, 00:49 
Спросите теоретика можно ли взломать RSA. И он ответит вам - "элементарно, просто факторизуйте вот это число". А теперь спросите практика...
Ответить | Правка | Наверх | Cообщить модератору

82. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от псевдонимус (?), 17-Янв-22, 09:50 
Гляди как тебя заминусили омноклепы. Это люди без уважения к себе и своей работе. Правильно, учись делать хорошо. Плохо и так получится.
Ответить | Правка | К родителю #24 | Наверх | Cообщить модератору

104. "Нарушение обратной совместимости в популярном NPM-пакете..."  +/
Сообщение от arisu (ok), 21-Янв-22, 12:27 
> его внезапно менять верх непрофессионализма.

ну так пусть требуют назад свои деньги.

Ответить | Правка | К родителю #24 | Наверх | Cообщить модератору

27. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –5 +/
Сообщение от Аноним (29), 16-Янв-22, 12:50 
Ха.
А вот в Арче нельзя иметь 2 одинаковых пакета.
И когда 1 пакет хочет пакет жопка.13* а второ хочет жопка.12* то жопка настает уже обновлению(пакетный манагер как бы говорит нам "я не могу затащить зависимости, чини их").
В итоге часто что-то будет не обновлено(в игнор закинуто) потому что вот.

А что-то обновится но отвалится от этого.
Так то я За первые пол года на Арче узнал о линуксе больше чем за 20 лет до этого, даже онлайн курсы по линю прошел. Но это Линукс.

А что даст подобная долботня с JS\Python\Подобным?

Ответить | Правка | Наверх | Cообщить модератору

60. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +3 +/
Сообщение от Аноним (58), 16-Янв-22, 20:42 
> Но это Линукс.

Осталоьс понять причем здесь линукс и пакетный менеджер конкретного дистра.

Ответить | Правка | Наверх | Cообщить модератору

28. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –2 +/
Сообщение от Аноним (30), 16-Янв-22, 12:50 
Не понимаю что происходит. Человек решил поменять API в своём собственном проекте и не хочет заниматься хаками и поддержкой легаси кода. Вместо того чтобы изменить одну строчку с импортом, все начали наезжать на него и учить жизни. Не пойти ли вам нафиг! Если у вас что-то сломалось, это ваши собственные проблемы, это опенсорс и вы не в магазине, чтобы предъявлять свои претензии.
Ответить | Правка | Наверх | Cообщить модератору

32. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от another_one (ok), 16-Янв-22, 13:00 
Сменить строчку не проблема, проблема в том, что отломался весь существующий код, его использующий. Но это не критично, т.к. вроде используется только для билда проектов и на прод не попадет. По хорошему автору надо было всего лишь выставить версию "3.0.0". Событие не тянет на новость.
Ответить | Правка | Наверх | Cообщить модератору

34. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –3 +/
Сообщение от Аноним (34), 16-Янв-22, 13:10 
Баба Маня ежедневно бесплатно кормила тебя конфетами. Например, M&Ms. Однажды баба Маня заменила все коричневые конфеты козьими экскриментами и снова тебя покормила. Хорошо ли поступила баба Маня?
Ответить | Правка | К родителю #28 | Наверх | Cообщить модератору

41. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +3 +/
Сообщение от Аноним 80_уровня (ok), 16-Янв-22, 15:42 
Не так.
Баба Маня ежедневно выкладывала на завалинку конфеты, а ты их бесплатно ел, проходя мимо.
Но однажды баба Маня вместо конфет положила на завалинку козьи экскременты, а ты опять...
Это баба Маня нехороший человек, правда ведь?
Ответить | Правка | Наверх | Cообщить модератору

42. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Аноним (42), 16-Янв-22, 15:57 
Баба маня оставляла конфеты на подоконнике, а ты их ежедневно оттуда брал не предоставляя ничего в замен. Баба маня решила рефакторнуть подоконник по собственным соображениям, так как это ее подоконник и на место конфет положила козинные ммдемсы, а конфеты положила на другой край подоконника.
Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

50. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (34), 16-Янв-22, 18:18 
Отвечаю сразу обоим:
Баба Маня опубликовала код не у себя в локальном паразитории, а в публично доступном месте, созданном специально для распространения кода. Так что и оба раза мимо.
Ответить | Правка | Наверх | Cообщить модератору

75. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от x3who (?), 17-Янв-22, 01:36 
Не ппавильная ана логия. Баба Маня вкладывала конфеты в фантике, а тут выложила в другоммфантике и ещё указала, что это другая версия подачки. Те, кто неглядя жрали конфеты прямо с фантиком, получили расстройство желудка.
Ответить | Правка | Наверх | Cообщить модератору

102. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от gogo (?), 18-Янв-22, 14:26 
Подоконник бабы Мани доступен публично.
Вот только она конфеты не для тебя конкретно делала, а с целью покормить зеленю птичку. И не возражала, чтобы и ты их ел.
Ответить | Правка | К родителю #50 | Наверх | Cообщить модератору

95. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от john_erohin (?), 17-Янв-22, 14:45 
надо ввести правило типа закона Годвина:
кто первый перешел на аналогии без КРАЙНЕЙ необходимости - тот лох и лузер.
Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

55. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Онаним (?), 16-Янв-22, 19:16 
Макаки удивились, обнаружив, что автообновление лефтпада может что-то сломать.
Ответить | Правка | К родителю #28 | Наверх | Cообщить модератору

63. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от kai3341 (ok), 16-Янв-22, 22:24 
Проебахтунг тут только в одном -- следовало заморочаться обратной совместимостью, сохранив совместимость и с require, и с import. Но это, скорее, мне самому на будущее
Ответить | Правка | К родителю #28 | Наверх | Cообщить модератору

65. "Нарушение обратной совместимости в популярном NPM-пакете при..."  –1 +/
Сообщение от Онаним (?), 16-Янв-22, 22:45 
Зачем, особенно если бесплатно? Проблемы end user, никто ничего никому не обещал.
Ответить | Правка | Наверх | Cообщить модератору

68. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от kai3341 (ok), 16-Янв-22, 23:48 
За шкафом. Разработчик не анонимен
Ответить | Правка | Наверх | Cообщить модератору

76. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от x3who (?), 17-Янв-22, 01:40 
Отлично, можно ему задрнатить за бэкпорт фичей в ветку 2.4 если так надо что-то из 2.5, а дописывать ".default" чота лень.
Ответить | Правка | Наверх | Cообщить модератору

78. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от kai3341 (ok), 17-Янв-22, 02:11 
Issue открыто: https://github.com/webpack-contrib/mini-css-extract-plugin/i...
Называют они это временным workaround
Открытых PR я не вижу
Недоумеваю, как умудрился не сломаться билд нашего проекта
Ответить | Правка | Наверх | Cообщить модератору

100. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Онаним (?), 17-Янв-22, 21:12 
И?
Это не проблемы разработчика, он этот код предоставляет без каких-либо гарантий.
Ответить | Правка | К родителю #68 | Наверх | Cообщить модератору

84. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от псевдонимус (?), 17-Янв-22, 09:54 
>следовало заморочаться обратной совместимостью, сохранив совместимость и с require, и с import

Не, не стОит. Это для лохов.

Ответить | Правка | К родителю #63 | Наверх | Cообщить модератору

86. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (86), 17-Янв-22, 11:00 
> совместимость и с require, и с import

В целях саморазвития: не подскажете, как это реализовать, учитывая, что импорт может содержать и определения типов, тогда как реквайр - только экспортируемый код?

Ответить | Правка | К родителю #63 | Наверх | Cообщить модератору

83. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от псевдонимус (?), 17-Янв-22, 09:53 
Ну вот и шел он нахер, очередной "никамунедолжный" п-ас вместе со своими мозговыми испражнениями.
Ответить | Правка | К родителю #28 | Наверх | Cообщить модератору

33. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от BrainFucker (ok), 16-Янв-22, 13:09 
> Проблема проявилась в проектах, не применяющих явную привязку к номеру версии при подключении зависимостей.

Ну пофиксят эти проекты свои package.json, нашли проблему. Офигеть повод для новости.

Ответить | Правка | Наверх | Cообщить модератору

35. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Аноним (35), 16-Янв-22, 13:56 
Эффект домино? Как этого избежать?
Ответить | Правка | Наверх | Cообщить модератору

43. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +3 +/
Сообщение от martyr.js (?), 16-Янв-22, 16:19 
Дбавлять package-lock.json в систему контроля версий (напр. git).
Тогда при установке зависимотей у пользовалетей (т.е. при выполнении `npm install`) будет устанавливаться зафиксированная версия.
В противном случае может устанавливаться совместимая по semver (в зависимости от того, как зависимости указаны в других пакетах)

https://docs.npmjs.com/cli/v8/configuring-npm/package-json#d...
https://github.com/npm/node-semver#versions
https://semver.org/lang/ru/

Ответить | Правка | Наверх | Cообщить модератору

44. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Аноним (44), 16-Янв-22, 16:20 
Как избежать чего? Того что при обновлении библиотеки придётся обновить и использующий её код? Никак Это нормально. Не нормально это каждый раз выкачивать последнюю версию зависимостей и надеяться, что они не изменятся.
Ответить | Правка | К родителю #35 | Наверх | Cообщить модератору

57. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (58), 16-Янв-22, 20:38 
>  Не нормально это каждый раз выкачивать последнюю версию зависимостей и надеяться, что они не изменятся.

По умолчанию выкачивается последняя совместимая по семверу. Другое дело, что авторы пакетов этот принцип нарушают.

Ответить | Правка | Наверх | Cообщить модератору

101. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Онаним (?), 17-Янв-22, 21:13 
А обещали где-то не нарушать? Покажите договор.
Ответить | Правка | Наверх | Cообщить модератору

45. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (45), 16-Янв-22, 16:25 
пинить точные версии зависимостей, прогонять тесты в ci при их изменении, узнать что такое культура разработки и повысить ее
Ответить | Правка | К родителю #35 | Наверх | Cообщить модератору

66. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Онаним (?), 16-Янв-22, 22:46 
Не тянуть в рот свеженькое прямо из-под выхлопа.
Ответить | Правка | К родителю #35 | Наверх | Cообщить модератору

38. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от JL2001 (ok), 16-Янв-22, 14:36 
какие системы зависимостей имеют поле версии зависимости "проверенно рабочая версия зависимости"?
чтоб можно было в случае проблем откатываться на эти версии автоматом
Ответить | Правка | Наверх | Cообщить модератору

46. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (46), 16-Янв-22, 17:00 
Потому что нужно использовать git submodule вместо всего этого мусора npm, pip, compose, git go
Ответить | Правка | Наверх | Cообщить модератору

47. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (46), 16-Янв-22, 17:01 
вместо git go имел ввиду go get конечно же
Ответить | Правка | Наверх | Cообщить модератору

48. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +2 +/
Сообщение от Kuromi (ok), 16-Янв-22, 17:51 
И что, сейчас опять забанят автора, потом откатят и конфискуют его пакет на соображениям "не допустим вандализма и разрушительных изменений"? Схема-то уже отработана.
Ответить | Правка | Наверх | Cообщить модератору

62. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (58), 16-Янв-22, 20:45 
Конечно забанят. Его бы еще прилюдно унизить нужно за незнание семвера.
Ответить | Правка | Наверх | Cообщить модератору

72. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Урри (ok), 17-Янв-22, 00:52 
Семвер уже несколько лет как не моден ибо не позволяет переставляя кровати делать вид, что ты что-то действительно меняешь.
Ответить | Правка | Наверх | Cообщить модератору

77. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от x3who (?), 17-Янв-22, 01:49 
Ну новость тому иллюстрация - изменение не тянет на мажорную версию, хотя формально да - вон АПИ афигеть как драматически поменялось.
Ответить | Правка | Наверх | Cообщить модератору

67. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Аноним (67), 16-Янв-22, 23:40 
В качестве обходного пути решения проблемы рекомендовано сменить язык программирования
Ответить | Правка | Наверх | Cообщить модератору

79. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Ананоним (?), 17-Янв-22, 06:32 
Попробовал я этот ваш NPM. Две программы пытался поставить, каждую раз 10, и так и сяк, не вышло. Как вы там вообще с этим живёте? Это ж сломано по проекту.
Ответить | Правка | Наверх | Cообщить модератору

90. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от ЖСразработчикemail (?), 17-Янв-22, 12:07 
Так и живём. Кактус хоть и колючий, но жрать его приходится!
Ответить | Правка | Наверх | Cообщить модератору

85. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (85), 17-Янв-22, 10:50 
Чей это такое ваш "npm репозиторий". Ни разу не пользовался.
Ответить | Правка | Наверх | Cообщить модератору

87. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (85), 17-Янв-22, 11:10 
Так, а куда смотрит команда гитхаба, срочно заблокировать учетку автора, и вернуть старую версию!
Ответить | Правка | Наверх | Cообщить модератору

88. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +1 +/
Сообщение от Аноним12345 (?), 17-Янв-22, 11:16 
нпм - зло
Ответить | Правка | Наверх | Cообщить модератору

89. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (89), 17-Янв-22, 11:29 
Поменял версию - положил интернет. Как удобно!
Ответить | Правка | Наверх | Cообщить модератору

103. "Нарушение обратной совместимости в популярном NPM-пакете при..."  +/
Сообщение от Аноним (103), 20-Янв-22, 18:40 
Использование NPM привело к сбоям в различных проекта.

Для решения подобных проблем в будущем создана инициативная группа по геноциду NPM

Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру