The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранени..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранени..."  +/
Сообщение от opennews (ok) on 05-Фев-16, 13:19 
Доступны (http://php.net/index.php#id2016-02-04-1) корректирующие выпуски языка программирования PHP 7.0.3, 5.6.18 и 5.5.32, в которых внесено около 40 изменений (http://www.php.net/ChangeLog-7.php#7.0.3), в том числе устранено несколько уязвимостей: несколько проблем, связанных с разыменованием указателя NULL, возможность фальсификации (https://bugs.php.net/bug.php?id=71323) вывода функции stream_get_meta_data, целочисленное переполнение (https://bugs.php.net/bug.php?id=71459) в  iptcembed(), обращение (http://bugs.php.net/71475) к неинициализированной области памяти в openssl_seal(), повреждение памяти (http://bugs.php.net/71354) при разборе некорректных файлов tar/zip/phar, переполнение (http://bugs.php.net/71488) стека при распаковке файлов tar, обращение (http://bugs.php.net/71311) к уже освобождённым областям памяти в SPL, переполнение буфера (https://bugs.php.net/bug.php?id=71039) в вызове exec() и т.п.

В версиях PHP 5.6.18 и 7.0.3 также добавлена поддержка нового кода ответа HTTP 451 (https://www.opennet.ru/opennews/art.shtml?num=43564) (Unavailable For Legal Reasons), предназначенного для обозначения факта блокировки доступа на основании решения властей.  Библиотека pcrelib обновлена до версии 8.38.

URL: http://php.net/index.php#id2016-02-04-1
Новость: https://www.opennet.ru/opennews/art.shtml?num=43823

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  –2 +/
Сообщение от РОСА (ok) on 05-Фев-16, 13:19 
> В версиях PHP 5.6.18 и 7.0.3 также добавлена поддержка нового кода ответа HTTP 451 (Unavailable For Legal Reasons), предназначенного для обозначения факта блокировки доступа на основании решения властей.

Интересно, а как сервер сможет определить, что его заблокировали извне и именно цензура…

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  +/
Сообщение от тоже Аноним email(ok) on 05-Фев-16, 13:23 
Определить - сможет, распарсив списки.
А вот сообщить об этом пользователю - нет, его же заблокировали.

Я так понимаю, это для двух случаев:
1. Отвечать таким заголовком на определенных страницах для определенных стран во избежание блокировки.
2. Передавать такой заголовок, если скрипт выполняет запрос к третьей стороне и выясняет, что она заблокирована для этого сервера или должна быть заблокирована для этого пользователя.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  +/
Сообщение от m_messiah (ok) on 05-Фев-16, 13:26 
все видимо успешно забыли про блокировку отдельных страниц, с указанием, направляемым сначала администратору ресурса, а не провайдеру.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  +/
Сообщение от тоже Аноним email(ok) on 05-Фев-16, 13:28 
Я дополнил ответ как раз по этому поводу.
Однако вопрос был про "сервер определит, что его УЖЕ заблокировали".
В этом случае Боржоми запаздывает.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  +2 +/
Сообщение от Какаянахренразница (ok) on 05-Фев-16, 13:29 
Не заблокировали, а зацензурили. Например, власти Гондураса сказали: "эту страницу нашим гондурасам не показывать, а то заблочим сайт полностью".
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  +1 +/
Сообщение от xl32 (ok) on 05-Фев-16, 13:31 
Сервер также может являться HTTP-клиентом, которому дали такой ответ.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

10. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  +2 +/
Сообщение от A.Stahl (ok) on 05-Фев-16, 15:27 
Зачем что-то хитро определять? IPшник российский (обычно сопутствующие таблицы довольно точные) -- отдавать 451. Зачем лишнюю логику городить?
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

11. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  –1 +/
Сообщение от myhand (ok) on 05-Фев-16, 16:16 
> IPшник российский (обычно сопутствующие таблицы довольно точные) -- отдавать 451.

Затем, что самые любимые народом фюреры и прочие
демократизаторы - есть и в других странах.  Со всеми втекающими
и вытекающими в виде цензуры.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  +2 +/
Сообщение от A.Stahl (ok) on 05-Фев-16, 16:21 
Китай да Северная Корея? Франция, вроде, что-то очень хотела цензурить... Ну вот эти IPшники вместе с российскими пусть получают 451. Все довольны, всем хорошо.
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  –1 +/
Сообщение от cmp (ok) on 05-Фев-16, 17:00 
То есть факт цензуры как таковой не интересен?
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  +2 +/
Сообщение от myhand (ok) on 05-Фев-16, 17:01 
> Китай да Северная Корея? Франция, вроде, что-то очень хотела цензурить...

Страну 404 не забываем...  Иран, Индия, ... - я наверно даже близко не
начал список.

Все ведь хотят цензурить, дай самой последней вошке банхаммер - ой-ой
чо будет...  Вон, даже в open source (tm) проектах во всю голову уже цветут разные
политкорректности, "Code of Conduct" и проч. по***нь, а вы хотите чтобы
простой демократичный депутоид не голосовал за запрет всего плохого
ради всего хорошего.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

15. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  –1 +/
Сообщение от OramahMaalhur (ok) on 06-Фев-16, 16:26 
>Страну 404 не забываем

А можно по-подробнее, уже начали что-то блокировать? Вроде же только собирались в далёких планах и только внутри уркнета.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

16. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  –1 +/
Сообщение от myhand (ok) on 06-Фев-16, 16:48 
>>Страну 404 не забываем
> А можно по-подробнее, уже начали что-то блокировать?

А что, еще осталось что-то?

> только внутри уркнета.

Дак и роскомпозор - тоже унутре.

PS: За уркнет - отдельный зачот.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

17. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  +/
Сообщение от commiethebeastie (ok) on 07-Фев-16, 15:26 
>Индия

А они что блокируют? Страничку с плеером deadbeef?

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

18. "Обновление PHP  5.5.32, 5.6.18 и 7.0.3 с устранением уязвимо..."  +/
Сообщение от myhand (ok) on 07-Фев-16, 16:35 
Дак даже тут новости набрасывали.  Поискайте.
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру