The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"В ядре Linux выявлена уязвимость, которая может привести к л..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от opennews (ok) on 16-Дек-14, 10:31 
Во всех актуальных версиях ядра Linux найдена (http://seclists.org/oss-sec/2014/q4/1052) уязвимость (CVE-2014-9322), которая позволяет локальному злоумышленнику повысить свои привилегии в системе. Проблема проявляется только на архитектуре x86_64. Уязвимость выявлена в результате анализа найденной в конце ноября проблемы CVE-2014-9090 (http://www.openwall.com/lists/oss-security/2014/11/26/5) и решается ранее представленным  для CVE-2014-9090 патчем (https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux....).


Таким образом, выпущенные (http://www.ubuntu.com/usn/usn-2447-1/) на прошлой неделе обновления пакетов с ядром для Ubuntu (http://www.ubuntu.com/usn/usn-2447-1/) и Fedora (https://admin.fedoraproject.org/updates/FEDORA-2014-16448/ke...)  закрывают и новую уязвимость (для RHEL/CentOS обновление (https://rhn.redhat.com/errata/RHSA-2014-1971.html) от 9 декабря не содержит исправления проблемы). Если проблема CVE-2014-9090  не закрыта, появляется новый вектор атаки, который может привести не только к краху ядра (CVE-2014-9090 имеет статус DoS-уязвимости), но и выполнению кода с повышенными привилегиями. Для систем в которых не включены механизмы защиты SMAP (https://www.opennet.ru/opennews/art.shtml?num=35554#smap)  (Supervisor Mode Access Prevention) и UDEREF (https://grsecurity.net/~spender/uderef.txt) отмечается высокая вероятность лёгкой эсплуатации уязвимости.

В настоящее время уже подготовлен тестовый эксплоит (https://gitorious.org/linux-test-utils/linux-clock-tests/sou...) (sigreturn), который можно использовать для проверки своих систем на наличие уязвимости. Одновременно сообщается о наличии ещё двух менее опасных уязвимостях в ядре Linux -  CVE-2014-8133 и CVE-2014-8134, которые могут привести к утечке 2-4 байт  из стека ядра.  Оценить появление обновлений  можно на следующих страницах: openSUSE (http://lists.opensuse.org/opensuse-security-announce/), SLES (https://www.suse.com/support/update/),  Slackware (http://www.slackware.com/security/list.php?l=slackware-secur...), Gentoo (http://www.gentoo.org/security/en/index.xml), CentOS (http://lists.centos.org/pipermail/centos-announce/2014-Decem...), Debian (https://lists.debian.org/debian-security-announce/2014/threa...), RHEL 6 (https://rhn.redhat.com/errata/rhel-server-6-errata.html), RHEL 7 (https://rhn.redhat.com/errata/rhel-server-7-errata.html) (в Ubuntu (http://www.ubuntu.com/usn/usn-2447-1/) и Fedora (https://admin.fedoraproject.org/updates/FEDORA-2014-16448/ke...) уязвимость CVE-2014-9090 устранена).

URL: http://seclists.org/oss-sec/2014/q4/1052
Новость: https://www.opennet.ru/opennews/art.shtml?num=41276

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "В ядре Linux выявлена уязвимость, которая может привести к л..."  –4 +/
Сообщение от res2500 (ok) on 16-Дек-14, 10:31 
> Во всех актуальных версиях ядра Linux найдена уязвимость

да ну, а где коменты "не работает"

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +12 +/
Сообщение от Аноним (??) on 16-Дек-14, 10:52 
Не работает
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

9. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Аноним (??) on 16-Дек-14, 12:36 
>Не работает

Похоже не работает. Тестировал на 2х (разные версии ядер) системах. Запустил, показало кучу FAIL - строк и вывалилось с SIGTRAP.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

3. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от S (??) on 16-Дек-14, 10:53 
[WARN]    ***** The 64-bit version requires a special kernel. *****
[WARN]    ***** Build with -m32. *****
a.out: stack16 is too high

Это работает или нет? gentoo :3

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

35. "В ядре Linux выявлена уязвимость, которая может привести к л..."  –1 +/
Сообщение от Ordu email(ok) on 17-Дек-14, 07:16 
> [WARN] ***** The 64-bit version requires a special kernel. *****
> [WARN] ***** Build with -m32. *****
> a.out: stack16 is too high
> Это работает или нет? gentoo :3

Я тебе дам совет: никогда, слышишь, никогда не собирай софт вручную, мимо ebuild'ов. Если когда тебя в лоб говорят "Build with -m32", ты этого не понимаешь, то продолжай дальше ждать ебилдов.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

39. "В ядре Linux выявлена уязвимость, которая может привести к л..."  –3 +/
Сообщение от А тебе скажу email on 18-Дек-14, 17:28 
Никогда не собирай софт из ебилдов и вообще забудь это слово, работать надо, а не компилировать.
Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

43. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +2 +/
Сообщение от Ordu email(ok) on 19-Дек-14, 00:20 
> Никогда не собирай софт из ебилдов и вообще забудь это слово, работать
> надо, а не компилировать.

Глупышка, пойми, что сегодня никто вручную не компилирует. Этап развития вычислительной техники, когда перевод в машинный код проводился специально нанятыми девушками давным-давно в прошлом. Открой для себя компиляторы, системы автоматизации сборки, системы автоматизации отслеживания зависимостей. И не трать больше время на компиляцию.

Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

6. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +3 +/
Сообщение от Неуловимый Д. on 16-Дек-14, 11:16 
>> Во всех актуальных версиях ядра Linux найдена уязвимость
> да ну, а где коменты "не работает"

Вспоминается демонстрационный эксплоит от "кислотных сук"   который  работал  на повышение привилегий, но при этом еще и скрытый бэкдор оставлял как выяснилось потом.  

И ведь там баг был  тоже для х64.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

7. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Неуловимый Д. on 16-Дек-14, 11:24 
https://www.opennet.ru/opennews/art.shtml?num=27979
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

28. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +1 +/
Сообщение от Led (ok) on 16-Дек-14, 23:02 
> И ведь там баг был  тоже для х64.

И при чём тут твоя венда?

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

40. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Аноним (??) on 18-Дек-14, 20:17 
> но при этом еще и скрытый бэкдор

...который было несложно заметить как нечто подозрительное - по солидному блобу шеллкода.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Нанобот (ok) on 16-Дек-14, 12:23 
>проявляется только на архитектуре x86_64

рано ещё продакшн на x86_64 переводить, сыровато ядро :)

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

12. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +1 +/
Сообщение от Аноним (??) on 16-Дек-14, 13:47 
Вы не в маилру, случаем, работаете?
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

13. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +9 +/
Сообщение от Аноним (??) on 16-Дек-14, 14:19 
Судя по никнейму – в Сколково.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

47. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Куяврег on 21-Дек-14, 17:20 
Кто ж такого в сколково возьмёт? Это микрософтобот, просто для удобства сократили.
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

33. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Прохожий (??) on 17-Дек-14, 07:07 
Улыбнуло. Наверно, сегодня день "хорошего настроения"!
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

38. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Typhoon (ok) on 18-Дек-14, 15:03 
вот и я о том-же, FreeBSD i386 на zfs, вот то, что нужно ставить, а то все заладили 64, 64...
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

41. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Аноним (??) on 18-Дек-14, 20:18 
> FreeBSD i386 на zfs

Так вот как выглядит удаление гланд через задний проход автогеном в исполнении айтишников...

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

42. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Typhoon (ok) on 18-Дек-14, 20:36 
к чему сарказм, что еще ставить если сервера на нетбуках?
Ответить | Правка | ^ к родителю #41 | Наверх | Cообщить модератору

14. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +3 +/
Сообщение от Zenitarka on 16-Дек-14, 15:45 
Вот бы мне на работе локальное повышение!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

24. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +2 +/
Сообщение от Ytch (ok) on 16-Дек-14, 20:05 
найди уязвимость )
Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

25. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Аноним (??) on 16-Дек-14, 20:08 
> найди уязвимость )

Ее еще попробуй найди, без помощи сообщества. Это только на словах всё просто.

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

31. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Аноним (??) on 17-Дек-14, 01:06 
Так не надо проприетарными системами пользоваться.
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

15. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от eganru on 16-Дек-14, 16:04 
я не смог у себя с помощью эксплойта повысить привелегии.
паста
http://pastebin.com/cZ30eaku
собирал эксплойт
gcc -std=gnu99 sigreturn.c -o sigreturn
ядро 3.14.4-geek
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

16. "В ядре Linux выявлена уязвимость, которая может привести к л..."  –8 +/
Сообщение от pavlinux (ok) on 16-Дек-14, 16:14 
Потому что ты дебил, в новости для таких написали 64 бита только!
Более того, ты дважды дебил, ибо нашёл ссцлку на эксплойт и не мог
не заметить упоминания о 64-битах. Но все ж скомпилил, и сюда скопипастил!
Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

18. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Anonn on 16-Дек-14, 16:20 
У меня система 64 битная, но пишет туже хрень про 32 бита.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

20. "В ядре Linux выявлена уязвимость, которая может привести к л..."  –2 +/
Сообщение от pavlinux (ok) on 16-Дек-14, 17:25 
хрень, хрень,... это експлоет доделывать вааще-то нужно.
Тут лишь показано, что возврат не туда возвращается.  
Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

22. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от BratSinot (ok) on 16-Дек-14, 18:38 
Хрен знает как в этих ваших multilib'ах все работает, но он может по умолчанию собирать -m32, а надо -m64.
Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

19. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +3 +/
Сообщение от Аноним (??) on 16-Дек-14, 16:22 
Кто опять за павлином недоглядел? Что он нажрался? Сестрааа! Несите рубашку.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

29. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +1 +/
Сообщение от Led (ok) on 16-Дек-14, 23:04 
> Что он нажрался?

А что - большой выбор?

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

21. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +3 +/
Сообщение от eganru on 16-Дек-14, 17:38 
В следующий перед тем как будете кукарекать, спросите.
egan@calculate ~/Загрузки/linux-test-utils-linux-clock-tests $ uname -m
x86_64
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

23. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Аноним (??) on 16-Дек-14, 19:56 
А что ты так раскудахтался как курица над яйцом? Ну уязвиомсть, ну бывает, ты же не требуешь от платных форточек безошибочности.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

34. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Ordu email(ok) on 17-Дек-14, 07:11 
Это твоя жизненная позиция такая -- запускать из интернета на своей системе всё говно, которое называют эксплоитом, даже не заглядывая в код? Запусти лучше rm -rf /* и не парься.

1. Там есть Makefile, ты видел его? Ты заглядывал в него? Опция -m32 критична для работы sigreturn.c. Он тебе даже в выводе заботливо написал, что процесс sigreturn должен быть 32-х битным, намекая что стоит всё же заглянуть в Makefile.

2. В новости выше неточность, это НЕ эксплоит, это тестовый код. Чтобы при его помощи поднять привилегии, надо заглянуть в файлик, въехать что он делает, посмотреть что из того, что он делает срабатывает в твоей системе, и вот затем можно на основании полученной информации написать эксплоит. Я бы пояснил подробнее, но мне чесслово лень вникать -- все эти GDT/LDT, дескрипторы сегментной адресации я ещё худо бедно помню, но въезжать в то что именно происходит в коде мне совершенно неинетесно.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

17. "В ядре Linux выявлена уязвимость, которая может привести к л..."  –2 +/
Сообщение от bOOster email(ok) on 16-Дек-14, 16:18 
Ну кто-бы сомневался. Linux стал медленнее на "сотню тактов"
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

30. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Аноним email(??) on 16-Дек-14, 23:32 
kernel panic (3.14.24, x86_64)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

32. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Аноним (??) on 17-Дек-14, 01:08 
> kernel panic (3.14.24, x86_64)

Как вы яхту назовете... в смысле, версия ядра к тому располагает. Только она должна быть 3.14.15 :)

Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

36. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от 3 on 17-Дек-14, 18:19 
вот в чем плюс старого компьютера :) Не перелез и нет уязвимости :)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

37. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от Аноним (??) on 17-Дек-14, 19:56 
ядро валится в панику
Linux laptop 3.14-2-amd64 #1 SMP Debian 3.14.15-2 (2014-08-09) x86_64 GNU/Linux
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

44. "В ядре Linux выявлена уязвимость, которая может привести..."  +/
Сообщение от arisu (ok) on 19-Дек-14, 19:08 
продолжаю смеяться над гордыми 64-битными птицами.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

45. "В ядре Linux выявлена уязвимость, которая может привести..."  +/
Сообщение от Alexxxyyyzzz on 19-Дек-14, 20:42 
Угу. А когда БД большие будете обрабатывать, тогда и поговорим. У нас только после переползание на 64 базы нормально стали крутится.
Когда к базе цепляются одновременно 8 филиалов по 150-200 человек 32 битная давала людям время чаек испить и прочее. На том же железе с 64 битами в разы быстрее поехало.
Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

46. "В ядре Linux выявлена уязвимость, которая может привести..."  +/
Сообщение от arisu (ok) on 19-Дек-14, 20:47 
> Угу. А когда БД большие будете обрабатывать, тогда и поговорим.

у вас что, сервера БД используются ещё и как рабочие станции? или туда принято ставить что ни попадя и обновлять бездумно? ай, малацца!

внимание, вопрос номер два: зачем *всем* идти на 64 бита, если достаточно только серверы перенести? *пользователю* 64 нафиг не нужно.

Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

49. "В ядре Linux выявлена уязвимость, которая может привести к л..."  +/
Сообщение от эцсамое on 22-Дек-14, 20:20 
gentoo 3.15.10-hardened-r1 - из иксов сделал панику.

если запустить со слипом без иксов и уйти в консоль на альт-f12 смотреть dmesg, то тихо валится с сегфолтом.

такое.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру