The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Openconnect Server"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (VPN / Linux)
Изначальное сообщение [ Отслеживать ]

"Openconnect Server"  +/
Сообщение от Андрей (??), 16-Май-22, 13:00 
Доброго времени суток.
Ни как не получается запустить Openconnect Server на Ubuntu 22.04

Стартует без ошибок, но при подключение клиента в логах вот такое:
ocserv-worker[27061] general protection fault ip:7facb9e2266898 sp:7ffe31eааа1c0 error:0 in libc.so.6\

Буду признателен за помощь.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по ответам | RSS]

1. Сообщение от ipmanyak (ok), 16-Май-22, 15:04   +/
> Доброго времени суток.
> Ни как не получается запустить Openconnect Server на Ubuntu 22.04
> Стартует без ошибок, но при подключение клиента в логах вот такое:
> ocserv-worker[27061] general protection fault ip:7facb9e2266898 sp:7ffe31eааа1c0 error:0
> in libc.so.6\
> Буду признателен за помощь.

Возможно память битая,  если сервак физический. Проявляется при повышенной нагрузке и запросах памяти.

Ответить | Правка | Наверх | Cообщить модератору
Ответы: #2

2. Сообщение от Андрей (??), 16-Май-22, 15:24   +/
>> Доброго времени суток.
>> Ни как не получается запустить Openconnect Server на Ubuntu 22.04
>> Стартует без ошибок, но при подключение клиента в логах вот такое:
>> ocserv-worker[27061] general protection fault ip:7facb9e2266898 sp:7ffe31eааа1c0 error:0
>> in libc.so.6\
>> Буду признателен за помощь.
> Возможно память битая,  если сервак физический. Проявляется при повышенной нагрузке и
> запросах памяти.

Точно сервер не при чем т к пробовал "поднять" на виртуалке - результат тот же.
Скорее всего какой то косяк в настройках (хотя все делалось по документации с сайта и кучи мануалов от коллег), шифровании и проч

Ответить | Правка | Наверх | Cообщить модератору
Родитель: #1 Ответы: #3

3. Сообщение от Андрей (??), 20-Май-22, 09:49   +/
>[оверквотинг удален]
>>> Стартует без ошибок, но при подключение клиента в логах вот такое:
>>> ocserv-worker[27061] general protection fault ip:7facb9e2266898 sp:7ffe31eааа1c0 error:0
>>> in libc.so.6\
>>> Буду признателен за помощь.
>> Возможно память битая,  если сервак физический. Проявляется при повышенной нагрузке и
>> запросах памяти.
> Точно сервер не при чем т к пробовал "поднять" на виртуалке -
> результат тот же.
> Скорее всего какой то косяк в настройках (хотя все делалось по документации
> с сайта и кучи мануалов от коллег), шифровании и проч

Может кому пригодится...
Проблема решилась заменой  isolate-workers = true на false
Как написано в конфиге: "..Note however, that process isolation is restricted to the specific libc versions"
Вот отсюда ошибка Все работает теперь как надо

Ответить | Правка | Наверх | Cообщить модератору
Родитель: #2


Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру