The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OSPFD"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"OSPFD"  +/
Сообщение от genyas email(ok) on 25-Ноя-09, 13:16 
привет такая вот засада ,что то не понимаю нчего уже .

есть два разных филиала , работают по тунелю(vtund) создает .
с двух сторон quagga (zebra , ospfd) больше ничего не надо. По зебре все пучком все видицо если маршруты писать статиком , а вот через ospfd что то ничего не ползет , пакеты кидаются а толку ноль . Вот примеры .
Конфиг ospfd

hostname xxxx
password xxxx
enable password xxxxx
log file /var/log/ospfd.log
!
!
!
interface lo0
!
interface pflog0
!
interface pfsync0
!
interface plip0
!
interface re0
!
interface re1
!
interface rl0
!
interface tun1
ip ospf network point-to-point
ip ospf cost 1
!
router ospf
ospf router-id x.x.xx.x
network x.x.x.x/30 area 0.0.0.0
network xx.xx.x.x/24 area 0.0.0.0
!
line vty


Вот что выдает лог от ospf
2009/11/25 12:04:59 OSPF: can't setsockopt IP_ADD_MEMBERSHIP (fd 6, addr 192.xx.xx.1, ifindex 8, AllSPFRouters): Invalid argument; perhaps a kernel limit on # of multicast group memberships has been exceeded?
2009/11/25 12:04:59 OSPF: interface xx.xx.xx.x [8] join AllDRouters Multicast group.

А вот на что ругается если смотреть через telnet подключаясь к самомоу ospfd


tun1 is up
  ifindex 10, MTU 1495 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,MULTICAST>
  Internet Address 10.xxx.xxx.1/30, Peer 10.xxx.xx.2, Area 0.0.0.0
  MTU mismatch detection:enabled
  Router ID 192.xxx.xx.1, Network Type POINTOPOINT, Cost: 1
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 1.351s
  Neighbor Count is 0, Adjacent neighbor count is 0
vlan0 is up
  ifindex 8, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST>
  Internet Address 192.xxx.xxx.1/24, Broadcast 192.xxx.xxx.255, Area 0.0.0.0
  MTU mismatch detection:enabled
  Router ID 192.xxx.xx.1, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 192.xxx.xxx.1, Interface Address 192.xxx.xxx.1
  No backup designated router on this network
  Multicast group memberships: OSPFDesignatedRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 1.352s
  Neighbor Count is 0, Adjacent neighbor count is 0

Это собрал на туннеле что висит между двумя шлюзами .

14:08:20.742435 IP (tos 0xc0, ttl 1, id 9864, offset 0, flags [none], proto OSPF (89), length 64) хх.хх.хх.х > OSPF-ALL.MCAST.NET: OSPFv2, Hello, length: 44
        Router-ID: 192.хх.хх.1, Backbone Area, Authentication Type: none (0)
        Options: [External]
          Hello Timer: 10s, Dead Timer 40s, Mask: 0.0.0.0, Priority: 1
14:08:25.334779 IP (tos 0xc0, ttl 1, id 49131, offset 0, flags [none], proto OSPF (89), length 68) хх.хх.хх.хх > OSPF-ALL.MCAST.NET: OSPFv2, Hello, length: 48
        Router-ID: 192.ххх.хх.4, Backbone Area, Authentication Type: none (0)
        Options: [External]
          Hello Timer: 10s, Dead Timer 40s, Mask: 0.0.0.0, Priority: 1
          Neighbor List:
            192.ххх.хх.1

Куда копать , на других железкав все пашет , на этой нет . что за бред ??
Спасибо.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

  • OSPFD, ALex_hha, 14:14 , 25-Ноя-09, (1)  
    • OSPFD, genyas, 14:34 , 25-Ноя-09, (2)  
      • OSPFD, ALex_hha, 14:37 , 25-Ноя-09, (3)  
        • OSPFD, genyas, 14:41 , 25-Ноя-09, (4)  
          • OSPFD, genyas, 15:17 , 25-Ноя-09, (5)  
            • OSPFD, ALex_hha, 15:25 , 25-Ноя-09, (6)  
              • OSPFD, genyas, 15:40 , 25-Ноя-09, (7)  
                • OSPFD, ALex_hha, 18:24 , 25-Ноя-09, (8)  
                  • OSPFD, genyas, 09:16 , 26-Ноя-09, (9)  
                    • OSPFD, genyas, 10:38 , 27-Ноя-09, (10)  

Сообщения по теме [Сортировка по времени | RSS]


1. "OSPFD"  +/
Сообщение от ALex_hha (ok) on 25-Ноя-09, 14:14 
Я бы не указывал ip ospf network point-to-point.

router id у них разный? Увеличь дебаг для ospf

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "OSPFD"  +/
Сообщение от genyas email(ok) on 25-Ноя-09, 14:34 
>Я бы не указывал ip ospf network point-to-point.
>
>router id у них разный? Увеличь дебаг для ospf

router-id разный . Как мы можем видеть по один то второге как соседа видит , а вот первый то не але , тобишь тот что с 4 он видет того что с 1 а вот 1 не видет соседа 4 .

Если не указывать ip ospf network то получается что идет разная маска , или ты имеешь ввиду вообще не указывать ни там ни там ?  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "OSPFD"  +/
Сообщение от ALex_hha (ok) on 25-Ноя-09, 14:37 
>[оверквотинг удален]
>router-id разный . Как мы можем видеть по один то второге как
>соседа видит , а вот первый то не але , тобишь
>тот что с 4 он видет того что с 1 а
>вот 1 не видет соседа 4 .
>
>
>
>Если не указывать ip ospf network то получается что идет разная маска
>, или ты имеешь ввиду вообще не указывать ни там ни
>там ?

да, на обоих концах не указывать


У меня так

interface tun0
description OSPF primary chanel
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 1234567
ip ospf cost 10
!
interface tun1
description OSPF backup chanel
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 1234567
ip ospf cost 100
!
router ospf
ospf router-id 10.3.0.1
redistribute connected route-map Local_Network
network 10.3.0.1/30 area 0.0.0.0
network 192.168.21.1/30 area 0.0.0.0
area 0.0.0.0 authentication message-digest

tun интерфейсы подняты на openvpn

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "OSPFD"  +/
Сообщение от genyas email(ok) on 25-Ноя-09, 14:41 
>[оверквотинг удален]
> ip ospf cost 100
>!
>router ospf
> ospf router-id 10.3.0.1
> redistribute connected route-map Local_Network
> network 10.3.0.1/30 area 0.0.0.0
> network 192.168.21.1/30 area 0.0.0.0
> area 0.0.0.0 authentication message-digest
>
>tun интерфейсы подняты на openvpn

Угу , понял , попробую . напишу как чего .

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "OSPFD"  +/
Сообщение от genyas email(ok) on 25-Ноя-09, 15:17 
>[оверквотинг удален]
>>router ospf
>> ospf router-id 10.3.0.1
>> redistribute connected route-map Local_Network
>> network 10.3.0.1/30 area 0.0.0.0
>> network 192.168.21.1/30 area 0.0.0.0
>> area 0.0.0.0 authentication message-digest
>>
>>tun интерфейсы подняты на openvpn
>
>Угу , понял , попробую . напишу как чего .

поуберал .
тот что 4 как не видел первого (1) так и не видет , но теперь 1 выдает в логах
OSPF: Packet 192.xxx.xx.1 [Hello:RECV]: NetworkMask mismatch on tun19:10.100.43.2 (configured prefix length is 30, but hello packet indicates 0).

tun19 это тот самый туннель что объединаяет эти два шлюза . Маски и IP для тунельного интерфэйса указаны верно , сам туннель рабочий . маска там /30  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "OSPFD"  +/
Сообщение от ALex_hha (ok) on 25-Ноя-09, 15:25 
> network x.x.x.x/30

показывай реальные данные, а не xxx :)

# ifconfig tun19

?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "OSPFD"  +/
Сообщение от genyas email(ok) on 25-Ноя-09, 15:40 
>> network x.x.x.x/30
>
>показывай реальные данные, а не xxx :)
>
># ifconfig tun19
>
>?

хорошо .
Это туннель со одной стороны
tun1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1495
        inet 10.100.43.1 --> 10.100.43.2 netmask 0xfffffffc
        Opened by PID 2224

Это туннель с другой .

tun19: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1495
        inet 10.100.43.2 --> 10.100.43.1 netmask 0xfffffffc
        Opened by PID 797


Вот все тоже самое тока без хххх


hostname xxxx
password xxxx
enable password xxxxx
log file /var/log/ospfd.log
!
!
!
interface lo0
!
interface pflog0
!
interface pfsync0
!
interface plip0
!
interface re0
!
interface re1
!
interface rl0
!
interface tun1
ip ospf network point-to-point
ip ospf cost 1
!
router ospf
ospf router-id 192.127.43.1
network 10.100.43.0/30 area 0.0.0.0
network 192.127.43.0/24 area 0.0.0.0
!
line vty


Вот что выдает лог от ospf
2009/11/25 12:04:59 OSPF: can't setsockopt IP_ADD_MEMBERSHIP (fd 6, addr 192.127.43.1, ifindex 8, AllSPFRouters): Invalid argument; perhaps a kernel limit on # of multicast group memberships has been exceeded?
2009/11/25 12:04:59 OSPF: interface 10.100.43.1 [8] join AllDRouters Multicast group.

А вот на что ругается если смотреть через telnet подключаясь к самомоу ospfd


tun1 is up
  ifindex 10, MTU 1495 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,MULTICAST>
  Internet Address 10.100.43.1/30, Peer 10.100.43.2, Area 0.0.0.0
  MTU mismatch detection:enabled
  Router ID 192.127.43.1, Network Type POINTOPOINT, Cost: 1
  Transmit Delay is 1 sec, State Point-To-Point, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 1.351s
  Neighbor Count is 0, Adjacent neighbor count is 0
vlan0 is up
  ifindex 8, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST>
  Internet Address 192.127.43.1/24, Broadcast 192.127.43.255, Area 0.0.0.0
  MTU mismatch detection:enabled
  Router ID 192.127.43.1, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 192.127.43.1, Interface Address 192.127.43.1
  No backup designated router on this network
  Multicast group memberships: OSPFDesignatedRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 1.352s
  Neighbor Count is 0, Adjacent neighbor count is 0

14:08:20.742435 IP (tos 0xc0, ttl 1, id 9864, offset 0, flags [none], proto OSPF (89), length 64) 10.100.43.1 > OSPF-ALL.MCAST.NET: OSPFv2, Hello, length: 44
        Router-ID: 192.127.43.1, Backbone Area, Authentication Type: none (0)
        Options: [External]
          Hello Timer: 10s, Dead Timer 40s, Mask: 0.0.0.0, Priority: 1
14:08:25.334779 IP (tos 0xc0, ttl 1, id 49131, offset 0, flags [none], proto OSPF (89), length 68) 10.100.43.2 > OSPF-ALL.MCAST.NET: OSPFv2, Hello, length: 48
        Router-ID: 192.127.89.4, Backbone Area, Authentication Type: none (0)
        Options: [External]
          Hello Timer: 10s, Dead Timer 40s, Mask: 0.0.0.0, Priority: 1
          Neighbor List:
            192.127.43.1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "OSPFD"  +/
Сообщение от ALex_hha (ok) on 25-Ноя-09, 18:24 
Какая версия кваги?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "OSPFD"  +/
Сообщение от genyas email(ok) on 26-Ноя-09, 09:16 
>Какая версия кваги?

quagga-0.99.9_5

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "OSPFD"  +/
Сообщение от genyas email(??) on 27-Ноя-09, 10:38 
>>Какая версия кваги?
>
>quagga-0.99.9_5

Усе тема закрыта , проблема была с версией quagg-и поставил 0.99.15 и все сразу увиделось .

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру