The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"ospf поверх pptp на quagga, FreeBSD"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"ospf поверх pptp на quagga, FreeBSD"  
Сообщение от HackerCB email(ok) on 27-Ноя-08, 23:30 
Есть два роутера на FreeBSD 7.0R + quagga 0.99.10

подняты тунели через mpd(клиент и сервер), все пингуется без проблем.

пытаюсь поднять ospf, и при этом второй маршрутик в упор не видит hello пакеты от первого (по tcpdump-у они есть)
подскажите, в чем могут быть грабли

==========================================================================
=== ПЕРВЫЙ МАРШРУТИК ===
==========================================================================
ng0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> metric 0 mtu 1492
        inet AAA.BBB.76.128 --> AAA.BBB.76.129 netmask 0xffffffff
==========================================================================
interface ng0
ipv6 nd suppress-ra
!
router ospf
redistribute connected
redistribute static
network AAA.BBB.64.92/30 area 0.0.0.0
network AAA.BBB.64.96/30 area 0.0.0.0
network AAA.BBB.76.0/24 area 0.0.0.5
network AAA.BBB.76.129/32 area 0.0.0.5
neighbor AAA.BBB.76.129
!
==========================================================================
mpd.conf:
   set iface disable on-demand
   set iface enable tcpmssfix
   set bundle enable multilink
   set link yes acfcomp protocomp
   set link no pap chap
   set link enable chap
   set link keep-alive 60 180
   set ipcp yes vjcomp
   set ipcp dns AAA.BBB.72.158 AAA.BBB.73.3
   set pptp enable incoming
   set pptp disable originate
   set iface mtu 1492
   set link mtu 1492


==========================================================================
=== ВТОРОЙ МАРШРУТИК ===
==========================================================================
ng0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> metric 0 mtu 1492
        inet AAA.BBB.76.129 --> AAA.BBB.76.128 netmask 0xffffffff
==========================================================================
interface ng0
ipv6 nd suppress-ra
!
router ospf
ospf router-id AAA.BBB.74.74
redistribute connected
redistribute static
network AAA.BBB.76.0/24 area 0.0.0.5
network AAA.BBB.76.128/32 area 0.0.0.5
neighbor AAA.BBB.76.128
!
==========================================================================
mpd.conf:
new -i ng0 vpn vpn
set iface disable on-demand
set iface idle 0
set bundle disable multilink
set bundle authname "XXXXXXXXXXXXX"
set bundle password "XXXXXXXXXXXXX"
set link keep-alive 10 75
set link disable chap pap
set link accept chap pap
set bundle disable compression
set ccp yes mpp-e40
set ccp no mpp-e128
set bundle disable crypt-reqd
set ccp no mpp-stateless
set ipcp no vjcomp
set iface mtu 1492
set link mtu 1492


==========================================================================
tcpdump:  
listening on ng0, link-type NULL (BSD loopback), capture size 96 bytes
23:26:20.405034 IP AAA.BBB.76.128 > 224.0.0.5: OSPFv2, Hello, length: 48
23:26:20.992866 IP AAA.BBB.76.129 > 224.0.0.5: OSPFv2, Hello, length: 44

==========================================================================
кусок лога:
2008/11/27 23:21:56 OSPF: ospf_flood_through_interface(): considering nbr AAA.BBB.74.74 (2-Way)
2008/11/27 23:21:56 OSPF: ospf_flood_through_interface(): considering int ng0:AAA.BBB.76.129, INBR(NULL), LSA[Type5,id(10.70.2.0),ar(AAA.BBB.74.74)]
2008/11/27 23:21:56 OSPF: ospf_flood_through_interface(): considering nbr AAA.BBB.74.74 (2-Way)
2008/11/27 23:21:56 OSPF: ospf_flood_through_interface(): considering int ng0:AAA.BBB.76.129, INBR(NULL), LSA[Type5,id(10.70.2.0),ar(AAA.BBB.74.74)]
2008/11/27 23:21:56 OSPF: ospf_flood_through_interface(): considering nbr AAA.BBB.74.74 (2-Way)
2008/11/27 23:22:00 OSPF: make_hello: options: 2, int: ng0:AAA.BBB.76.129
2008/11/27 23:22:00 OSPF: Hello sent to [224.0.0.5] via [ng0:AAA.BBB.76.129].
2008/11/27 23:22:10 OSPF: make_hello: options: 2, int: ng0:AAA.BBB.76.129
2008/11/27 23:22:10 OSPF: Hello sent to [224.0.0.5] via [ng0:AAA.BBB.76.129].

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "ospf поверх pptp на quagga, FreeBSD"  
Сообщение от Vaso Petrovich on 27-Ноя-08, 23:55 
а что то типа
ip ospf network point-to-point
поШему нету?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "ospf поверх pptp на quagga, FreeBSD"  
Сообщение от HackerCB (ok) on 28-Ноя-08, 10:45 
>а что то типа
>ip ospf network point-to-point
>поШему нету?

Оно есть по дефолту для p2p интерфейсов.
Я пробовал все варианты, в т.ч. non-broadcast


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "ospf поверх pptp на quagga, FreeBSD"  
Сообщение от HackerCB email(ok) on 28-Ноя-08, 20:26 
Решил проблему путем поднятия GRE поверх PPTP.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "ospf поверх pptp на quagga, FreeBSD"  
Сообщение от sudosu (??) on 13-Янв-09, 12:55 
>Решил проблему путем поднятия GRE поверх PPTP.

А покажи конфиги плз

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру