The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Проблема с зависанием..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Проблема с зависанием..."  
Сообщение от Евгений email(??) on 10-Янв-06, 23:15 
Посдскажите пожалуйста решение следующей проблемы:

стоит FreeBSD 6.0
все работает корректно, но... стабильно зависает
причем зависает независимо от того: в консоле я, в Х-ах, работаю или проставивает машина... может зависнуть через 5 минут после загрузки системы, может через 3 часа работы после загрузки.

проблема не исчезла и при пересборке ядра.
в принципе никаких серьезных настроек не делал. только установил родной дистриб, а так же поставил родные драйвера от нВидии.

сетевые сервисы (httpd,ftpd и прочие) не включал - лишь настроен доступ в сеть (IPv6 отключен)

тот же дистриб на другой машине - работает стабильно (правда машина поновее)

Комп работает с Виндами уже 5 лет, работает стабильно... всякие стресс-тесты ничего не выявляют.

ВОПРОС: в чем может быть причина??? излазил в /var/log ничего подозрительного не обнаружил... во всех логах сеанс кончается последней удачной командой, а потом идет уже лог загрузки ядра заново...
где мне посмотреть какие могут быть ошибки? как мне разобраться, что может вызывать зависание? посмотрел банальные весчи - место на разделах есть... все устройства работают...

но все равно виснет даже в консольной строке... ((

система замкнута - нет никаких влияний извне за исключением смонтированнного PRIMARI DOS раздела на rw... но я не думаю, что изза него могут быть сбои...

ПАМАГИТЕ!!!!! ПЛИИИИИИЗ!!!!!

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Проблема с зависанием..."  
Сообщение от co6aka (ok) on 11-Янв-06, 02:24 
Подробное описание железа в студию! Извините, но если мне не изменяет память, меалофон у Алисы.
Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 11-Янв-06, 02:52 
>Подробное описание железа в студию! Извините, но если мне не изменяет память,
>меалофон у Алисы.

содержание dmesg.boot :

FreeBSD 6.0-RELEASE #0: Thu Nov  3 09:36:13 UTC 2005
...
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) Processor (847.14-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x642  Stepping = 2
  Features=0x183f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR>
  AMD Features=0xc0440800<SYSCALL,<b18>,MMX+,3DNow+,3DNow>
real memory  = 268369920 (255 MB)
avail memory = 248950784 (237 MB)
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
cpu0 on motherboard
pcib0: <Host to PCI bridge> pcibus 0 on motherboard
pir0: <PCI Interrupt Routing Table: 8 Entries> on motherboard
pci0: <PCI bus> on pcib0
agp0: <VIA 82C8363 (Apollo KT133x/KM133) host to PCI bridge> mem 0xd8000000-0xdbffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
nvidia0: <GeForce2 MX/MX 400> mem 0xdc000000-0xdcffffff,0xd0000000-0xd7ffffff irq 10 at device 0.0 on pci1
nvidia0: [GIANT-LOCKED]
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 82C686A UDMA66 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xc000-0xc00f at device 7.1 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
uhci0: <VIA 83C572 USB controller> port 0xc400-0xc41f irq 11 at device 7.2 on pci0
uhci0: [GIANT-LOCKED]
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xc800-0xc81f irq 11 at device 7.3 on pci0
uhci1: [GIANT-LOCKED]
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pci0: <bridge> at device 7.4 (no driver attached)
pcm0: <VIA VT82C686A> port 0xcc00-0xccff,0xd000-0xd003,0xd400-0xd403 irq 5 at device 7.5 on pci0
pcm0: [GIANT-LOCKED]
pcm0: <SigmaTel STAC9721/23 AC97 Codec>
vr0: <VIA VT6105 Rhine III 10/100BaseTX> port 0xd800-0xd8ff mem 0xde000000-0xde0000ff irq 11 at device 16.0 on pci0
miibus0: <MII bus> on vr0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
vr0: Ethernet address: 00:40:f4:86:dd:dc
pcm1: <Creative EMU10K1> port 0xdc00-0xdc1f irq 10 at device 17.0 on pci0
pcm1: <SigmaTel STAC9708/11 AC97 Codec>
pmtimer0 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model IntelliMouse, device ID 3
fdc0: <Enhanced floppy controller> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
unknown: <PNP0303> can't assign resources (port)
unknown: <PNP0c01> can't assign resources (memory)
unknown: <PNP0f13> can't assign resources (irq)
unknown: <PNP0700> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0400> can't assign resources (port)
Timecounter "TSC" frequency 847139718 Hz quality 800
Timecounters tick every 1.000 msec
ad0: 76319MB <Seagate ST380011A 3.06> at ata0-master PIO4
acd0: DVDR <SONY DVD RW DW-Q30A/YYS1> at ata1-master PIO4
acd1: CDRW <SONY CD-RW CRX300E/KYS2> at ata1-slave PIO4
...

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 11-Янв-06, 02:54 
>Подробное описание железа в студию! Извините, но если мне не изменяет память,
>меалофон у Алисы.
...
unknown: <PNP0303> can't assign resources (port)
unknown: <PNP0c01> can't assign resources (memory)
unknown: <PNP0f13> can't assign resources (irq)
unknown: <PNP0700> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0400> can't assign resources (port)
...
эти строки иногда пишет, иногда нет...
а зависает всегда, если я правильно понял - все определилось и загрузилось как нада...
Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

22. "Проблема с зависанием..."  
Сообщение от Wulf on 23-Янв-06, 00:16 
>unknown: <PNP0303> can't assign resources (port)
>unknown: <PNP0c01> can't assign resources (memory)
>unknown: <PNP0f13> can't assign resources (irq)
>unknown: <PNP0700> can't assign resources (port)
>unknown: <PNP0501> can't assign resources (port)
>unknown: <PNP0501> can't assign resources (port)
>unknown: <PNP0400> can't assign resources (port)
>...
>эти строки иногда пишет, иногда нет...

сдается мне, что у вас(или у Вашей FreeBSD) пробемы с ACPI. Можно попробовать поправить hint.acpi.0.disabled="1" в /boot./devices.hint (тогда такие строчки все время будут выскакивать) или попробовать обновится до CURRENT, если не боитесь граблей.

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "Проблема с зависанием..."  
Сообщение от lavr email on 11-Янв-06, 18:25 
>Посдскажите пожалуйста решение следующей проблемы:
>
>стоит FreeBSD 6.0
>все работает корректно, но... стабильно зависает
>причем зависает независимо от того: в консоле я, в Х-ах, работаю или
>проставивает машина... может зависнуть через 5 минут после загрузки системы, может
>через 3 часа работы после загрузки.
>
>проблема не исчезла и при пересборке ядра.
>в принципе никаких серьезных настроек не делал. только установил родной дистриб, а
>так же поставил родные драйвера от нВидии.
>
>сетевые сервисы (httpd,ftpd и прочие) не включал - лишь настроен доступ в
>сеть (IPv6 отключен)
>
>тот же дистриб на другой машине - работает стабильно (правда машина поновее)
>
>
>Комп работает с Виндами уже 5 лет, работает стабильно... всякие стресс-тесты ничего
>не выявляют.
>
>ВОПРОС: в чем может быть причина??? излазил в /var/log ничего подозрительного не
>обнаружил... во всех логах сеанс кончается последней удачной командой, а потом
>идет уже лог загрузки ядра заново...
>где мне посмотреть какие могут быть ошибки? как мне разобраться, что может
>вызывать зависание? посмотрел банальные весчи - место на разделах есть... все
>устройства работают...
>
>но все равно виснет даже в консольной строке... ((
>
>система замкнута - нет никаких влияний извне за исключением смонтированнного PRIMARI DOS
>раздела на rw... но я не думаю, что изза него могут
>быть сбои...
>
>ПАМАГИТЕ!!!!! ПЛИИИИИИЗ!!!!!

# uname -a
# kldstat
# sysctl -a | grep hw.ata
# sysctl -a | grep cpu
результаты команд в студию, плюс конфиг ядра

1) загрузись с acpi disable и посмотри как долго машина будет жить
2) что значит "машина зависает"? kernel-panic? дамп паники есть?

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 11-Янв-06, 19:15 
># uname -a
># kldstat
># sysctl -a | grep hw.ata
># sysctl -a | grep cpu
>результаты команд в студию, плюс конфиг ядра

FreeBSD ghost.rostokino 6.0-RELEASE FreeBSD 6.0-RELEASE #0: Mon Jan  9 03:59:24 MSK 2006     root@ghost.rostokino:/usr/src/sys/i386/compile/MYFK  i386

Id Refs Address    Size     Name
1    5 0xc0400000 3545b4   kernel
2    1 0xc0755000 429d40   nvidia.ko

hw.ata.ata_dma: 1
hw.ata.atapi_dma: 1
hw.ata.wc: 1

kern.threads.virtual_cpu: 1
kern.ccpu: 1948
kern.smp.maxcpus: 1
kern.smp.cpus: 1
debug.cpufreq.lowest: 0
debug.cpufreq.verbose: 0
hw.ncpu: 1
machdep.cpu_idle_hlt: 1
dev.cpu.0.%driver: cpu
dev.cpu.0.%parent: legacy0

Конфиг ядра стандартный GENERIC, закоментированы почти все СКАЗИ (за исключением scbus и da и чего-то еще) и добавлен драйвер звука на креатив - встроенную звуковуху я отрубил, остался Креатив SB Live!.
А так ядро стандартное. Лог кстати стандартного GENERIC ядра.
Я же говорю - после установки ничего существенного не устанавливал/ не настраивал - только поставил драйвер нВидиа - стоит не криво вроде. А проблемы с зависанием начались сражу же с первой загрузки после установки Фри...
Комп под виндами тестил всякими бенчмарками, мемтестом, спидсисом и прочим прочим прочим... везде все стабильно.... ((((

>1) загрузись с acpi disable и посмотри как долго машина будет жить
живет по-разному что с acpi, что без...

>2) что значит "машина зависает"? kernel-panic? дамп паники есть?
паника ядра была всего один раз - вытащил неразмонтированную флэшку (просто решил проверить) и это было в том году, больше паник не было, дампа нет

машина виснет наглухо, на NumLock не реагирует, вообще ни на что.
на пинг не проверял, но думаю - бесполезно... при случае проверю....

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "Проблема с зависанием..."  
Сообщение от northbear (??) on 13-Янв-06, 08:02 

>da и чего-то еще) и добавлен драйвер звука на креатив -
>встроенную звуковуху я отрубил, остался Креатив SB Live!.

Очевидно, что встроенная звуковуха не отрублена:

pcm0: <VIA VT82C686A> port 0xcc00-0xccff,0xd000-0xd003,0xd400-0xd403 irq 5 at device 7.5 on pci0
pcm0: [GIANT-LOCKED]
pcm0: <SigmaTel STAC9721/23 AC97 Codec>
...
[skipped]
...
pcm1: <Creative EMU10K1> port 0xdc00-0xdc1f irq 10 at device 17.0 on pci0
pcm1: <SigmaTel STAC9708/11 AC97 Codec>

Если я правильно себе представляю ситуацию, то на мамке должон быть жампер соответствующий.


>А так ядро стандартное. Лог кстати стандартного GENERIC ядра.
>Я же говорю - после установки ничего существенного не устанавливал/ не настраивал
>- только поставил драйвер нВидиа - стоит не криво вроде. А
>проблемы с зависанием начались сражу же с первой загрузки после установки
>Фри...
>Комп под виндами тестил всякими бенчмарками, мемтестом, спидсисом и прочим прочим прочим...
>везде все стабильно.... ((((
>
>>1) загрузись с acpi disable и посмотри как долго машина будет жить
>живет по-разному что с acpi, что без...
>
>>2) что значит "машина зависает"? kernel-panic? дамп паники есть?
>паника ядра была всего один раз - вытащил неразмонтированную флэшку (просто решил
>проверить) и это было в том году, больше паник не было,
>дампа нет
>
>машина виснет наглухо, на NumLock не реагирует, вообще ни на что.
>на пинг не проверял, но думаю - бесполезно... при случае проверю....

Это однозначно свидетельствует о косяках с железом.
Советую заглянуть в LINT на предмет всяческих фич VIA чипсетов...

В частности, например:

device          smbus
device          viapm
device          smb  

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "Проблема с зависанием..."  
Сообщение от lavr email on 13-Янв-06, 13:22 
Sorry - НЕБЫЛО ВРЕМЕНИ

>># uname -a
>># kldstat
>># sysctl -a | grep hw.ata
>># sysctl -a | grep cpu
>>результаты команд в студию, плюс конфиг ядра
>
>FreeBSD ghost.rostokino 6.0-RELEASE FreeBSD 6.0-RELEASE #0: Mon Jan  9 03:59:24 MSK
>2006     root@ghost.rostokino:/usr/src/sys/i386/compile/MYFK  i386
>
>Id Refs Address    Size     Name
>
> 1    5 0xc0400000 3545b4   kernel
> 2    1 0xc0755000 429d40   nvidia.ko
>
>hw.ata.ata_dma: 1
>hw.ata.atapi_dma: 1
>hw.ata.wc: 1

переведи в 0 все верхние переменные

>kern.threads.virtual_cpu: 1
>kern.ccpu: 1948
>kern.smp.maxcpus: 1
>kern.smp.cpus: 1
>debug.cpufreq.lowest: 0
>debug.cpufreq.verbose: 0
>hw.ncpu: 1
>machdep.cpu_idle_hlt: 1
>dev.cpu.0.%driver: cpu
>dev.cpu.0.%parent: legacy0
>
>Конфиг ядра стандартный GENERIC, закоментированы почти все СКАЗИ (за исключением scbus и
>da и чего-то еще) и добавлен драйвер звука на креатив -
>встроенную звуковуху я отрубил, остался Креатив SB Live!.
>А так ядро стандартное. Лог кстати стандартного GENERIC ядра.

плохо :( я просил ядро, сюда конечно необязательно, но URL можно
было бы дать. А так, разговор беcпредметный.

>Я же говорю - после установки ничего существенного не устанавливал/ не настраивал
>- только поставил драйвер нВидиа - стоит не криво вроде. А
>проблемы с зависанием начались сражу же с первой загрузки после установки
>Фри...
>Комп под виндами тестил всякими бенчмарками, мемтестом, спидсисом и прочим прочим прочим...
>везде все стабильно.... ((((
>
>>1) загрузись с acpi disable и посмотри как долго машина будет жить
>живет по-разному что с acpi, что без...
>
>>2) что значит "машина зависает"? kernel-panic? дамп паники есть?
>паника ядра была всего один раз - вытащил неразмонтированную флэшку (просто решил
>проверить) и это было в том году, больше паник не было,
>дампа нет
>
>машина виснет наглухо, на NumLock не реагирует, вообще ни на что.
>на пинг не проверял, но думаю - бесполезно... при случае проверю....

# pciconf -lv
и ядро в студию + какие устройства используются: USB, SOUND, PRINTER...

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 13-Янв-06, 17:25 
>>hw.ata.ata_dma: 1
>>hw.ata.atapi_dma: 1
>>hw.ata.wc: 1
>
>переведи в 0 все верхние переменные

прописал в loader.conf - перезагружусь и посмотрю, будет ли реакция...

>я просил ядро, сюда конечно необязательно, но URL можно
>было бы дать. А так, разговор беcпредметный.
># pciconf -lv
>и ядро в студию + какие устройства используются: USB, SOUND, PRINTER...

http://liquidcore.nm.ru/BSD/
3 файла : конфиг ядра MYFK, лог загрузки и результат pciconf -lv

А из девайсов: монитор, клава PS/2, mouse PS/2; в сисблоке типичный набор девайсов (мама+проц+память+хард) звук встроенный (отрублен), SB LIVE PCI (модуль включен в ядро), видео nVidia GeForce2 MX 400 32 метра (модуль подгружается при загрузке), сетевуха PCI VIA ShrineIII (вроде так). Все. Более ничего. Принтер к LPT - я его даже еще не включал.

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

10. "Проблема с зависанием..."  
Сообщение от lavr email on 13-Янв-06, 18:08 
>>>hw.ata.ata_dma: 1
>>>hw.ata.atapi_dma: 1
>>>hw.ata.wc: 1
>>
>>переведи в 0 все верхние переменные
>
>прописал в loader.conf - перезагружусь и посмотрю, будет ли реакция...
>
>>я просил ядро, сюда конечно необязательно, но URL можно
>>было бы дать. А так, разговор беcпредметный.
>># pciconf -lv
>>и ядро в студию + какие устройства используются: USB, SOUND, PRINTER...
>
>http://liquidcore.nm.ru/BSD/
>3 файла : конфиг ядра MYFK, лог загрузки и результат pciconf -lv
>
>
>А из девайсов: монитор, клава PS/2, mouse PS/2; в сисблоке типичный набор
>девайсов (мама+проц+память+хард) звук встроенный (отрублен), SB LIVE PCI (модуль включен в
>ядро), видео nVidia GeForce2 MX 400 32 метра (модуль подгружается при
>загрузке), сетевуха PCI VIA ShrineIII (вроде так). Все. Более ничего. Принтер
>к LPT - я его даже еще не включал.

atapci0: <VIA 82C686A UDMA66 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xd000-0xd00f at device 7.1 on pci0

ATA(IDE) контроллер - UDMA66 на VIA чипсете, они чаще всего уродские

ad0: 76319MB <Seagate ST380011A 3.06> at ata0-master UDMA66
acd0: DMA limited to UDMA33, device found non-ATA66 cable
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
acd0: DVDR <SONY DVD RW DW-Q30A/YYS1> at ata1-master UDMA33
acd1: CDRW <SONY CD-RW CRX300E/KYS2> at ata1-slave UDMA33

кабель на котором сидят DVD/CDRW - 40pin
диск на таком же кабеле сидит? короче забей на UDMA66, возьми
старый IDE кабель 40pin как для DVD/CDRW и посади на него HDD

Короче проблема в контроллере и дисках - переведи ВСЕ в PIO MODE
и засунь переменные ядра hw.ata в /boot/loader.conf или в
/boot/loader.conf.local + то что написано выше.

Все твои проблемы должны будут исчезнуть.

Из ядра можешь смело выкинуть ненужные опции и драйвера:

...
options AHC_REG_PRETTY_PRINT # Print register bitfields in debug
# output.  Adds ~128k to driver.
options AHD_REG_PRETTY_PRINT # Print register bitfields in debug
# output.  Adds ~215k to driver.
options ADAPTIVE_GIANT # Giant mutex is adaptive.
...
device eisa #нафига тебе EISA, у тебя есть такая шина?

device ch # SCSI media changers - выкини

нафик не нужно, а в секцию к ata добавь:

device          atapicam # можно испльзовать CAM-SCSI для работы с CD/DVD

соответственно забить на burncd и поставить из портов cdrtools/cdrdao
и тд и тп
device apm # выкинь нафик, если у тебя система нормально работает
в ACPI, какую-то одну технологию нужно использовать, либо APM - устарев.
либо ACPI.

на кой тебе PCCARD/PCMCIA (у теб что - notebook?)
device cbb # cardbus (yenta) bridge
device pccard # PC Card (16-bit) bus
device cardbus # CardBus (32-bit) bus

Если не будешь использовать принтер - закоментарь ВСЮ секцию LPT -
освободишь IRQ=7

закоментарь или выкини ВСЕ драйвера network-card, грузи модулем или
оставь только тот которые используешь РЕАЛЬНО.

Тоже самое и с sound
options COMPAT_LINUX # выкинь, лучше использовать модульную
подгрузку

После этого будет цивильно.

В монолитном ядре КРАЙНЕ НЕЖЕЛАТЕЛЬНО оставлять драйвера для
отсутствующих устройств, мешать будут, если для необходимого
устройства есть модульный драйвер - лучше и грузить его модульно.

Особенно net-card, sound, и эмуляцию linux'а

да, возможно имеет смысл попробовать:

# viapm         VIA VT82C586B/596B/686A and VT8233 Power Management Unit

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

11. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 17-Янв-06, 02:33 
>ATA(IDE) контроллер - UDMA66 на VIA чипсете, они чаще всего уродские
>
>ad0: 76319MB <Seagate ST380011A 3.06> at ata0-master UDMA66
>acd0: DMA limited to UDMA33, device found non-ATA66 cable
>^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>acd0: DVDR <SONY DVD RW DW-Q30A/YYS1> at ata1-master UDMA33
>acd1: CDRW <SONY CD-RW CRX300E/KYS2> at ata1-slave UDMA33
>
>кабель на котором сидят DVD/CDRW - 40pin
>диск на таком же кабеле сидит? короче забей на UDMA66, возьми
>старый IDE кабель 40pin как для DVD/CDRW и посади на него HDD
>
>Короче проблема в контроллере и дисках - переведи ВСЕ в PIO MODE

1) хард висит на 80пиновом (ну который 66), 2 сидюка на 40пиновом
неужели проблемы исчезнут если поменять кабеля? (т.е. 33 на хард пустить, а 66 на сидюки?)
2) что есть PIO MODE? попробовал посадить хард и двд на 80пиновый - писал во время теста оборудования что-то про PIO4...
3) есть ли ресурс про известные ошибки оборудования? чтоб я вводил допустим мой чипсет VIA 82C686A и он мне писал все, что Бздя должна о нем думать?


>и засунь переменные ядра hw.ata в /boot/loader.conf или в
>/boot/loader.conf.local + то что написано выше.
>Все твои проблемы должны будут исчезнуть.
>
хех... я все не могу понять при чем тут контроллер IDE? в винде то работает ( я понимаю память битая была б, или видюха кривая... и почему логов нигде не остается? можно все таки, чтоб сама система написала где сбой? а то мне не нравится то, в чем я не могу разобраться...

>Из ядра можешь смело выкинуть ненужные опции и драйвера:
про ненужные эт я понял....

>да, возможно имеет смысл попробовать:
># viapm         VIA VT82C586B/596B/686 and VT8233 Power Management Unit
хм... включу в ядро, но необходима ли она?

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

12. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 17-Янв-06, 11:04 
мда... хотел переустановить Фрю... зависла даже на этапе установки... ((
Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

13. "Проблема с зависанием..."  
Сообщение от lavr email on 17-Янв-06, 11:51 
>мда... хотел переустановить Фрю... зависла даже на этапе установки... ((

я дал конкретный СОВЕТ, ваша ситуация прозрачна:

- сменить 80pin кабель на 40pin для HDD
- перевести работу HDD в PIO: в BIOS и в системе

# echo hw.ata.ata_dma=0 >> /boot/loader.conf
# echo hw.ata.wc=0 >> /boot/loader.conf

если что-то непонятно в отношении hardware -> читайте ixbt.com или
массу различной документации по hardware

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

14. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 22-Янв-06, 11:30 
В любом случае - СПАСИБО ОГРОМНОЕ.... хотя проблему я пока не смог решить... вопрос: когда вы говорите про "сменить на на 40пиновый" вы имеете ввиду ВСЕ харды? просто ситуация такая:
КОнтроллер АТА66
1 канал IDE висит на 80пиновом (80Гб сегейт (АТА100) и ДВД-РВ (хз сколько))
2 канал IDE висит на 40пиновом (4.3Гб Фуджитсу (АТА33) и КОМБО (хз сколько))

на 1 канале висит Винда
на 2ом канале висит Фря...

поэтому тот диск, что используется Фрей висит на 40пиновом...
в принципе не висла долгое время... потом я примонтировал раздел FAT с первого диска и через час-полтора она повисла - может не использовать ad0 через фрю? т.е. фича контролера будет обходиться фрей и все будет окей?

Плиз прокомментируйте..
Еще раз спасибо за уделенное мне время =)


Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

15. "Проблема с зависанием..."  
Сообщение от lavr email on 22-Янв-06, 17:30 
>В любом случае - СПАСИБО ОГРОМНОЕ.... хотя проблему я пока не смог
>решить... вопрос: когда вы говорите про "сменить на на 40пиновый" вы
>имеете ввиду ВСЕ харды? просто ситуация такая:
>КОнтроллер АТА66
>1 канал IDE висит на 80пиновом (80Гб сегейт (АТА100) и ДВД-РВ (хз
>сколько))
>2 канал IDE висит на 40пиновом (4.3Гб Фуджитсу (АТА33) и КОМБО (хз
>сколько))
>
>на 1 канале висит Винда
>на 2ом канале висит Фря...
>
>поэтому тот диск, что используется Фрей висит на 40пиновом...
>в принципе не висла долгое время... потом я примонтировал раздел FAT с
>первого диска и через час-полтора она повисла - может не использовать
>ad0 через фрю? т.е. фича контролера будет обходиться фрей и все
>будет окей?
>
>Плиз прокомментируйте..
>Еще раз спасибо за уделенное мне время =)


О господя...

Допустим у меня контроллер с двумя каналами, на каждом по устройству.

И вот на одном канале дохнет контроллер или чип. Не полностью, но
подыхает. Питание на устройства вы подали, интерфейсный кабель тоже.

Какое будет поведение системы? Правильно - непредсказуемое, работает...
работает... Бац, чип перегрелся и сдурел - система в панике.

Что нужно сделать чтобы этого НЕ БЫЛО: правильно - как минимум вытащить
интерфейсные шлейфы, максимум - еще и питалово с hdd/cd[rw]/dvd[rw]
на этом канале.

Что от того что там Windows, драйвер видит устройство и работает
с контроллером, контроллер обслуживает ОБА канала - что еще объяснять?!

Ну выньте шлейфы и питалово из устройств на ненужном вам канале
и посмотрите результат.

Все остальное я уже объяснил и прокомментировал: UDMA -> PIO
и смотрите результат, либо получите дамп при панике, либо используйте
ядрЁную отладку...

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

16. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 22-Янв-06, 18:48 
>Ну выньте шлейфы и питалово из устройств на ненужном вам канале
>и посмотрите результат.
может я чего не понимаю... но на момент открытия темы у меня висело 3 девайса, собстно оба канала были в использовании (т.е. нет ненужных каналов - и оба канала работали стабильно в Винде...)
4 девайса висит сейчас - Винда работает не менее стабильно... все девайсы (все 4) 100% рабочие и без глюков - оттестеные по несколько раз всеми возможными утилитами, включая фирмовые (от фирм-производителей)
Комп находится в работе в конфигурации 3-4 девайса (переменно) уже в течении 5 лет без перерыва использования... иногда неделями без выключения... виснет крайне редко, и то это в прошлом когда была одна битая линейка памяти...
на протяжении 5 лет стояли ВСЕ!!! (до 2003иХР) версии ОС Windows, пара тройка linux систем (и RedHAt, и ASPLinux и чет еще)... ВСЕ РАБОТАЛИ СТАБИЛЬНО!!! Т.е. беспричинных глюков, а тем более глюков с оборудованием не было...

Ничего не понимаю... я вроде не дурак... столько систем разных попереустанавливал.. столько компов собрал, сервера собирал, настраивал... опыта правда мало с ОС POSIX типа.... но...
нихера не понимаю...
>
>Все остальное я уже объяснил и прокомментировал: UDMA -> PIO
>и смотрите результат, либо получите дамп при панике, либо используйте
>ядрЁную отладку...
Паники нет, логи ничего не фиксируют, драйвера никакие не подгружал, только раздел смонтировал... и то не факт что изз-за ентого...
попробую работать в изоляции от неродных систем - может не будет виснуть.....

все должно работать - висит хард на 40пиновом шлейфе сам ATA33, шлейф ATA33 - все как положено мля... у меня уже истерика...
плять...
........

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

17. "Проблема с зависанием..."  
Сообщение от lavr email on 22-Янв-06, 19:20 
>>Ну выньте шлейфы и питалово из устройств на ненужном вам канале
>>и посмотрите результат.
>может я чего не понимаю... но на момент открытия темы у меня
>висело 3 девайса, собстно оба канала были в использовании (т.е. нет
>ненужных каналов - и оба канала работали стабильно в Винде...)
>4 девайса висит сейчас - Винда работает не менее стабильно... все девайсы
>(все 4) 100% рабочие и без глюков - оттестеные по несколько
>раз всеми возможными утилитами, включая фирмовые (от фирм-производителей)
>Комп находится в работе в конфигурации 3-4 девайса (переменно) уже в течении
>5 лет без перерыва использования... иногда неделями без выключения... виснет крайне
>редко, и то это в прошлом когда была одна битая линейка
>памяти...
>на протяжении 5 лет стояли ВСЕ!!! (до 2003иХР) версии ОС Windows, пара
>тройка linux систем (и RedHAt, и ASPLinux и чет еще)... ВСЕ
>РАБОТАЛИ СТАБИЛЬНО!!! Т.е. беспричинных глюков, а тем более глюков с оборудованием
>не было...
>
>Ничего не понимаю... я вроде не дурак... столько систем разных попереустанавливал.. столько
>компов собрал, сервера собирал, настраивал... опыта правда мало с ОС POSIX
>типа.... но...
>нихера не понимаю...
>>
>>Все остальное я уже объяснил и прокомментировал: UDMA -> PIO
>>и смотрите результат, либо получите дамп при панике, либо используйте
>>ядрЁную отладку...
>Паники нет, логи ничего не фиксируют, драйвера никакие не подгружал, только раздел
>смонтировал... и то не факт что изз-за ентого...
>попробую работать в изоляции от неродных систем - может не будет виснуть.....
>
>
>все должно работать - висит хард на 40пиновом шлейфе сам ATA33, шлейф
>ATA33 - все как положено мля... у меня уже истерика...
>плять...
>........

вы совет попробуйте:

# echo "hw.ata.ata_dma=0" >> /boot/loader.conf
# echo "hw.ata.wc=0" >> /boot/loader.conf

а потом думайте и рассуждайте сколько душе угодно, что еще вам отписать и
насколько доходчиво, я не знаю.

PS. Если хотите, попробуйте поиск по форуму нечто freebsd udma...

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

18. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 22-Янв-06, 21:12 
>вы совет попробуйте:
># echo "hw.ata.ata_dma=0" >> /boot/loader.conf
># echo "hw.ata.wc=0" >> /boot/loader.conf

давно уже в лоадере прописано

>а потом думайте и рассуждайте сколько душе угодно, что еще вам отписать

>насколько доходчиво, я не знаю.

спасибо и за все предыдущие сабжи... по опыту - бывают странности, которые не имеют почвы под ногами... и это прискорбно...
например как-то в новогоднюю ночь включил комп... глючило все, начиная от драйвера мыши до любой программы... включая nc и все все... выключил... включил вечером - все работает идеально, как и за день до этого... после этого как-то страшно за свой выбор в жизни - работа с ИТ...
>
>PS. Если хотите, попробуйте поиск по форуму нечто freebsd udma...

времени нет копаться без конкретной цели к сожалению... вот если бы Вы посоветовали пару доходчивых мануалов по отлову ошибок такого плана, где могут сохраняться логи ошибок, окромя как в /var/log (там я ничего подозрительного не обнаружил - никаких ошибок), и как самостоятельно проследить ошибки, трассировать их и прочее... то я был бы очень признателен...

Хотя, признаться, я даже не ожидал такой чуткой реакции на мою проблему. Спасибо.

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

23. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 27-Янв-06, 19:01 
Кстати - я заметил, что комп виснет, когда нет активности... т.е. я пошел за чаем.... или ушел на пару часов.... если я постоянно активен - все в порядке в винде.... во фре почти нормально
Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 13-Янв-06, 00:14 
и что? никто не знает чем еще помочь? сделал дамп ACPI - при команде iasl находит 3 предупреждения и три ошибки... но все равно даже без поддержки ACPI виснет... какие нибудь бенчмарки из коллекции портов могут помочь в обнаружении ошибки? или нет?

помагите мудрым советом....

P.S. советы типа "сменить железо" и "сменить дистриб" - НЕ мудрые.... т.к. не помагают....

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

19. "Проблема с зависанием..."  
Сообщение от AMDmi3 email on 22-Янв-06, 23:38 
У меня была такая-же проблема. Как оказалось, остановился кулер на видюхе (тоже nvidia), причем под windows также все нормально работало. Копай все-таки в сторону железа, вряд-ли система виновата. Если не видеокарта, вполне возможно, что память (для проверки памяти - утилита memtest86).
Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

20. "Проблема с зависанием..."  
Сообщение от Toxa (??) on 22-Янв-06, 23:41 
>У меня была такая-же проблема. Как оказалось, остановился кулер на видюхе (тоже
>nvidia), причем под windows также все нормально работало. Копай все-таки в
>сторону железа, вряд-ли система виновата. Если не видеокарта, вполне возможно, что
>память (для проверки памяти - утилита memtest86).

Лучшее что встречал под Винду - prime95 - в режиме Torture test. - Если сутки простояло - в железе можно быть уверенным.

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

21. "Проблема с зависанием..."  
Сообщение от Евгений email(??) on 23-Янв-06, 00:01 
>У меня была такая-же проблема. Как оказалось, остановился кулер на видюхе (тоже
>nvidia), причем под windows также все нормально работало. Копай все-таки в
>сторону железа, вряд-ли система виновата. Если не видеокарта, вполне возможно, что
>память (для проверки памяти - утилита memtest86).

память мемтестом ошибок не выявляет
по поводу видла у меня есть некоторые абстраткные сомнения... можно даже сказать предчувствия... =) хотя бы мне не нравится, что кулер поскрипывает =) иногда )) я его запарился смазывать =) 2 недели крутит и по новой..

надо буит потестить... спасибо за идею =)

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру