The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"setlocale в новом мире?"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"setlocale в новом мире?" 
Сообщение от petr999 emailИскать по авторуВ закладки(??) on 14-Дек-05, 11:51  (MSK)
Недавно попробовал просапиться до реленг_6_0 --- увидел, что не работает локаль. Откатился. Ну это десктоп, ладно, проехали. Есть ещё одна машина, там мир ставится автоматом еженедельно из реленг_5. Так вот, недавно и там локаль отпала. Какие-то конкретные изменения пошли в 5-стабле? где смотреть/трейсить? в сях-щах не силён, но уверен, что дело в мире.
  Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]

1. "setlocale в новом мире?" 
Сообщение от lavr emailИскать по авторуВ закладки on 15-Дек-05, 12:20  (MSK)
>Недавно попробовал просапиться до реленг_6_0 --- увидел, что не работает локаль. Откатился.
>Ну это десктоп, ладно, проехали. Есть ещё одна машина, там мир
>ставится автоматом еженедельно из реленг_5. Так вот, недавно и там локаль
>отпала. Какие-то конкретные изменения пошли в 5-стабле? где смотреть/трейсить? в сях-щах
>не силён, но уверен, что дело в мире.

в этом мире не все просто, но и не так уж сложно.

Зачем вам еженедельная сборка, тем более что в щах вы не сильны?
Из верхнего БЛИЗКО не видно ОТКУДА(с какого release/stable) до КАКОГО(release/stable) были подъемы.

5.x - это одна ВЕТВЬ FreeBSD
6.x - другая, в 6.x изменилась libc, отсюда могут быть проблемы
с locale того софта, что собирался на 5.x и остался после подъема 5.x -> 6.x

Как решается эта проблема - было уже отписано на этом форуме и на sysadmins.ru

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "setlocale в новом мире?" 
Сообщение от petr999 emailИскать по авторуВ закладки(??) on 15-Дек-05, 18:14  (MSK)
>Зачем вам еженедельная сборка, тем более что в щах вы не сильны?

хочется DRI на via s3g unichrome, которое не работает без device drm ( это где 5->6 ).
хочется автоматического реагирования на security advisories ( а это --- где 5->5 ). Всё же вроде работало?

>Из верхнего БЛИЗКО не видно ОТКУДА(с какого release/stable) до КАКОГО(release/stable) были подъемы.

с 5.4-stable августа  до 6.0-release образца ноября (или когда оно там вышло)
теперь та же проблема с 5.4-stable конца ноября до 5.4-stable середины декабря

>5.x - это одна ВЕТВЬ FreeBSD
>6.x - другая, в 6.x изменилась libc, отсюда могут быть проблемы
>с locale того софта, что собирался на 5.x и остался после подъема 5.x -> 6.x

переход 5-stable->6-release ещё объясним, но не 5-stable->5-stable

>Как решается эта проблема - было уже отписано на этом форуме и
>на sysadmins.ru

по каким ключам искать? и почему такие вещи не пишутся в UPDATING?

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "setlocale в новом мире?" 
Сообщение от lavr emailИскать по авторуВ закладки on 15-Дек-05, 20:07  (MSK)
>>Зачем вам еженедельная сборка, тем более что в щах вы не сильны?
>
>хочется DRI на via s3g unichrome, которое не работает без device drm ( это где 5->6 ).

откуда такие сведения про:

device drm ???

есть DRI драйвера для отдельного набора карт (в ядре появилось в 5.x):

1) DRI KERNEL-LEVEL (выдержка из NOTES):

# DRM options:
# mgadrm:    AGP Matrox G200, G400, G450, G550
# r128drm:   ATI Rage 128
# radeondrm: ATI Radeon up to 9000/9100
# sisdrm:    SiS 300/305,540,630
# tdfxdrm:   3dfx Voodoo 3/4/5 and Banshee
# DRM_DEBUG: include debug printfs, very slow
#
# mga requires AGP in the kernel, and it is recommended
# for AGP r128 and radeon cards.

device          mgadrm
device          "r128drm"
device          radeondrm
device          sisdrm
device          tdfxdrm

options         DRM_DEBUG

2) есть в портах (кто в какой момент свежей, нужно смотреть:
ls -la /usr/ports/graphics/ | grep drm
ls -la /usr/ports/graphics/ | grep dri

Про unichrome - работает и поддерживается только то что есть в
последнем xorg 6.8.2 или смотреть x11-servers/xorg-server-snap
Есть проект DRI в рамках которого для linux лобают драйвера и
openchrome - только для unichrome и тоже под linux. Ничего из этого
не портируется, ну разве что первый перерабатывается под FreeBSD.

>хочется автоматического реагирования на security advisories ( а это --- где 5->5 ). Всё же вроде работало?
>

в смысле? я понимаю к примеру использование проекта binaries-upgrade:
security/freebsd-update

а все остальное - подписка на security...@freebsd.org и получение
свежих новостей

>>Из верхнего БЛИЗКО не видно ОТКУДА(с какого release/stable) до КАКОГО(release/stable) были подъемы.
>
>с 5.4-stable августа  до 6.0-release образца ноября (или когда оно там
>вышло)

libc изменилась, не вижу проблем, отписано ранее

>теперь та же проблема с 5.4-stable конца ноября до 5.4-stable середины декабря
>

uname -rs текущей stable? Наверняка тоже libc могла поменяться, если
это так, то при выпуске 5.5 это будет отражено в UPDATING, хотя слабо
вериться чтобы в пределах ВЕТКИ изменили libc, сомневаюсь, полагаю
что вы сами где-то накосячили.

>>5.x - это одна ВЕТВЬ FreeBSD
>>6.x - другая, в 6.x изменилась libc, отсюда могут быть проблемы
>>с locale того софта, что собирался на 5.x и остался после подъема 5.x -> 6.x
>
>переход 5-stable->6-release ещё объясним, но не 5-stable->5-stable
>
>>Как решается эта проблема - было уже отписано на этом форуме и
>>на sysadmins.ru
>
>по каким ключам искать? и почему такие вещи не пишутся в UPDATING?

какие такие? о чем писать - о том что libc изменилась, так это пол-системы, ежику понятно, есть масса вещей которые НЕ ПИШУТ в UPDATING
и смотреть их можно только через CVS

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "setlocale в новом мире?" 
Сообщение от petr999 emailИскать по авторуВ закладки(??) on 16-Дек-05, 10:54  (MSK)
>>>Зачем вам еженедельная сборка, тем более что в щах вы не сильны?
>>хочется DRI на via s3g unichrome, которое не работает без device drm ( это где 5->6 ).
>откуда такие сведения про:
>device drm ???

я вытащил из cvs HEAD xorg в части xc/extras/drm и увидел, что патч от eric anholt туда вошёл. Собрал модуль ядра via.ko, а он не грузится, сообщает, что потому что в ядре нет drm. Подгрузил drm.ko от 6.0, via.ko грузится, но жалуется на несоответствие версии. Думаю, 6.0 ему надо.

>есть DRI драйвера для отдельного набора карт (в ядре появилось в 5.x):
>1) DRI KERNEL-LEVEL (выдержка из NOTES):

видел, нету там via s3g unichrome igp

>2) есть в портах (кто в какой момент свежей, нужно смотреть:
>ls -la /usr/ports/graphics/ | grep drm
>ls -la /usr/ports/graphics/ | grep dri

по порядку:

$ ls -1d /usr/ports/graphics/dr[im]*
/usr/ports/graphics/dri

и так есть

/usr/ports/graphics/dri-devel

июльский снапшот --- via там нет:

===
$ find /usr/ports/graphics/dri-devel/work/drm/bsd* -iname '*via*'|wc -l
0
===
/usr/ports/graphics/driconf

это тулзы, надо ядро/либы

/usr/ports/graphics/drm-kmod

это под фрю-4

>Про unichrome - работает и поддерживается только то что есть в
>последнем xorg 6.8.2 или смотреть x11-servers/xorg-server-snap

только в snap он и есть, но без dri.

> Есть проект DRI в рамках которого для linux лобают драйвера и
>openchrome - только для unichrome и тоже под linux. Ничего из этого
>не портируется, ну разве что первый перерабатывается под FreeBSD.

какой проект? dri.sf.net?

>>хочется автоматического реагирования на security advisories ( а это --- где 5->5 ). Всё же вроде работало?
>в смысле? я понимаю к примеру использование проекта binaries-upgrade:
>security/freebsd-update

и там libc не меняется? а там можно выписать stable или только release?

>>с 5.4-stable августа  до 6.0-release образца ноября (или когда оно там
>>вышло)
>libc изменилась, не вижу проблем, отписано ранее

ранее ---это на деревню опеннету? или куда?

>>теперь та же проблема с 5.4-stable конца ноября до 5.4-stable середины декабря
>uname -rs текущей stable?

FreeBSD 5.4-STABLE

> Наверняка тоже libc могла поменяться, если
>это так, то при выпуске 5.5 это будет отражено в UPDATING, хотя
>слабо
>вериться чтобы в пределах ВЕТКИ изменили libc,

мне тоже

> сомневаюсь, полагаю
>что вы сами где-то накосячили.

год крон нормально эту задачу выполнял в обычной и jail-ветках, а тут вдруг ему взбрендилось?

>>>5.x - это одна ВЕТВЬ FreeBSD
>>>6.x - другая, в 6.x изменилась libc, отсюда могут быть проблемы
>>>с locale того софта, что собирался на 5.x и остался после подъема 5.x -> 6.x
>>переход 5-stable->6-release ещё объясним, но не 5-stable->5-stable
>>>Как решается эта проблема - было уже отписано на этом форуме и
>>>на sysadmins.ru
>>по каким ключам искать? и почему такие вещи не пишутся в UPDATING?
>какие такие?

https://www.opennet.ru/search.shtml?words=freebsd+libc&sort=time&exclude=&config=htdig_forum&exclude=index
странно, но нашлось

> о чем писать - о том что libc изменилась, так
>это пол-системы, ежику понятно, есть масса вещей которые НЕ ПИШУТ в
>UPDATING
>и смотреть их можно только через CVS

думается, что UPDATING --- это чтобы сюда не писАли "не работает!". разве не так?

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "setlocale в новом мире?" 
Сообщение от lavr emailИскать по авторуВ закладки on 16-Дек-05, 11:56  (MSK)
>>>>Зачем вам еженедельная сборка, тем более что в щах вы не сильны?
>>>хочется DRI на via s3g unichrome, которое не работает без device drm ( это где 5->6 ).
>>откуда такие сведения про:
>>device drm ???
>
>я вытащил из cvs HEAD xorg в части xc/extras/drm и увидел, что
>патч от eric anholt туда вошёл. Собрал модуль ядра via.ko, а
>он не грузится, сообщает, что потому что в ядре нет drm.
>Подгрузил drm.ko от 6.0, via.ko грузится, но жалуется на несоответствие версии.
>Думаю, 6.0 ему надо.

sorry, ниче не понял

>>есть DRI драйвера для отдельного набора карт (в ядре появилось в 5.x):
>>1) DRI KERNEL-LEVEL (выдержка из NOTES):
>
>видел, нету там via s3g unichrome igp

а кто-то говорил что есть?! 8-|

>>2) есть в портах (кто в какой момент свежей, нужно смотреть:
>>ls -la /usr/ports/graphics/ | grep drm
>>ls -la /usr/ports/graphics/ | grep dri
>
>по порядку:
>
>$ ls -1d /usr/ports/graphics/dr[im]*
>/usr/ports/graphics/dri
>
>и так есть
>
>/usr/ports/graphics/dri-devel
>
>июльский снапшот --- via там нет:
>
>===
>$ find /usr/ports/graphics/dri-devel/work/drm/bsd* -iname '*via*'|wc -l
>0
>===
>/usr/ports/graphics/driconf
>
>это тулзы, надо ядро/либы
>
>/usr/ports/graphics/drm-kmod
>
>это под фрю-4

Бр-р-р. Разве не вы написали про: device drm в ядре?!
Именно по этому пункту я и отвечал, полагая что достаточно указать
на то ГДЕ посмотреть:
- kernel-level dri
- modules from ports
- drivers from Xorg

из которых можно понять что НЕТ нужного вам драйвера и ВСЕ ЧТО ВЫ
можете найти - это Xorg, это было сказано прямым текстом и что
в портах НЕТ НИЧЕГО в плане unichrome и единственный вариант - посмотреть
xorg-server-snap. Ниже это явно и прямым текстом.

>>Про unichrome - работает и поддерживается только то что есть в
>>последнем xorg 6.8.2 или смотреть x11-servers/xorg-server-snap
>
>только в snap он и есть, но без dri.

либо собирайте сами - не из портов, либо спросите в списках рассылки
freebsd. Возможно что-то заведется, под XFree86 у кого-то получалось.

>> Есть проект DRI в рамках которого для linux лобают драйвера и
>>openchrome - только для unichrome и тоже под linux. Ничего из этого
>>не портируется, ну разве что первый перерабатывается под FreeBSD.
>
>какой проект? dri.sf.net?

угу, но его рихтует Эрик конкретно под FreeBSD, те то что в портах
!= dri.sf.net

>>>хочется автоматического реагирования на security advisories ( а это --- где 5->5 ). Всё же вроде работало?
>>в смысле? я понимаю к примеру использование проекта binaries-upgrade:
>>security/freebsd-update
>
>и там libc не меняется? а там можно выписать stable или только
>release?

бррр, а теперь самостоятельно подумайте что спросили и что есть
бинарный апгрейд.

>>>с 5.4-stable августа  до 6.0-release образца ноября (или когда оно там
>>>вышло)
>>libc изменилась, не вижу проблем, отписано ранее
>
>ранее ---это на деревню опеннету? или куда?

no comments

>>>теперь та же проблема с 5.4-stable конца ноября до 5.4-stable середины декабря
>>uname -rs текущей stable?
>
>FreeBSD 5.4-STABLE

увы, тут не подскажу, 5.4 у меня только на одном сервере осталась
и поднимать до 5.4-stable не вижу резона, так что посмотреть не на чем.

>> Наверняка тоже libc могла поменяться, если
>>это так, то при выпуске 5.5 это будет отражено в UPDATING, хотя
>>слабо
>>вериться чтобы в пределах ВЕТКИ изменили libc,
>
>мне тоже

значит ищите где у вас косяк.

>> о чем писать - о том что libc изменилась, так
>>это пол-системы, ежику понятно, есть масса вещей которые НЕ ПИШУТ в
>>UPDATING
>>и смотреть их можно только через CVS
>
>думается, что UPDATING --- это чтобы сюда не писАли "не работает!". разве
>не так?

вероятно не так, обратитесь к FreeBSD Team с этим вопросом, свои мысли
я уже изложил. Да, еще регулярно публикуются отчеты и к каждому РЕЛИЗУ
есть RELNOTES, для STABLE и CURRENT есть cvs и списки рассылки freebsd.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "setlocale в новом мире?" 
Сообщение от petr999 emailИскать по авторуВ закладки(??) on 16-Дек-05, 12:32  (MSK)
>>>откуда такие сведения про:
>>>device drm ???
>>я вытащил из cvs HEAD xorg в части xc/extras/drm и увидел, что
>>патч от eric anholt туда вошёл. Собрал модуль ядра via.ko, а
>>он не грузится, сообщает, что потому что в ядре нет drm.
>>Подгрузил drm.ko от 6.0, via.ko грузится, но жалуется на несоответствие версии.
>>Думаю, 6.0 ему надо.
>sorry, ниче не понял

я достал xorg из cvs и вижу, что там есть исходники для сборки via.ko. Даже удалось собрать, но он не грузится. drm.ko от 6.0 помог. неясно что?

>>>есть DRI драйвера для отдельного набора карт (в ядре появилось в 5.x):
>>>1) DRI KERNEL-LEVEL (выдержка из NOTES):
>>видел, нету там via s3g unichrome igp
>а кто-то говорил что есть?! 8-|

я говорил что надо

>>>2) есть в портах (кто в какой момент свежей, нужно смотреть:
>>>ls -la /usr/ports/graphics/ | grep drm
>>>ls -la /usr/ports/graphics/ | grep dri
>>по порядку:
>>$ ls -1d /usr/ports/graphics/dr[im]*

>Бр-р-р. Разве не вы написали про: device drm в ядре?!
>Именно по этому пункту я и отвечал, полагая что достаточно указать
>xorg-server-snap. Ниже это явно и прямым текстом.

я уже давно нашёл svga развёртки, надо dri к нему, в частности, drm-модуль ядра.

>>>Про unichrome - работает и поддерживается только то что есть в
>>>последнем xorg 6.8.2 или смотреть x11-servers/xorg-server-snap
>>только в snap он и есть, но без dri.
>либо собирайте сами - не из портов, либо спросите в списках рассылки
>freebsd. Возможно что-то заведется, под XFree86 у кого-то получалось.

конечно, заведётся, только не зависит это от того, какое X, а нужен модуль ядра соответствующий, то есть, от ядра.

>угу, но его рихтует Эрик конкретно под FreeBSD, те то что в
>портах
>!= dri.sf.net

смотрел я его, стащил эриков патч, потом xorg из cvs, смотрю, а этот патч уже вошёл.

>>>>хочется автоматического реагирования на security advisories ( а это --- где 5->5 ). Всё же вроде работало?
>>>в смысле? я понимаю к примеру использование проекта binaries-upgrade:
>>>security/freebsd-update
>>и там libc не меняется? а там можно выписать stable или только
>>release?
>бррр, а теперь самостоятельно подумайте что спросили и что есть
>бинарный апгрейд.

от бинарного апгрейда меняется libc, правильно?

>>> Наверняка тоже libc могла поменяться, если
>>>это так, то при выпуске 5.5 это будет отражено в UPDATING, хотя
>>>слабо
>>>вериться чтобы в пределах ВЕТКИ изменили libc,
>>мне тоже
>значит ищите где у вас косяк.

где именно искать? в том и вопрос.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "setlocale в новом мире?" 
Сообщение от lavr emailИскать по авторуВ закладки on 16-Дек-05, 14:28  (MSK)
>>>>откуда такие сведения про:
>>>>device drm ???
>>>я вытащил из cvs HEAD xorg в части xc/extras/drm и увидел, что
>>>патч от eric anholt туда вошёл. Собрал модуль ядра via.ko, а
>>>он не грузится, сообщает, что потому что в ядре нет drm.
>>>Подгрузил drm.ko от 6.0, via.ko грузится, но жалуется на несоответствие версии.
>>>Думаю, 6.0 ему надо.
>>sorry, ниче не понял
>
>я достал xorg из cvs и вижу, что там есть исходники для
>сборки via.ko. Даже удалось собрать, но он не грузится. drm.ko от
>6.0 помог. неясно что?

теперь ясно

>>>>есть DRI драйвера для отдельного набора карт (в ядре появилось в 5.x):
>>>>1) DRI KERNEL-LEVEL (выдержка из NOTES):
>>>видел, нету там via s3g unichrome igp
>>а кто-то говорил что есть?! 8-|
>
>я говорил что надо

я ответил что НЕТУ и все что есть - это можно найти в snapshot'е xorg'а

>я уже давно нашёл svga развёртки, надо dri к нему, в частности,
>drm-модуль ядра.

попытаться разобраться в linux'овых модулях либо от dri.sf.net,
либо от openchrome и портировать их под freebsd.

>конечно, заведётся, только не зависит это от того, какое X, а нужен
>модуль ядра соответствующий, то есть, от ядра.

в xorg тоже есть модули drm с заточкой под разные OS

>>бррр, а теперь самостоятельно подумайте что спросили и что есть
>>бинарный апгрейд.
>
>от бинарного апгрейда меняется libc, правильно?

ну если были изменения, значит как произведен апгрейд - неважно.

>где именно искать? в том и вопрос.

truss, strace, ktrace - еще полезно логи cvsup'а иметь, сразу видно
какие sources в системе менялись и тут уж можно конкретные sources
сравнить. Чесно говоря, я ничего не сравнивал когда перевел свою 5.4
на 6.0 (личную wks - экспериментальную) - просто сразу начал шаманить
и смотреть трассировки, сделал вывод что изменилась libc, доставил
compat5x, вычистил из /lib старье от 5.x (чтобы оно только в compat было)
и приступил к мапированию через libmap.conf
Просто так с бухты-барахты, даже не знаю какой совет дать, с чего
начать и в каком направлении двигаться...
Разве что первое: везде locale рухнуло или где-то работает, а где-то
нет? Если не везде - смотреть как собраны работающие и неработающие
приложения, возможно отличия наведут на мысль.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "setlocale в новом мире?" 
Сообщение от petr999 emailИскать по авторуВ закладки(??) on 16-Дек-05, 15:14  (MSK)
>я ответил что НЕТУ и все что есть - это можно найти
>в snapshot'е xorg'а
>>я уже давно нашёл svga развёртки, надо dri к нему, в частности,
>>drm-модуль ядра.
>попытаться разобраться в linux'овых модулях либо от dri.sf.net,
>либо от openchrome и портировать их под freebsd.

упс. проще может на 6.0-release перейти?

>>от бинарного апгрейда меняется libc, правильно?
>ну если были изменения, значит как произведен апгрейд - неважно.

тогда binary-upgrades ни при чём

>>где именно искать? в том и вопрос.
>truss, strace, ktrace - еще полезно логи cvsup'а иметь, сразу видно

c этим понятно куда копать хотя бы

>и приступил к мапированию через libmap.conf

а это где грамотно описано?

> Разве что первое: везде locale рухнуло или где-то работает, а где-то
>
>нет? Если не везде - смотреть как собраны работающие и неработающие
>приложения, возможно отличия наведут на мысль.

с 5.4->5.4 я понял, кажется, что надо perl пересобрать
с 5.4->6 единственное что работает --- cal. Ни ввод в консоли не работает, и в X нац. букв нету. locale показывает "C" невзирая на $LANG, даже кажется, на $LANG тявкает по ходу оперы:)

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "setlocale в новом мире?" 
Сообщение от lavr emailИскать по авторуВ закладки on 16-Дек-05, 16:23  (MSK)
>>я ответил что НЕТУ и все что есть - это можно найти
>>в snapshot'е xorg'а
>>>я уже давно нашёл svga развёртки, надо dri к нему, в частности,
>>>drm-модуль ядра.
>>попытаться разобраться в linux'овых модулях либо от dri.sf.net,
>>либо от openchrome и портировать их под freebsd.
>
>упс. проще может на 6.0-release перейти?

так а под каким релизом эксперименты проводились, как я понял под 6.x?

>>>от бинарного апгрейда меняется libc, правильно?
>>ну если были изменения, значит как произведен апгрейд - неважно.
>
>тогда binary-upgrades ни при чём

принципиально не причем, но бывает что неверно делают апгрейд через
cvsup:

- неверный tag используют
- неверно используют cvsup
- неверно производят сборку после cvsup
- не понимают что мир от одного релиза и ядро от другого, не только
не будут нормально работать, а вообще могут не работать, модули
от одного релиза не будут работать с ядром другого и тд и тп...

>>>где именно искать? в том и вопрос.
>>truss, strace, ktrace - еще полезно логи cvsup'а иметь, сразу видно
>
>c этим понятно куда копать хотя бы

мне казалось что я расписывал когда свою писульку про locale
писал при переходе 5.3/4 -> 6.0

>>и приступил к мапированию через libmap.conf
>
>а это где грамотно описано?

я читал man libmap.conf и смотрел примеры

>> Разве что первое: везде locale рухнуло или где-то работает, а где-то
>>
>>нет? Если не везде - смотреть как собраны работающие и неработающие
>>приложения, возможно отличия наведут на мысль.
>
>с 5.4->5.4 я понял, кажется, что надо perl пересобрать
>с 5.4->6 единственное что работает --- cal. Ни ввод в консоли не работает, и в X нац. букв нету. locale показывает "C" невзирая на $LANG, даже кажется, на $LANG тявкает по ходу оперы:)

# uname -rs
# echo $SHELL
# env
# ls -lA /lib
# ls -lA /usr/share/locale/

ну а дальше:

# ldd на пару тройку утилит у которых проблемы с locale

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

10. "Таможня даёт отбой (c)" 
Сообщение от petr999 emailИскать по авторуВ закладки(??) on 19-Дек-05, 10:26  (MSK)
Эрик-таки ответил:
===
The VIA driver isn't ported.                                                                                                
                                                                                                                             Also, never build the drm from the xc/ tree.  It is always stale and                                                        
never tested for actual building or usability.                                                                              
===
так что подождём пока. Или возьмём ядро линакса;)
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх


Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру