The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"помогите плиз с установкой acl на ext3"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"помогите плиз с установкой acl на ext3"
Сообщение от asipin emailИскать по авторуВ закладки on 28-Фев-04, 18:49  (MSK)
Появилась необходимость установить acl на сервере......
Решил проверить на своей машине (везде Slackware 9.0)
Заодно решил обновить ядро.... до 2.4.24
Взял ядро с kernel.org
Взял патч http://acl.bestbits.at/current/diff/ea+acl+nfsacl+sec-2.4.24-0.8.69.diff.gz
Установил.... Включил поддержку extended attributes и POSIX ACL в ядре...
Пересобрал ядро, так же как и на сервере будет.... Загрузил.
Linux version 2.4.24 (root@sipin) (gcc version 3.2.2) #1 SMP Fri Feb 27 18:48:23 MSK 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)
BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)
BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
511MB LOWMEM available.
found SMP MP-table at 000f58d0
hm, page 000f5000 reserved twice.
hm, page 000f6000 reserved twice.
hm, page 000f1000 reserved twice.
hm, page 000f2000 reserved twice.
On node 0 totalpages: 131056
zone(0): 4096 pages.
zone(1): 126960 pages.
zone(2): 0 pages.
ACPI: RSDP (v000 IntelR                                    ) @ 0x000f7380
ACPI: RSDT (v001 IntelR AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x1fff3000
ACPI: FADT (v001 IntelR AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x1fff3040
ACPI: MADT (v001 IntelR AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x1fff6e40
ACPI: DSDT (v001 INTELR AWRDACPI 0x00001000 MSFT 0x0100000c) @ 0x00000000
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 Pentium 4(tm) XEON(tm) APIC version 20
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] disabled)
ACPI: LAPIC_NMI (acpi_id[0x00] polarity[0x1] trigger[0x1] lint[0x1])
ACPI: LAPIC_NMI (acpi_id[0x00] polarity[0x1] trigger[0x1] lint[0x1])
Using ACPI for processor (LAPIC) configuration information
Intel MultiProcessor Specification v1.1
    Virtual Wire compatibility mode.
OEM ID: OEM00000 Product ID: PROD00000000 APIC at: 0xFEE00000
I/O APIC #2 Version 17 at 0xFEC00000.
Enabling APIC mode: Flat.       Using 1 I/O APICs
Processors: 1
Kernel command line: auto BOOT_IMAGE=test ro root=900 acpismp=force
Initializing CPU#0
Detected 2402.976 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 4797.23 BogoMIPS
Memory: 515848k/524224k available (1246k kernel code, 7992k reserved, 272k data, 288k init, 0k highmem)
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 512K
CPU: Hyper-Threading is disabled
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: bfebfbff 00000000 00000000 00000000
CPU:             Common caps: bfebfbff 00000000 00000000 00000000
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 512K
CPU: Hyper-Threading is disabled
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: bfebfbff 00000000 00000000 00000000
CPU:             Common caps: bfebfbff 00000000 00000000 00000000
CPU0: Intel(R) Pentium(R) 4 CPU 2.40GHz stepping 07
per-CPU timeslice cutoff: 1463.04 usecs.
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Error: only one processor found.
ENABLING IO-APIC IRQs
Setting 2 in the phys_id_present_map
...changing IO-APIC physical APIC ID to 2 ... ok.
init IO_APIC IRQs
IO-APIC (apicid-pin) 2-0, 2-5, 2-9, 2-10, 2-11, 2-12, 2-20, 2-21, 2-22 not connected.
..TIMER: vector=0x31 pin1=2 pin2=0
number of MP IRQ sources: 16.
number of IO-APIC #2 registers: 24.
testing the IO APIC.......................

IO APIC #2......
.... register #00: 02000000
.......    : physical APIC id: 02
.......    : Delivery Type: 0
.......    : LTS          : 0
.... register #01: 00178020
.......     : max redirection entries: 0017
.......     : PRQ implemented: 1
.......     : IO APIC version: 0020
.... register #02: 00000000
.......     : arbitration: 00
.... register #03: 00000001
.......     : Boot DT    : 1
.... IRQ redirection table:
NR Log Phy Mask Trig IRR Pol Stat Dest Deli Vect:
00 000 00  1    0    0   0   0    0    0    00
01 001 01  0    0    0   0   0    1    1    39
02 001 01  0    0    0   0   0    1    1    31
03 001 01  0    0    0   0   0    1    1    41
04 001 01  0    0    0   0   0    1    1    49
05 000 00  1    0    0   0   0    0    0    00
06 001 01  0    0    0   0   0    1    1    51
07 001 01  0    0    0   0   0    1    1    59
08 001 01  0    0    0   0   0    1    1    61
09 000 00  1    0    0   0   0    0    0    00
0a 000 00  1    0    0   0   0    0    0    00
0b 000 00  1    0    0   0   0    0    0    00
0c 000 00  1    0    0   0   0    0    0    00
0d 001 01  0    0    0   0   0    1    1    69
0e 001 01  0    0    0   0   0    1    1    71
0f 001 01  0    0    0   0   0    1    1    79
10 001 01  1    1    0   1   0    1    1    81
11 001 01  1    1    0   1   0    1    1    89
12 001 01  1    1    0   1   0    1    1    91
13 001 01  1    1    0   1   0    1    1    99
14 000 00  1    0    0   0   0    0    0    00
15 000 00  1    0    0   0   0    0    0    00
16 000 00  1    0    0   0   0    0    0    00
17 001 01  1    1    0   1   0    1    1    A1
IRQ to pin mappings:
IRQ0 -> 0:2
IRQ1 -> 0:1
IRQ3 -> 0:3
IRQ4 -> 0:4
IRQ5 -> 0:17
IRQ6 -> 0:6
IRQ7 -> 0:7
IRQ8 -> 0:8
IRQ9 -> 0:23
IRQ10 -> 0:19
IRQ11 -> 0:18
IRQ12 -> 0:16
IRQ13 -> 0:13
IRQ14 -> 0:14
IRQ15 -> 0:15
.................................... done.
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 2402.8775 MHz.
..... host bus clock speed is 133.4929 MHz.
cpu: 0, clocks: 1334929, slice: 667464
CPU0<T0:1334928,T1:667456,D:8,S:667464,C:1334929>
Waiting on wait_init_idle (map = 0x0)
All processors have done init_idle
PCI: PCI BIOS revision 2.10 entry at 0xfb240, last bus=2
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Ignoring BAR0-3 of IDE controller 00:1f.1
Transparent bridge - Intel Corp. 82801BA/CA/DB/EB PCI Bridge
PCI: Using IRQ router PIIX/ICH [8086/24c0] at 00:1f.0
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
Journalled Block Device driver loaded
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
loop: loaded (max 8 devices)
tg3.c:v2.3 (November 5, 2003)
eth0: Tigon3 [partno(BCM95702A20) rev 1002 PHY(5703)] (PCI:33MHz:32-bit) 10/100/1000BaseT Ethernet 00:50:8d:49:da:fb
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH4: IDE controller at PCI slot 00:1f.1
ICH4: chipset revision 2
ICH4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:pio
hda: ST380011A, ATA DISK drive
blk: queue c031f820, I/O limit 4095Mb (mask 0xffffffff)
hdc: ST380011A, ATA DISK drive
blk: queue c031fc8c, I/O limit 4095Mb (mask 0xffffffff)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 156301488 sectors (80026 MB) w/2048KiB Cache, CHS=9729/255/63, UDMA(100)
hdc: attached ide-disk driver.
hdc: host protected area => 1
hdc: 156301488 sectors (80026 MB) w/2048KiB Cache, CHS=9729/255/63, UDMA(100)
Partition check:
hda: hda1 hda2 hda3 hda4
hdc: hdc1 hdc2 hdc3 hdc4
Guestimating sector 156280064 for superblock
Guestimating sector 156280064 for superblock
driver for Silicon Image(tm) Medley(tm) hardware version 0.0.1: No raid array found
md: raid1 personality registered as nr 3
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
[events: 0000007d]
[events: 00000077]
[events: 00000077]
[events: 00000077]
[events: 0000007d]
[events: 00000077]
[events: 00000077]
[events: 00000077]
md: autorun ...
md: considering hdc4 ...
md:  adding hdc4 ...
md:  adding hda4 ...
md: created md3
md: bind<hda4,1>
md: bind<hdc4,2>
md: running: <hdc4><hda4>
md: hdc4's event counter: 00000077
md: hda4's event counter: 00000077
md: RAID level 1 does not need chunksize! Continuing anyway.
md3: max total readahead window set to 124k
md3: 1 data-disks, max readahead per data-disk: 124k
raid1: device hdc4 operational as mirror 1
raid1: device hda4 operational as mirror 0
raid1: raid set md3 active with 2 out of 2 mirrors
md: updating md3 RAID superblock on device
md: hdc4 [events: 00000078]<6>(write) hdc4's sb offset: 72774336
md: hda4 [events: 00000078]<6>(write) hda4's sb offset: 72774336
md: considering hdc3 ...
md:  adding hdc3 ...
md:  adding hda3 ...
md: created md2
md: bind<hda3,1>
md: bind<hdc3,2>
md: running: <hdc3><hda3>
md: hdc3's event counter: 00000077
md: hda3's event counter: 00000077
md: RAID level 1 does not need chunksize! Continuing anyway.
md2: max total readahead window set to 124k
md2: 1 data-disks, max readahead per data-disk: 124k
raid1: device hdc3 operational as mirror 1
raid1: device hda3 operational as mirror 0
raid1: raid set md2 active with 2 out of 2 mirrors
md: updating md2 RAID superblock on device
md: hdc3 [events: 00000078]<6>(write) hdc3's sb offset: 2441792
md: hda3 [events: 00000078]<6>(write) hda3's sb offset: 2441792
md: considering hdc2 ...
md:  adding hdc2 ...
md:  adding hda2 ...
md: created md1
md: bind<hda2,1>
md: bind<hdc2,2>
md: running: <hdc2><hda2>
md: hdc2's event counter: 00000077
md: hda2's event counter: 00000077
md: RAID level 1 does not need chunksize! Continuing anyway.
md1: max total readahead window set to 124k
md1: 1 data-disks, max readahead per data-disk: 124k
raid1: device hdc2 operational as mirror 1
raid1: device hda2 operational as mirror 0
raid1: raid set md1 active with 2 out of 2 mirrors
md: updating md1 RAID superblock on device
md: hdc2 [events: 00000078]<6>(write) hdc2's sb offset: 489856
md: hda2 [events: 00000078]<6>(write) hda2's sb offset: 489856
md: considering hdc1 ...
md:  adding hdc1 ...
md:  adding hda1 ...
md: created md0
md: bind<hda1,1>
md: bind<hdc1,2>
md: running: <hdc1><hda1>
md: hdc1's event counter: 0000007d
md: hda1's event counter: 0000007d
md: RAID level 1 does not need chunksize! Continuing anyway.
md0: max total readahead window set to 124k
md0: 1 data-disks, max readahead per data-disk: 124k
raid1: device hdc1 operational as mirror 1
raid1: device hda1 operational as mirror 0
raid1: raid set md0 active with 2 out of 2 mirrors
md: updating md0 RAID superblock on device
md: hdc1 [events: 0000007e]<6>(write) hdc1's sb offset: 2441728
md: hda1 [events: 0000007e]<6>(write) hda1's sb offset: 2441728
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 32768)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 288k freed
Adding Swap: 489848k swap-space (priority -1)
EXT3 FS 2.4-0.9.19, 19 August 2002 on md(9,0), internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on md(9,2), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on md(9,3), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
tg3: eth0: Link is up at 100 Mbps, full duplex.
tg3: eth0: Flow control is on for TX and on for RX.

Такая вот загогулина вышла.

Далее ... слил пакет acl-1.1.3 откомпилировал, установил.
Установил.....
Перемонтировал корень с ext3 с поддержкой acl
mount -o acl,remount /

создал каталог q2 в нем каталог test
Выдаю комманду
getfacl test
получаю
# file: test
# owner: root
# group: root


Но должна быть еще информация о правах.... хотя бы о текущих...
Ладно, думаю ,может у каталога еще нет никаких acl , пытаюсь установить....

setfacl -s u:saa:rwx ./test
получаю
setfacl: ./test: Resulting ACL `user:saa:rwx,mask::rwx': Missing or wrong entry at entry 1

Ясно, что acl не работает....
Может есть какие либо пподводные камни, кто сталкивался и ставил acl на ext3 подскажите, пожалуйста....

PS на XFS ставил ACL без проблем..... Но не могу перейти на этом сервере на XFS.... Максимум, что могу - перезагрузить его  т.е 2 минуты неработоспособности....
Да и не нужен мне тут xfs////
Всем заранее спасибо.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "помогите плиз с установкой acl на ext3"
Сообщение от asipin emailИскать по авторуВ закладки on 29-Фев-04, 12:19  (MSK)
Уже сам разобрался....
Дело в 2 весчах
при установке пакета attr (make install install-lib) в /usr/include/attr не копируется ./attr/include....
Копируем вручную......
2.
Библиотека libacl.so ложится не в /lib/ а в /usr/lib.... Вот и не работало....
Блин, надо было сразу голову применить, а не потом :)
  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "помогите плиз с установкой acl на ext3"
Сообщение от Евгений emailИскать по авторуВ закладки(??) on 09-Дек-04, 19:02  (MSK)
>Уже сам разобрался....
>Дело в 2 весчах
>при установке пакета attr (make install install-lib) в /usr/include/attr не копируется ./attr/include....
>
>Копируем вручную......
>2.
>Библиотека libacl.so ложится не в /lib/ а в /usr/lib.... Вот и не
>работало....
>Блин, надо было сразу голову применить, а не потом :)
То же самое пишет, хотя в ядре поддержка включена, все библиотеки на месте вродь и раздел смонтирован с acl. :(
  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру